3PAR StoreServ Storage
cancel
Showing results for 
Search instead for 
Did you mean: 

StoreServ Simulator 3paradm user can't do many things

 
Highlighted
Pebble1
Occasional Visitor

StoreServ Simulator 3paradm user can't do many things

Hi,

    I'm new to 3par and trying to use the simulator to get the "wsapi" running.

I've followed the setup instructions.  That seems to go ok.  Although...it does complain about the odd thing as you go through.

I can get SSMC to connect using the 3paradm account.

But I cannot set the wsapi to enabled:

I get the following message as part of the error:

05-Apr-2019 12:12:38 o'clock BST Created
05-Apr-2019 12:12:38 o'clock BST Start user operation
05-Apr-2019 12:12:38 o'clock BST Executing setsys operation on the array
05-Apr-2019 12:12:38 o'clock BST Executing startwsapi operation on the array
05-Apr-2019 12:12:43 o'clock BST 2FF70002AC01855F : Could not update wsapi table.
05-Apr-2019 12:12:43 o'clock BST Checking for object to update in the cache
05-Apr-2019 12:12:43 o'clock BST Failed: Error updating system StoreServ2

If I try and log on via the command line I get the same "Could not update wsapi table" when I run startwsapi.

I did manage to have permission to run the shutdown command though.  Which is better than yesterdays attempt where it could not even do that.

Any suggestions for getting permissions for 3paradm in the simulator to start the wsapi?

Thanks

5 REPLIES 5
Highlighted
Pebble1
Occasional Visitor

Re: StoreServ Simulator 3paradm user can't do many things

And after shutting everything down, and restarting them as per the instructions.  Now SSMC cannot connect to the simulator.

On the CLI for the nodes I keep getting "linux_nemoe_get_env: NEMOE device open failed"

Any ideas on if that's my issue and how to resolve it?

Highlighted
rmay_bk
Frequent Advisor

Re: StoreServ Simulator 3paradm user can't do many things

I've heard that people successfully use it for tech demos and I'm amazed.  It was a beast to get it running and I can't seem to keep it running any longer than one or two restarts.  I gave up on it a long time ago.

Highlighted
Pebble1
Occasional Visitor

Re: StoreServ Simulator 3paradm user can't do many things

Thanks for the reply.  Apart from that one brief glimpse of success.  I've failed to get it to work.  I just started from scratch, exactly the same options chosen.  It's not even responding to ping.

Problem I've got is wanting to try out interrogating the wsapi, without having any 3par hardware to play with...  This seemed ideal but... 2 days wasted and back to square 1 I guess.

Highlighted
veeyarvi
HPE Pro

Re: StoreServ Simulator 3paradm user can't do many things

Hello Pebble1,

Please send an email to 3parsimsupport@hpe.com for support on 3PAR simulators since a complete reinstallation did not help in your case.


I am an HPE Employee
Accept or Kudo
Highlighted
Pebble1
Occasional Visitor

Re: StoreServ Simulator 3paradm user can't do many things

Hey, thanks for the e-mail address.

To follow up on this.  In detailing what I was doing to send an e-mail.  I found a way to get the simulator working.

Once you get to the end of the instructions.  SSMC will not connect and you can't ping the IP address given in the OOTB setup.

Suspend the node0 VM in workstation for a few seconds.  Then set it running again.  This causes it to "freak out", and it restarts, reconnects with node1 and after a few minutes of lots of seemingly bad messages, the IP address will start responding to ping and SSMC will connect.

The 2nd time through this process, the 3paradm user did have permission to turn on the wsapi in SSMC.

I have not dared turn off the VMs to see if this is a repeatble process.