Application Integration
cancel
Showing results for 
Search instead for 
Did you mean: 

Powershell Module - only partial functions work in V1 and V2

SOLVED
Go to solution
linkall78
Occasional Visitor

Powershell Module - only partial functions work in V1 and V2

We have a Nimble Storage, software version: 2.2.8.0-252438-opt. We tried to use powershell module GitHub - jrich523/NimblePowerShell: Nimble PowerShell Module to automate the process to create a volume from a snapshot, then we found that some functions (snapshot related, such as Get-NSSnapshot) work for V1 (master branch), but do not work for V2; and some functions (volume related, such as New-NSvolume) work for V2, but do not work for V1. Is there a quick way to fix it?

2016-04-19_1253.png

Thank you,

Victor

5 REPLIES
jcates98
Trusted Contributor

Re: Powershell Module - only partial functions work in V1 and V2

Hi Victor,

While I can't help you out with Mr. Rich's PS module, I can certainly help you with PowerShell scripts to automate creating a new volume from a snapshot of an existing volume.  The attached examples make use of the Nimble REST API - note that you are going to need to be on Nimble OS 2.3 or greater.

I'm attaching two files here.  The first is a simplified example where you are presenting the cloned volume back to the same host(s) that the original volume is presented to.  The second script takes an additional argument of an initiator group name that you'd like the newly created volume to be presented to.  It removes the original initiator group mapping and then maps it to the initiator group you specify.

Cheers!

Julian

linkall78
Occasional Visitor

Re: Powershell Module - only partial functions work in V1 and V2

Thank you, Julian! We definitely will try this API method after we upgrade our Nimble OS to 2.3.

At the meantime, has anyone a idea to make the current PS module works with Nimble OS 2.2.8.0-252438-opt?

Thanks,

Victor

linkall78
Occasional Visitor

Re: Powershell Module - only partial functions work in V1 and V2

Nimble just released "Nimble PowerShell Toolkit NPT"

NPT.png

I have a few questions about it:

1. It says support Array versions

o Casablanca

o Daytona

what's the version number for those?

2. When we tried to connect to a array using Connect-NsGroup command, we got following error:

Get-Certificate : Failed to get website certificate. The error was 'Exception calling "GetResponse" with "0" argument(s): "Unable to connect to the remote server"'.

any help would be appreciated!

Victor

jcates98
Trusted Contributor
Solution

Re: Powershell Module - only partial functions work in V1 and V2

Hi Victor,

The Nimble toolkit requires a NimbleOS version of 2.3.x or greater, as it's built on the REST API. I suspect that this is the cause of your error, as you are running 2.2.x, yeah?

Stay tuned for an updated readme along with a blog post that covers this new PS toolkit.

Cheers,

Julian

linkall78
Occasional Visitor

Re: Powershell Module - only partial functions work in V1 and V2

Hi Julian,

You are right, we have the other Nimble which is 2.3.x, and Connect-NsGroup of Nimble PowerShell Toolkit works fine to connect to it.

Thank you,

Victor