Array Setup and Networking

LVM Cannot Activate showing duplicate path already active

 
masoodasif1
Occasional Visitor

LVM Cannot Activate showing duplicate path already active

Dear Team,

I am configuring a new Setup of Nimble with 3 SUSE SLE15 SP2 setup.

we are using dedicated ISCSI ports for the DATA network 

I have created Logical volume using /dev/nimblestorage/diskxxxUUID but when the server is rebooting it is not mounting the filesystem. I have created 3 LUNS from the nimble site and create 3 separate VGs on them.

while reboot only one of them (randomly) activates and other won't activate on the startup I saw the service log and found out that the VG which activate 1st also claim other volumes device paths and other wont activate with the following error.

Cannot activate LVs in VG vghanalog while PVs appear on duplicate devices.

however, once the server is up I am able to activate it manually.

i have tried creating filesystem without using LVM and that is working fine with me without any issues seems like something to do with multipathing 

 

Thanks 

Regards 

Masood Asif

3 REPLIES 3
Nick_Dyer
Honored Contributor

Re: LVM Cannot Activate showing duplicate path already active

Hi,

This has been appropriately answered on another forum. The outcome is: any time you need assistance with anything - please contact Nimble Support.

Nick Dyer
twitter: @nick_dyer_
masoodasif1
Occasional Visitor

Re: LVM Cannot Activate showing duplicate path already active

Dear Nick,

 

Already opened the support case and its talking time from them so was trying my luck here if someone faced the same issue

 

thanks 

Masood Asif

Nick_Dyer
Honored Contributor

Re: LVM Cannot Activate showing duplicate path already active

If you email Nimble Support, the turnaround is set to ~24 hours, as an email by definition isn't important.

If it is important, please call them using your local rate number.

Nick Dyer
twitter: @nick_dyer_