Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

5406zl unable to update to firmware k.15.xx

 
One234
Occasional Advisor

5406zl unable to update to firmware k.15.xx

Hello All,

 

I have a very old 5406zl (J8697A) that still had firmware version 11.11 on it. I'm currently trying to upgrade the firmware to version K.15.13.0005. But as soon as I install a K.15 firmware version the system just hangs after the Decompressing...done. message. I tried all the K.15 firmware versions I could find, but all have the same problem. As soon as a K.15 firmware version is installed the switch hangs after it decompressed the firmware. A power cycle doesn't help either. And all the LEDs stay on...

 

I followed the following steps to upgrade the firmware to version K.15.13.0005

 

- Upgrade to version K.12.62 - Reboot - No problems found

- Upgrade to version K.13.68 - Reboot - No problems found

- Upgrade to version K.15.13.0005 - Reboot - System Hangs after decompress message

- Power cycle the switch - same problem

- Loaded K.13.68 from secondairy flash - No problems

- Tried all other K.15 versions - All give the same problem. System hangs after decompress message

- Upgrade to version K.14.92 - Reboot - No problems found

- Tried to upgrade to a K.15 version - Same problem - System hangs after decompress message

 

Below is a printout of a K.15 version boot:

 

IS2S0123
ROM information:
   Build directory: /ws/swbuildm/btmrom_t5b_qaoff/rom/build/btmrom(btmrom_t5b_qaoff)
   Build date:      Nov 12 2012
   Build time:      13:42:32
   Build version:   K.15.30
   Build number:    11194



Boot Profiles:

0. Monitor ROM Console
1. Primary firmware image   [K.15.10.0022]
2. Secondary firmware image [K.13.68     ]

Select profile (primary): 


Booting Primary firmware image...

Decompressing...done.

And that's it... Nothing more, nothing less...

 

I hope someone can help me with this problem because we need K.15 for the new 10/100/1000 v2 modules...

 

Thank you in advance.

 

Marc D.

 

9 REPLIES 9
Pete W
Valued Contributor

Re: 5406zl unable to update to firmware k.15.xx

If you can safely boot off K.14.92 in the primary flash, then try putting a K15 image in secondary flash and booting off that.

 

Pete

One234
Occasional Advisor

Re: 5406zl unable to update to firmware k.15.xx

Hi Pete,

 

Thank you for your reply. I will try that today or tomorrow.

 

Best regards,

 

Marc

One234
Occasional Advisor

Re: 5406zl unable to update to firmware k.15.xx

Hi,

 

I just tried using the secondairy flash to boot the K.15.13.0005 firmware and it's having the same problem. After the reboot or power cycle it just stops after the Decompressing...done message...

 

Is there somewhere else I can have a look to see way the switch just stops booting with any version of the K.15 firmware?

 

IS2S0123
ROM information:
   Build directory: /ws/swbuildm/btmrom_t5b_qaoff/rom/build/btmrom(btmrom_t5b_qaoff)
   Build date:      Nov 12 2012
   Build time:      13:42:32
   Build version:   K.15.30
   Build number:    11194



Boot Profiles:

0. Monitor ROM Console
1. Primary firmware image   [K.13.68     ]
2. Secondary firmware image [K.15.13.0005]

Select profile (secondary): 


Booting Secondary firmware image...

Decompressing...done.

 

Pete W
Valued Contributor

Re: 5406zl unable to update to firmware k.15.xx

Interesting - it's not often that I see this kind of issue. How about ...

  • Remove all modules and attempt the same boot into K15.
  • Factory reset the unit and try again
  • Log a call with HP - could be dodgy flash

 

Really not sure what else it could be.

 

Regards,

 

Pete

One234
Occasional Advisor

Re: 5406zl unable to update to firmware k.15.xx

Hi Pete,

 

Thanks again for your reply.

 

There are currently no modules in the 5406zl, so I skipped that step :-) We want to use the new 10/100/1000 v2 modules and they need K.15+ firmware :-( So at the moment it's just the "case" with the control module J8726a.

 

I tried to factory default the switch with the erase startup and with the reset/clear pins. Same issue.

 

I think I will need to log a case with HP to solve this issue.

 

Thanks again for your help!

 

Best regards,

 

Marc

 

 

adiez
Occasional Visitor

Re: 5406zl unable to update to firmware k.15.xx

Hi,

I have had the same problem with K18.08.0014 firmware version (ROM K.15.28) . I have changed the control module (j8726A) and the compat flash which contain k.15.15.0012 version firmware (ROM K.15.30) but it is same.

You found a solution?

 

 Best regards,

Ana.

parnassus
Honored Contributor

Re: 5406zl unable to update to firmware k.15.xx

Better to start another fresh new Thread and there describe exactly what is your issue.

It's unclear what version your HPE 5400 zl is actually running and what version you will need (just a correction: K.18.08.0014 doesn't exist...probably you were referring to K.15.08.0014 of 2012).

Did you followed the upgrading instructions available on the Aruba "Best practices for software updates" section (start on page 139 to be sure) of the HPE ArubaOS-Switch Basic Operations Guide Version 16.02?

If your Switch is running the K.15.08.0014 with a BootROM K.15.28 (so with a BootROM newer than BootROM K.12.17) you should be able to upgrade directly into K.15.15.0013 (with BootROM K.15.30) or K.16.01.0008 or the very latest K.16.02.0010 (both use BootROM K.15.30).

One234
Occasional Advisor

Re: 5406zl unable to update to firmware k.15.xx

I agree that it is better to start a new thread. But the solution to my problem was replacing the board. I called HP and they replaced the board.

adiez
Occasional Visitor

Re: 5406zl unable to update to firmware k.15.xx

I'm Sorry, the firmware was K15.08.0014 .

Thank you, I'll start another thread if I can't resolve it with K.15.15.0013 version.