Aruba & ProVision-based

Re: 6600ml - SFP+ ports won't come up (repost to a more appropriate forum)

Occasional Contributor

6600ml - SFP+ ports won't come up (repost to a more appropriate forum)

Good evening!

I've got a 6600ml I inherited, and I'm trying to uplink it to a pair of Cisco 6248 fabric interconnects. I can't get the ports on the 6600 to come up to save my life! Anyone have suggestions for me? Here's the skinny...

I've got a pair of twinax SFP+ cables between each 6248 and the SFP+ ports on the 6600 (ports 49-52). Solidly clicked/locked into place on installation on both sides.

On the Cisco side there's not much to configure (and the configuration was done with a Cisco engineer from Cisco proper on the line).

On the 6600, I ran the following to create the LACP trunk: "trunk 49-52 Trk1 lacp". Afterwards I ran a "show lacp" which produced the following configuration output:

HP-6600ml-48G-4XG# show lacp


LACP Trunk Port LACP Admin Oper
Port Enabled Group Status Partner Status Key Key
----- ------- ------- ------- ------- ------- ------ ------
49 Active Trk1 Down No Success 0 290
50 Active Trk1 Down No Success 0 290
51 Active Trk1 Down No Success 0 290
52 Active Trk1 Down No Success 0 290

A quick run of show trunk yields the following (I named the ports through the webGUI at some point):

HP-6600ml-48G-4XG# show trunk

Load Balancing Method: L3-based (default)

Port | Name Type | Group Type
---- + -------------------------------- ---------- + ------ --------
49 | HyperFlex-FI-A_Uplink | Trk1 LACP
50 | HyperFlex-FI-A_Uplink | Trk1 LACP
51 | HyperFlex-FI-B_Uplink | Trk1 LACP
52 | HyperFlex-FI-B_Uplink | Trk1 LACP

Any ideas what I'm missing here? I unfortunately don't have physical access to this datacenter anymore, so really hoping I can get it to fly with a bit of your gracious help.



Ian Vaughan
Honored Contributor

Re: 6600ml - SFP+ ports won't come up (repost to a more appropriate forum)


Which DAC / Twinax SFP+ cables did you use to do your wiring between the 6600 and the Cisco tin?

The Provision switches are very particular about which modules you plug into them. Unless they are the officially supported ones often* they just don't work. Are there any messages in the switch log relating to unsupported transceivers or suchlike?

* - I believe the latest 16.x code has opened up the possibility of using "foreign" transcievers and just giving a warning just like on the Comware platforms. Maybe someone can confirm if this is the case.

Unfortunately I don't think that you can uplift your switch to a version of software (greater than 15.x) that will let you use those transcievers if they are indeed third party ones.

Most of the time folks find themselves going down the (more expensive) route of putting officially supported SFP+ modules into each vendors equipment and using a fibre to join them up. :-(

If the Cisco switches don't mind a foreign DAC and will just "moan" about it with an SNMP message that can be suppressed, sourcing the official HPE DACs might be the cheapest solution. You may even have some that came with the original 6600 switch purchase, it might be worth a look.

Best of luck - let us know what you find and how you get on.

Many thanks


Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Tweets: @2techie4me
Honored Contributor

Re: 6600ml - SFP+ ports won't come up (repost to a more appropriate forum)

Are you distributing/spanning the LACP ports (LAGs formed by ports 49, 50, 51 and 52 on the HP 6600-48G-4XG Switch (J9452A)) partially - links from ports 49 and 50 - on first Cisco 6248 Switch and partially - links from ports 51 and 52 - on second Cisco 6248 Switch or the whole HP LAG is terminated on a corresponding LAG on only one Cisco 6248 Switch?

If the scenario is the first one then you need to have both Cisco 6248 configured with sort of VSS (to form a Virtual Switch) in order to avoid to be forced to work with Distributed LACP (dt-lacp), in other words if you deliberatly span your HP LAG links to two separate Cisco Switches (not interconnected together to form a VSS) then you must use Distributed Trunking (dt-lacp)...and I don't know if the HP DT is compatible with a possible Cisco DT.

If the scenario is the second one - no VSS but all HP LAG links go to one and only one Cisco Switch - then you need to be sure that LACP settings are the same on both ends (HP and Cisco), on all involved 4 ports per side.

Clearly the last verifying step above should come after the very first mandatory one: be sure to use genuine SFP+ Transceivers on both ends (HP and Cisco) and be sure to have fulfilled the requirments (and restrictions) to correctly form a LAG on HP and a LAG on the Cisco.

Unfortunately no K.16.xx Software (it's still the old ProVision, your latest one is K.15.18.0012 July 2016) branch was ever released for your HP 6600-48G-4XG Switch (J9452A) so - if your HP Switch is equipped with non genuine SFP+ Transceivers - you can't benefit from this update: Upcoming ArubaOS-Switch release to enable use of third-party transceivers and DACS where upcoming means Software versions starting with ArubaOS-Switch 16.02.

I'm not an HPE Employee
Kudos and Accepted Solution banner
Occasional Contributor

Re: 6600ml - SFP+ ports won't come up (repost to a more appropriate forum)

Thanks for the response Ian!

I think you're probably on to something there, especially given some of the diagnostic output I get:

HP-6600ml-48G-4XG# show interfaces transceiver

Transceiver Technical Information:

Product Serial Part
Port Type Number Number Number
------- ----------- ------------ ------------------ ----------
49 ?? ?? unsupported
50 ?? ?? unsupported
51 ?? ?? unsupported
52 ?? ?? unsupported

The following transceivers have extra information:
Port # Message
-------- -------------------------------------
Port 49 Transceiver type not supported in this port.
Port 50 Transceiver type not supported in this port.
Port 51 Transceiver type not supported in this port.
Port 52 Transceiver type not supported in this port.

Looks like I'll need to go fishing for either a new switch or some 'certified' transceivers and fiber cables to fix this mess up.

Thanks again for the response and the welcome!