Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

AP-365 rebooting constantly

 
tnicola
Occasional Visitor

AP-365 rebooting constantly

I have an outdoor 365 AP. It is constantly rebooting. I am able to log into it and pull logs (shown below). It is not joining the Airwave cluster. I am guessing that is because the image might be incorrect (6.5.4.3) . I have multiple 325 APs on my network running 6.4.4.4 and they didn't have issues joining nor rebooting. Any insight would be appreciated.

 


Jul 24 18:26:54 radiusd[2633]: Loaded virtual server <default>
Jul 24 18:26:54 radiusd-term[2634]: Ready to process requests.
Jul 24 18:26:54 radiusd[2633]: Ready to process requests.
Jul 24 18:26:54 cli[2412]: <341135> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| Master Changed - new 10.72.72.98 old 0.0.0.0 current swarm state 1.
Jul 24 18:26:57 cli[2412]: _send_auth_server_message_only
Jul 24 18:26:57 cli[2412]: <341011> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| AP image version mismatch 40 6.4.4.4-4.2.3.0_54225 48
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| AP image mismatch, turn off master election
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| Slave_start_sync
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| Amp_send_request
Jul 24 18:26:57 awc[2409]: awc_init_connection: 2233: connecting to 172.16.12.16:443
Jul 24 18:26:57 awc[2409]: tcp_connect: 168: recv timeout set to 5
Jul 24 18:26:57 awc[2409]: tcp_connect: 175: send timeout set to 5
Jul 24 18:26:57 awc[2409]: awc_init_connection: 2275: connected to 172.16.12.16:443
Jul 24 18:26:57 awc[2409]: awc_init_connection: 2416: Connected
Jul 24 18:26:57 awc[2409]: amp_image_request: 3603: Sent header 'POST /swarm HTTP/1.1^M Host: 172.16.12.16^M Content-Length: 0^M X-Type: image-url-req^M X-Guid: 70daa731014c84ae595af75acbcd7ade44b1a4398e134e0a65^M X-Shared-Secret: XXXXXXXXXX^M X-OEM-Tag: Aruba^M X-Current-Version: 6.5.4.3-6.5.4.3_61959^M X-Desired-Version: 6.4.4.4-4.2.3.0_54225^M X-Organization: HWY290-CLUSTER^M X-Ap-Info: CNGVJSW344,48^M ^M '
Jul 24 18:26:57 awc[2409]: Message over SSL from 172.16.12.16, SSL_read() returned 130, errstr=Success, Message is "HTTP/1.1 200 OK^M X-Manage-Mode: monitor^M Cookie: 4dd5c83c2514cd99522904e0233b24b1^M X-Command: image-upgrade^M Content-Length: 0^M ^M ", AWC response: (null)
Jul 24 18:26:57 awc[2409]: firmware sync from airwave
Jul 24 18:26:57 awc[2409]: the url from amp server is:
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| AMP is available
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| Get real response from the AMP.
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| awc_image_sync:
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| swarm_url_valid: input url is NULL
Jul 24 18:26:57 cli[2412]: <341004> <WARN> |AP 90:4c:81:c4:ac:10@10.72.73.145 cli| download_image_url: url is invalid
Jul 24 18:26:58 KERNEL(90:4c:81:c4:ac:10@10.72.73.145): [ 128.664473] (18:26:58) !!! Init ---> Slave
Jul 24 18:27:04 nanny[2337]: <303074> <ERRS> |AP 90:4c:81:c4:ac:10@10.72.73.145 nanny| Process /aruba/bin/rngd [pid 2453] died: exited with 0x0
Jul 24 18:27:04 nanny[2337]: <303076> <ERRS> |AP 90:4c:81:c4:ac:10@10.72.73.145 nanny| Non re-startable process /aruba/bin/rngd [pid 2453] has terminated

2 REPLIES 2
tnicola
Occasional Visitor

Re: AP-365 rebooting constantly

Reading log it appears that I need a different image. Would the 6.4.4.4 image work on this 365? 

Re: AP-365 rebooting constantly

Hello, 

This question seems to be related to Aruba Instant AP 365. Please note that questions related to Aruba wireless products should be asked in the Airheads Community https://community.arubanetworks.com/

The chance of getting a proper answer there is much higher. The HPE community handles only the legacy wireless products before Aruba was aquired.

From what I see you have currently a cluster which is running the version 6.4.4. You are trying to add an IAP 365 with version 6.5.x. The IAP 365 cannot join the cluster because the version of the cluster is lower than its own version. Here is what the manual says.

Each IAP model has a minimum required version as shown in Table 3. When a new IAP is added into an
existing cluster, it can join the cluster only if the existing cluster is running at least the minimum required
version of that AP. If the existing cluster is running a version below the minimum required version of the new
AP, new AP will not come up and may reboot with the reason Image sync fail. To recover from this
condition, upgrade the existing cluster to at least the minimum required version of the new AP first, and add
the new AP.

 

Checking the data sheet of the 360 series APs we can see

https://www.arubanetworks.com/assets/ds/DS_AP360Series.pdf

page 4

Minimum operating system software version: Unified ArubaOS and Instant OS 6.5.2.0 and 8.2.0.

That means that the 360 series cannot run version 6.4.4.4. 

SInce AP 325 seems to support 6.5.x.x versions I guess you have to follow the recommendation of the manual the upgrade the existing cluster. 

 

I am an HPE employee

Accept or Kudo