Aruba & ProVision-based

Alcatel to Aruba

 
Yolonero
Visitor

Alcatel to Aruba

Greetings,

 

I'm trying to replace an old Alcatel with a new Aruba 2930 and I'm struggling to make the VoIP works. So far, I was used to "modern" VoIP configurations ("voice" vlan, tagged and that's it), however it seems that it doesn't work like this here. Someone that worked on it before told me that "I have to enable LLDP", which I did but still nothing. The only way for the phones to work is to "untag" the port, which isn't the goal since we need to make the data go through the phone aswell.

 

Can someone spot where I did wrong ? I'm linking the Alcatel and the Aruba configuration

Alcatel : https://pastebin.com/HZT30CyD

Aruba : https://pastebin.com/yYQntjFS

Thanks in advance

9 REPLIES 9
Stan_N
Occasional Visitor

Re: Alcatel to Aruba

Hi Yolonero,

You can confitgure/mark your vlan as a "voice" vlan. For example:

vlan 100

voice

"Labels this VLAN as a Voice VLAN, allowing you to separate, prioritize, and authenticate voice traffic moving through your network."

Please refer to the following document for a similar configuration:

https://support.hpe.com/hpesc/public/docDisplay?docId=emr_na-c03386522

Regards

Stanislav

Yolonero
Visitor

Re: Alcatel to Aruba

Hi,

I already tried it but nothing happens. (it is on the config file linked previously)

vlan 100
name "voice"
untagged 1,47-48
tagged 2-46
ip address 172.16.1.25 255.255.255.0
ip helper-address 172.16.1.254
qos dscp 46
voice
exit

It's as if the phone doesn't know what VLAN to get and only chose the "untagged" one 

 

 

parnassus
Honored Contributor

Re: Alcatel to Aruba

Hi! Alcatel pastebin can't be seen...

If I look at Arbua pastebin I noticed:

  1. Software version too old
  2. VLAN memberships a little bit strange considering you want to connect VoIP Phones on ports with a Voice tagged VLAN ID and a Data untagged VLAN ID:

You pasted:

 

vlan 1
name "LAN"
no untagged 1-40,47-48
untagged 41-46,49-52
ip address 192.168.2.15 255.255.255.0
exit
vlan 100
name "voice"
untagged 1,47-48
tagged 2-46
ip address 172.16.1.25 255.255.255.0
ip helper-address 172.16.1.254
qos dscp 46
voice
exit

 

so VLAN 1 is removed from ports 1-40 and 47-48...if removing VLAN 1 from 47-48 can be reasonable (maybe those ports are used for uplinking and you don't want to transport VLAN 1...then it looks strange, it looks also strange you configured 1-40 as no untagged (orphaned) of VLAN 1...which should be - my assumption - your Data dedicated VLAN ID.

VLAN 100 was set untagged on 1, 47-48 and declared Voice...and set tagged on 2-46...bah.

Let's try this on ports dedicated to access (Data+Voice): supposing ports 1-46 are for access (hosts and/or phones)...then ports 1-46 should be untagged members of Data VLAN 1 and tagged member of Voice VLAN 100....uplink ports then should transport - I believe - both VLAN 1 and VLAN 100...how (untagged/tagged) depends on your network infrastructure (uplink peer switch).

It's just a start (or a re-start).


I'm not an HPE Employee
Kudos and Accepted Solution banner
Yolonero
Visitor

Re: Alcatel to Aruba

Hi,

I see that pastabin removed the Alcatel one for some reasons, I'm going to post it at the end here directly.

My apologies I forgot to give some context : you can ignore the VLAN 1 that I removedconsider that in the end, all the ports EXCEPT THE LAST 2 ports (47,48, like how it is done on the Alcatel) will be "untag VLAN1, tag VLAN100". It was to make some tests without cutting the phone, currently working on the old Alcatel, and without making any loops with the LAN. (currently, the Alcated (port 13 if I remember correctly is connected to the port 10 of the Aruba to be able to test it before switching anything)

When my tests failed, I had the VLAN 1 untagged and the VLAN 100 tagged (with "voice" and everything that goes with it), and for some reasons I decided to untag the VLAN 100 to check and it worked. That's why I making this post here since I don't understand why the phones doesn't retrieve the tagged VLAN.

Note : unfortunatly I can't really use the "let's dedicate some port for the voice and some for the LAN" because we wont have enough port left. It has to be one link only with both VLAN.

I'll go check for the software version

 

Here's the Alcatel config :

 

 

aaa authentication telnet local
aaa authentication ftp local
aaa authentication ssh local
aaa authentication http local
http server
http ssl
https server
https ssl
!
vlan 100 enable name voice

!
ip interface INT100 address 172.16.1.251/24 vlan 100

ip static-route 0.0.0.0 mask 0.0.0.0 gateway 172.16.1.254
!
vlan 100 port default 1/21-24


vlan 100 802.1q 1/1
vlan 100 802.1q 1/2
vlan 100 802.1q 1/3
vlan 100 802.1q 1/4
vlan 100 802.1q 1/5
vlan 100 802.1q 1/6
vlan 100 802.1q 1/7
vlan 100 802.1q 1/8
vlan 100 802.1q 1/9
vlan 100 802.1q 1/10
vlan 100 802.1q 1/11
vlan 100 802.1q 1/12
vlan 100 802.1q 1/13
vlan 100 802.1q 1/14
vlan 100 802.1q 1/15
vlan 100 802.1q 1/16
vlan 100 802.1q 1/17
vlan 100 802.1q 1/18
vlan 100 802.1q 1/19
vlan 100 802.1q 1/20

qos enable
policy condition IPphoneDSCP DSCP 46
policy action IPphone-act priority 5
policy rule IPphone-rule condition IPphoneDSCP action IPphone-act
policy service PoPC destination udp port 32000-32512
policy service group soft-phone PoPC
policy condition PoPC-cond service PoPC
policy action a2 priority 6
policy rule r2 condition PoPC-cond action a2
qos apply
!
lldp network-policy 10 application voice vlan 100 l2-priority 5 dscp 46
lldp chassis tlv med capability enable network-policy enable power enable
lldp chassis med network-policy 10
!
lanpower start 1
!
write memory
copy working certified

 

 

parnassus
Honored Contributor

Re: Alcatel to Aruba

Hi!


@Yolonero wrote: unfortunatly I can't really use the "let's dedicate some port for the voice and some for the LAN" because we wont have enough port left.

Nobody asked you to do that indeed a correct approach would be to set an access port as untagged member of "data" VLAN id and tagged member of "voice" VLAN id as you're trying to do.

Question: are you trying to swap phones and hosts from Alcatel to Aruba (while Alcatel has other essential services - Internet, DHCP Server, VoIP Server, etc. - running on hosts attached to it) OR are you trying to swap phones, client hosts and all other essential services you have from Alcatel to Aruba (with the Alcatel left unused)...if the former then we need to be sure about tagging on Alcatel (and, consequently, how to tag the uplink between Alcatel and Aruba), I don't believe you're trying with the latter (switch exchange in one shot).

If I look at the Alcatel, then this particular configuration line:

 

vlan 100 port default 1/21-24

 

means that ports 1/21 - 1/24 are untagged members of VLAN 100, which is the "voice" VLAN on your Alcatel Switch (VLAN 100 is thus "native VLAN" for those ports).

Then if I look at these configuration lines:

 

vlan 100 802.1q 1/1
vlan 100 802.1q 1/2
vlan 100 802.1q 1/3
vlan 100 802.1q 1/4
vlan 100 802.1q 1/5
vlan 100 802.1q 1/6
vlan 100 802.1q 1/7
vlan 100 802.1q 1/8
vlan 100 802.1q 1/9
vlan 100 802.1q 1/10
vlan 100 802.1q 1/11
vlan 100 802.1q 1/12
vlan 100 802.1q 1/13
vlan 100 802.1q 1/14
vlan 100 802.1q 1/15
vlan 100 802.1q 1/16
vlan 100 802.1q 1/17
vlan 100 802.1q 1/18
vlan 100 802.1q 1/19
vlan 100 802.1q 1/20

 

they mean that ports 1/1 - 1/20 are all tagged members of VLAN 100, which is - again - the "voice" VLAN on your Alcatel Switch (those ports haven't a native "untagged" VLAN membership since there is no reference about any other default VLAN for those ports, as above for 1/21-1/24).

That's to say:

  • How it is supposed to work data+voice in Alcatel IF a VoIP Phone + PC are connected via - say - port 1/1 considering only "voice" VLAN 100 is passed tagged and there isn't an untagged VLAN for data?
  • Show us how is tagged the uplink port between the Alcatel and the Aruba, on both sides (on Aruba check with show vlan port ethernet <port-id> detail CLI command).

I'm not an HPE Employee
Kudos and Accepted Solution banner
Yolonero
Visitor

Re: Alcatel to Aruba

Hi,

My apologies I see that it is starting to be a bit confusing. Let me try to sum up how it is currently (English isn't my native language but I'll do my best. I'm adding a quick diagram aswell) :

Currently, both LAN and VoIP networks are completly seperated. We have an Alcatel Switch for the VoIP and an old switch Netgear for the LAN. The port 1 of the Alcatel isn't connected currently, only the port 2 to 10 (iirc) and the port 23/24 (which are the links to the IPBX) are connected.

My current goal is to use one switch only instead of 2 (mainly because many cables in the walls are dead and the director doesn't want to spend money to repair them). Since both switchs are quite outdated, we decided to get a new one aswell (which is the Aruba)

I've connected a tagged link between one of the ports of the Alcatel to my Aruba to test out the phones to prevent keeping the users without phone too long (which as mentionned before, doesn't seem to work on my new switch if I don't put them in "untag").

I called back the ISP that set up the VoIP back then, and he kept telling me "you need to set up LLDP" (which is currently done, except if i'm wrong) and in the end he told me "if that doesn't work, you will need to set the VLAN manually on each phone (I think he gave up on helping me).

I hope it is more clear now

Note : the "internet router" is dedicated for the VoIP. There's of course another one for the LAN that isn't mentionned here.

network.png

parnassus
Honored Contributor

Re: Alcatel to Aruba

Way clearer (isn't surprising when you discover that a tiny thing is a little bit bigger?).

On Aruba please paste the output of:

 

show vlan port ethernet 10 detail (uplink to Alcatel)
show vlan port ethernet 11 detail (access for the VoIP Phone that isn't working)

 

On Alcatel, giving the configuration you posted ports 24 (to Router, your next hop) and 23 (to IP-PBX) are Untagged members of VLAN 100 while all other ports are Tagged members of VLAN 100...at this point the port 15 used for connecting to Aruba is tagged too on VLAN 100 only SO the same port (interface 10) should match the tagging on the Aruba side. Let us to verify that first please (see two commands above) so we will be sure about that Alcatel and Aruba interlink is going to pass the VLAN 100 correctly (tagged).

Here you can find a guide how to setup VoIP on ArubaOS-Switch based switch series (especially for the LLDP part).


@Yolonero wrote: I called back the ISP that set up the VoIP back then, and he kept telling me "you need to set up LLDP" (which is currently done, except if i'm wrong) and in the end he told me "if that doesn't work, you will need to set the VLAN manually on each phone (I think he gave up on helping me).

See above for the LLDP part.

With regard to "and in the end he told me "if that doesn't work, you will need to set the VLAN manually on each phone (I think he gave up on helping me)." you could do a test by using a host with a NIC capable of being VLAN aware (so you can set a VLAN id as tagged)...you should then set VLAN id 100 (and correct IP Address is DHCP doesn't work) and connect it to an Aruba access port SET to be VLAN 100 tagged...it's like connecting a VoIP Phone with port configured with VLAN 100 tagged (LLDP apart).

That would be a test to see if such of an host will be able to ping other hosts (VoIP Phones) on the VLAN 100 subnet, IP-PBX and Router included.


I'm not an HPE Employee
Kudos and Accepted Solution banner
Yolonero
Visitor

Re: Alcatel to Aruba

I won't be able to do the "sh vlan" on the port 11 because I'm not physically there today (and nobody will be able to connect me a phone), but I know that the result was similar to the port 10, here :

2021-06-10 10_57_57-192.168.2.15 - PuTTY.png

I do ping the gateway from my Aruba

2021-06-10 11_01_23-192.168.2.15 - PuTTY.png

For the article about LLDP, I already found it and set it as it is told (if you check the config file, you'll see at the top (cdp part) and the bottom (profiles part)).

parnassus
Honored Contributor

Re: Alcatel to Aruba

Hi, if you do ping the 172.16.1.254 from the Aruba (and from a VLAN unaware host connected to an untagged port member of VLAN 100 on the Aruba OR from a VLAN aware host set on VLAN 100 connected to a tagged port member of VLAN 100 on the Aruba) it means that VLAN tagging is OK and it traverses correctly all involved devices (Aruba and Alcatel).

As said do a test with a host with its port set to be tagged on VLAN id 100 (to simulate a phone).

Your Data and Voice logical networks are physicall separated now, isn't it? OK...so on this setup you can only test how a VoIP phone will behave once moved on the Aruba...isn't that an untagged VLAN is necessary (to simulate the scenario when you have Voice and Data on the same physical infrastructure...where data is untagged and voice tagged)?


I'm not an HPE Employee
Kudos and Accepted Solution banner