Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Aruba 2920-24G (J9726A) SNMP problem

 
Occasional Visitor

Aruba 2920-24G (J9726A) SNMP problem

 

Switch HP 2920-24G(config)# show snmp-server

 SNMP Communities

  Community Name       MIB View Write Access
  -------------------- -------- ------------
  manager              Manager  Unrestricted
  public               Operator Restricted

 Trap Receivers

  Link-Change Traps Enabled on Ports [All] : All

  Traps Category                          Current Status
  _____________________________________   __________________
  SNMP Authentication                   : Standard
  Stacking                              : Enabled
  Password change                       : Enabled
  Login failures                        : Enabled
  Port-Security                         : Enabled
  Authorization Server Contact          : Enabled
  DHCP-Snooping                         : Enabled
  DHCPv6-Snooping Out of Resource       : Enabled
  DHCPv6-Snooping Errant Replies        : Enabled
  Dynamic ARP Protection                : Enabled
  Dynamic IP Lockdown                   : Enabled
  Dynamic IPv6 Lockdown Out of Resource : Enabled
  Dynamic IPv6 Lockdown Violations      : Enabled
  Startup Config change                 : Disabled
  Running Config Change                 : Disabled
  MAC address table changes             : Disabled

  DHCP-Server                           : Enabled
  NTP-Client                            : Disabled

  ND Snooping Out of Resources Traps    : Enabled

  Address                Community              Events   Type   Retry   Timeout
  ---------------------- ---------------------- -------- ------ ------- -------
  172.18.230.150         manager                Not-INFO trap   3       15


 Excluded MIBs


 Snmp Response Pdu Source-IP Information

  Selection Policy   : configuredIP
  IP Address         : 172.18.240.7

 Trap Pdu Source-IP Information

  Selection Policy   : configuredIP
  IP Address         : 172.18.240.7

 

Check from 230.150: 

# snmpwalk -v 2c -c manager 172.18.240.7
Timeout: No Response from 172.18.240.7

 

Firewall not blocking. Request reaches the target but no response. 

Problem was discovered on the old FW 15.11.0007 and it is still actual after update to 16.09.003.

I've tried different combitaions of settings, and still nothing works.

Any ideas? 

4 REPLIES 4
HPE Pro

Re: Aruba 2920-24G (J9726A) SNMP problem

Hi,

Can you check the reachability of 172.18.240.7 from Aruba switch?

Also please enable som snmp/trap debugging commands to check the status.

Thanks!

 

I am an HPE Employee

Accept or Kudo

Visitor

Re: Aruba 2920-24G (J9726A) SNMP problem

Hello folks, I hope i can still get feedback on this post. I must prefice my post by that I am fairly new to networking but a keen learner. I am having the same/similar SNMP problems with two identical switches Aruba 2920-24G (J9726A) and only with switches of thiis exact specification. They are both running WB.16.10.0009 .

To give context, I am currently testing librenms for viability and left default configurations in place since this is only temporary. Once we have a clear picture whether librenms serves our monitoring needs I plan to configure snmpv3.

We have just shy of a dozen switches at one of our facilities, a couple of 2530s and several 2920s, of which two are J9729A in a stack and the other two are J9726A. The latter two are the problem devices. All switches are on the same LAN segment as the librenms server, and all of them were added by a few clicks (specifying IP addresses and the default 'public' snmp community - done), except these two.

- They have never been part of any snmp setup so there are no conflicting pre-existing configurations that I'm aware of.
- Both switches can ping the librenms server and viceversa
- There is no firewall between librenms server and these switches. Only a 2530 8-port and the stacked 2920 (J9729A), both of which have been successfully enrolled in librenms
- Both switches have the same configuration as shown in the original post except the exluded MIBs.

So far i have tried: (not sure if all of these even apply to the matter)

* defining the librenms ip as an snmp trap receiver
* specifying the librenms ip as authorized manager IP
* even tried skipping snmp v2c  and setting up v3 instead
* checked the names of the switches (whether they are identical to other switch names)

Nothing makes these switches talk to librenms. The message i get on the librenms WebUI is:

 Could not connect to 10.10.10.239, please check the snmp details and snmp reachability
 SNMP v2c: No reply with community public
 
Any help would be greatly appreciated.
Frequent Advisor

Re: Aruba 2920-24G (J9726A) SNMP problem

@RocketRon ,

I think you should consider creating a new topic instead

Visitor

Re: Aruba 2920-24G (J9726A) SNMP problem

Will do, thank you.