Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get GMB through QoS settings

haleema
Occasional Visitor

Can't get GMB through QoS settings

Hi,

I am playing with the QoS configurations of a HP ProCurve Switch 5406zl since the last month or so. And, what I am trying to do is rate-limit the traffic on the hardware table and then use the DSCP mapping (assigned to queues) to monitor flows through the switch. Through this I am mainly checking how the bandwidth is being shared between flows. Flows, that I am running through iperf3. 

Since HP ProCurve Switches use GMB, the expected result should be that the percentage bandwidth corresponding to each queue should be given to the flows going through them. But nothing like that is happening. At one time one of my flows has 0 Mb/sec throughput and at other time its 50-50 with the other flow assigned to a queue with a lower priority. I have gone through a lot of documentation but nothing seems to be helping me. 

Can you please guide me with this issue? I have been at it since the last month.

Thanks.

4 REPLIES
Michael Patmon
Trusted Contributor

Re: Can't get GMB through QoS settings

Hello.  GMB settings only come into play when the port traffic is egressing is oversubscribed.  By default each queue gets some percentage of the outbound bandwidth so you should not see any queue getting starved. 

Can you reply with your platform, config, "show bandwidth output", and client-port connection mapping?

Thanks.

haleema
Occasional Visitor

Re: Can't get GMB through QoS settings

I have currently set two queues. The low priority queue has 20% Bandwidth and the high priority queue has 80% Bandwidth.

I have removed all the default dscp-code points and set two code-points for each queue - 2 for the low prio queue and 4 for the high prio queue and rate-limited my openflow instance hardware table at 100 Mb/sec.


I test my queue through TCP and UDP flows using iperf3 (for tagging the flows with the relevant TOS bits). But what the results that I see are completely different from what I expect. Like it seems that time has an impact on the amount of bandwidth each flow gets. The flow which goes in last usu gets most of the bandwidth. And, there is no bandwidth sharing. For e.g., at times one of my flows recieves 0Mb/sec while rest have 30-30-20 bandwidth assigned to them.

I am completely confused now. What should I do? I don't have much time.

haleema
Occasional Visitor

Re: Can't get GMB through QoS settings

Also, I have observed that when I send  UDP flows greater than 100Mb (since I have rate-limited the openflow inst at 100 Mb/sec) the throughput decreases at the receiving end. For 1Gb UDP flow the throughput is 0 Mb/sec.

What could possibly be making it act like this?

My running-config file is attached.

Michael Patmon
Trusted Contributor

Re: Can't get GMB through QoS settings

Rate-limiting is done before the GMB is applied, so there really is no GMB when enabled concurrently with rate-limiting.  I would suspect for two UDP flows they would get roughly 50% of the available bandwidth.  Your TCP throughput will be much lower with rate-limting applied, packets start getting dropped indiscriminately once the limit is exceeded.

I don't know what your OpenFlow rules look like but if you're ingressing on ports A16 & A17 and egressing the same port your best bet would be to remove the OpenFlow rate-limting and force the egress port-speed to auto-100.  This would allow GMB to maintain the guarantees while preserving your 100Mbps "rate-limit".

If your traffic is egressing the same as other ports and forcing the port-speed is not an option you should remove the rate-limit and just let QoS/GMB handle the prioritization.