Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot Reach DHCP with Hybrid Port on an HPE 5130 EI Switch

 
Occasional Visitor

Cannot Reach DHCP with Hybrid Port on an HPE 5130 EI Switch

Across the campus we have a lot of HPE 5130 EI switches that have no issue.   The basic explanation of the network setup is that we have a core switch (Layer 3) switch that handles all the VLAN interfaces (DHCP relays are set up on the interface, pointing to a DHCP server) and LAN routing.  Then we have around 90 layer 2 switches.  On the layer two switches we use hybrid ports with a client (PC) VLAN (VLAN 2001) and a voice (Phone) VLAN (VLAN 2002), and that way with using one port, connect the phone to the switch and then the computer gets connection through connecting to the phone's PC port.  Below is the configuration that we use for the port.

port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2001 untagged
port hybrid pvid vlan 2001
voice-vlan 2002 enable
broadcast-suppression pps 3000
poe enable
loopback-detection enable vlan 1 to 4094
loopback-detection action block

97% of the switches on campus have no issue with the port configuration above.  But I have two switches that when using this configuration, it cannot reach the DHCP server.  It will not pull an IP address when connected to through the phone or directly into the switch.  Ran wireshark and you can only see the "DHCP Discover" being sent over and over.  You never see a reply.

But as soon as you configure the port to be an access port, it reaches the DHCP server, and gets an IP address.  Wireshark even shows the full DHCP process.

Thought that it might be firmware, updated the switches to latest version with still no luck.  Since these issues with the two switches, I have added the same model switch with the same version of firmware into another building, and that switch is working perfect with the same port configuration.

Please help, not sure why this is happening to only two switches.

2 REPLIES 2
HPE Pro

Re: Cannot Reach DHCP with Hybrid Port on an HPE 5130 EI Switch

Hi ,

Thank you for writing.

The issue could be specific with only the two switches and not with the configuration.Are the switches the same model/hardware as we need to check if the Hybrid port is supported.

Has this worked before on the two switches?Did you try with all the ports or only single port on the switches?

Have the "debug dhcp all" on the switches and share the results for review,as the switch is sending the request ,there seems to be no response or rechability issue to the DHCP Server.Try to ping to check the reachability to the DHCP Relay /server when configured as Hybrid port. at the same time while running the ping test please try doing a "debug ip icmp" to know who is not responding to the echo requests...if the DHCP server is not responding, check the logs on the DHCP if there is a request is being sent by the switch or not..or it could be also that it is not reachable to the relay itself.

 

Thanks,

 

I work for HPE
Accept or Kudo
Occasional Visitor

Re: Cannot Reach DHCP with Hybrid Port on an HPE 5130 EI Switch

Hi @3Naga ,

The switch that is having the issue is an HPE FlexFabric 5130 EI, and we have other switches that are the exact same model, but no issues.

Right now, I found out that if I have the original configuration that works on other switches.

 

port link-type hybrid
undo port hybrid vlan 1
port hybrid vlan 2001 untagged
port hybrid pvid vlan 2001
voice-vlan 2002 enable
broadcast-suppression pps 3000
poe enable
loopback-detection enable vlan 1 to 4094
loopback-detection action block

 

The phone works, but the computer shows "Unidentified Network" and does not communicate with the DHCP server and gets the Automatic Private IP Addressing (APIPA).

But if I have the port configured to the following configuration.

 

 undo port hybrid vlan 1
 port hybrid vlan 2002 tagged
 port hybrid vlan 2001 untagged
 port hybrid pvid vlan 2001
 broadcast-suppression pps 3000
 stp edged-port
 poe enable
 loopback-detection enable vlan 1 to 4094
 loopback-detection action block

 

Without the "voice-vlan" command.  The phone still works, and the computer communicates and pulls a valid IP address from the DHCP server.

It seems like it is something wrong with the "voice-vlan" command.  But what confuses me is that I have the same switches (Make and model) and same firmware version, plugged into the same core switch, with the same core switch port configuration, and the other switches do not have an issue with the voice-vlan command in the configuration?

Thanks,

Justin