Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Cisco to HP Procurve switch config

 
DarylB
Visitor

Cisco to HP Procurve switch config

Hi,

 

I'm new to HP networking and need to replace an old unsupported Cisco switch for a HP Procurve.

The current switch has a very simple config and has uplinks to an ASA HA pair, and connections to 3 HyperV hosts which are tagging a single VLAN (70).

 

The current switch config is below (Minus unimportant bits):

Spoiler
vlan 70
name DMZ
!
interface FastEthernet0/1
description *** HyperV Host 1 ***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/2
description *** HyperV Host 2 ***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/3
description *** HyperV Host 3 ***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/13
description *** Uplink to ASA DMZ interface ***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface FastEthernet0/14
description *** Uplink to ASA DMZ interface ***
switchport trunk encapsulation dot1q
switchport mode trunk
spanning-tree portfast
!
interface Vlan1
no ip address
shutdown
!

Please could someone advise how I can replicate this, i've tried creating VLAN 70 on the ProCurve and using the commands 'tagged 1-3,23-24' and I have also used the 'no untagged' command for these ports under VLAN 1. Unfortunately traffic is not passing, so I must be missing something.

Hoping it's something simple!

Many thanks

9 REPLIES 9
joacef
Occasional Advisor

Re: Cisco to HP Procurve switch config

Are you assign the VLAN on the Hyper-V networkcard?

If you are not assign the VLAN on the networkcard test this.

 

VLAN 70
untagged 1-3,23-24
Vince-Whirlwind
Honored Contributor

Re: Cisco to HP Procurve switch config

You seem to have the right idea - just add the VLAN as "tagged" to the switchport on the procurve should do it. And leave VLAN1 on it, because that's how the Cisco is configured.

The equivalent of "portfast" is admin-port edge, although amusingly the Cisco switchport config is ineffective because that is the "portfast" command for a switchport that is in "access" mode, not "trunk".

So I'd say your connectivity problems are not related to your VLAN port config but something else. For example, the Cisco config allows all VLANs by default, whereas on the HP you have to explicitly add them - perhaps your hosts are using a different VLAN and not 70?

DarylB
Visitor

Re: Cisco to HP Procurve switch config

The VLAN is assigned on the Hyper-V network card using the 'enable virtual LAN identification' option.

DarylB
Visitor

Re: Cisco to HP Procurve switch config

Thanks for this.

When you say leave VLAN 1 on the Procurve, do you mean assign the ports to VLAN 1 as well? So using the 'tagged' command for the ports on both VLAN 1 and VLAN 70?

joacef
Occasional Advisor

Re: Cisco to HP Procurve switch config

VLAN 70
tagged 1-3,23-24

VLAN 1
untagged 1-3,23-24

or 

INT 1-3,23-24
untagged vlan 1
tagged vlan 70
DarylB
Visitor

Re: Cisco to HP Procurve switch config

Thanks for this, I have applied this config but unfortunately it is still not working, the server is still unable to communicate.

joacef
Occasional Advisor

Re: Cisco to HP Procurve switch config

Can you share your HP config?

Mark Wibaux
Trusted Contributor

Re: Cisco to HP Procurve switch config

With the Cisco, if you are not specifying a native VLAN (or restricting the allowed VLANs) for a trunk interface, then all VLANs are tagged on that interface.

In the HPE world, the default for VLAN 1 is untagged across all ports.

I would suggest you try

INT 1-3,23-24 
tagged vlan 1, 70

That way those 5 ports should be configured the same way the Cisco ones were. I assume there are no other VLANs other than 1 & 70.

Perhaps you are mistakenly using VLAN 1 on your HyperV hosts for the connection at the server end.

Vince-Whirlwind
Honored Contributor

Re: Cisco to HP Procurve switch config

Unless things have changed in the world of Cisco, a port configured in trunk mode will by default have VLAN1 untagged.

You remove it (or tag it) by specifying a different native VLAN.