Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Communicate between VLANs

 
SOLVED
Go to solution
IrsathAhamed
Regular Visitor

Communicate between VLANs

Dear All,

Can someone help me to how can i communicate between 2 vlans.

we are using HP Procurve 2610-45 PoE Switch, created 2 vlan, one for Data and another for voice. Here i can not able to ping from date to voice and voice to date.

my switch running configuration follow:-

EO_ProCurve_2610-48-PWR# show running-config

Running configuration:

; J9089A Configuration Editor; Created on release #R.11.22

hostname "EO_ProCurve_2610-48-PWR"
snmp-server contact "IT Department"
snmp-server location "EO"
ip default-gateway 192.168.2.253
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "DEFAULT_VLAN"
untagged 49-50
no ip address
no untagged 1-48,51-52
exit
vlan 2
name "Data"
untagged 3-40,44-47,51-52
ip address 192.168.2.254 255.255.255.0
tagged 49-50
exit
vlan 3
name "voice"
untagged 1-2,42-43
ip address 192.168.3.254 255.255.255.0
qos priority 7
tagged 3-41,44-52
exit
ip route 0.0.0.0 0.0.0.0 192.168.2.253
password manager
password operator

Thank you in advance

6 REPLIES 6
Highlighted
gc_09
HPE Pro

Re: Communicate between VLANs

Your runing conifg shows you have IP routing enabled and you have IP addresses assigned to the data and voice vlans as well.

What exactly the issue you are seeing ?

I assume it's a typo in your statement which states "we are using HP Procurve 2610-45 PoE Switch, created 2 vlan, one for Data and another for voice. Here i can able to ping from date to voice and voice to date." that you are not able to ping. 

Can you post the client's IP configuration here which is being used for test ?

 

 

 

I am an HPE Employee

Accept or Kudo

Highlighted
IrsathAhamed
Regular Visitor

Re: Communicate between VLANs

Thank you for the reply.

Yes that is my typo error, i can not able to ping from Clinet pc to Voice Server.

We are using Avaya Telephoinc System. Avana phone has two lan port, one for voice and another for data. The pc is connected in that Data port and pc is having the ip 192.168.2.50 and Voice Server ip is 192.168.3.96.

I am unable to access voice server from the pc even though the ip routing is enabled.

 

Highlighted
gc_09
HPE Pro

Re: Communicate between VLANs

What is the gateway IP configured for this client ? and the avaya server?

Is the avaya server connected to this same switch ?  If not, then which device and is that the L2 device in your network ?

Where is the default route pointing to ?

I am an HPE Employee

Accept or Kudo

Highlighted
IrsathAhamed
Regular Visitor

Re: Communicate between VLANs

Thank you again for your reply.

Client gateway is 192.168.2.253 which is Sonic Firewall connected in the same switch.

No gateway for Avaya Server.

Both client, Sonic Firewall and Avaya server are connected in the same switch. I don’t know about the Switch is L2 or L3. How can I find out that??

My default routing point to Sonic Firewall.
Highlighted
gc_09
HPE Pro
Solution

Re: Communicate between VLANs

Client's gateway IP address must be an interface IP address configured in the firewall, this clarifies that the L3 device in your network must be the firewall. 

You must have a similar one configured in the firewall for the voice vlan and the avaya server server should have a gateway configured which will be the IP address of the interface in the firewall.

I am an HPE Employee

Accept or Kudo

Highlighted
IrsathAhamed
Regular Visitor

Re: Communicate between VLANs

Thanks for the prompt reply and sorry for the late response.

As you adviced I have created a interface in Sonicfirwall and connected to the untagged port no 42 in HP Switch 2610. Now i can able to ping but im unable to access the avaya server using putty or web portal.

The gateway mentioned in Avaya Server is 192.168.3.254 (Whis the interface ip of HP Procurve 2610).

My question is

1. Should i change the gateway ip to Sonicwall interface ip?

2. or Should i need to create any access rule in firewall. (which i already tired but no luck).