Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Communications between Vlan's (HP 2920-48G Switch (J9728A))

 
JohanCa
Occasional Visitor

Communications between Vlan's (HP 2920-48G Switch (J9728A))

Hi all!

I need help with communications between Vlan's

I have Vlan 1, Default_vlan and Vlan 560

Vlan 1 is the standard one and 560 is just created for wifi with a diffrent ip serie (10.0.50x, standard ip 10.0.5.x)

I want Vlan 560 to be able to communicate with printer and such on Vlan 1.

Posting configurations snippets below:

stacking
member 1 type "J9728A" mac-address 
member 2 type "J9728A" mac-address
exit
hostname "FB_GB_SR_2920"
mirror-port 1/2
aruba-central disable
no rest-interface
trunk 1/48,2/48 trk1 lacp
trunk 1/41,2/41 trk2 trunk
trunk 1/A1-1/A2 trk3 lacp
timesync sntp
sntp unicast
sntp server priority 1 192.36.133.17
time daylight-time-rule western-europe
time timezone 60
ip default-gateway 10.0.5.245
ip route 0.0.0.0 0.0.0.0 10.0.5.245
interface 1/1
monitor
name "INTERNET/INTRANET"
exit

....

....

vlan 1
name "DEFAULT_VLAN"
no untagged 1/39-1/40,2/39-2/40
untagged 1/1-1/38,1/42-1/47,2/1-2/38,2/42-2/47,Trk1-Trk3
ip address 10.0.5.220 255.255.255.0
exit
vlan 20
name "WIFIGUESTSVLAN20"
untagged 1/40,2/40
tagged Trk2-Trk3
no ip address
exit
vlan 50
name "VLAN50-WIFI"
no ip address
exit
vlan 100
name "VLAN100FIREWALL-WAN"
tagged 1/43-1/44,2/43-2/44
no ip address
exit
vlan 150
name "VLAN150-STORAGE"
tagged 1/34,1/42,1/45-1/47,2/45-2/47,Trk1
no ip address
exit
vlan 560
name "WIFIVLAN560"
untagged 1/39,2/39
tagged 1/1,Trk2-Trk3
no ip address
exit

Any suggestions and pointers much appreciated.

/Johan

1 REPLY 1
parnassus
Honored Contributor

Re: Communications between Vlan's (HP 2920-48G Switch (J9728A))

Hi Johan, welcome to HPE Community.

Giving the running configuration you posted two things pop up: each VLAN you want to let partecipate to IPv4 routing needs to own an IP Address (SVI) and - that's essential (mandatory) - the Switch owning those VLANs needs to have IP routing enabled.

I don't see neither the former nor the latter requirement satisfied on posted configuration.

Clearly the above requirements are valid if your network design expects that routing role (for your internal VLANs) must be performed by your Switch.