Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Configure LACP in 2530 switch

 
SOLVED
Go to solution
Jorge_GT
Visitor

Configure LACP in 2530 switch

Hello my friends!

I have a question to ask, I am trying to set up a nic teaming in windows server 2012, the configuration that I have is the following:

Team training mode: LACP
Load balance mode: dynamic
Standby adapter: none
 
In the switch I have configured ports 11 and 12 as follows:
 
port: 11
Enabled: yes
Mode: auto
Flow control: disabled
LACP status: Active
trunk type:
Trunk group:
 
port: 12
Enabled: yes
Mode: auto
Flow control: disabled
LACP status: Active
trunk type:
Trunk group:
 
The question is this:
If I have the 2 ports connected, I lose the connection with the server, if I disconnect any of the 2, I can access without problems.
 
What could be wrong?

3 REPLIES
parnassus
Honored Contributor
Solution

Re: Configure LACP in 2530 switch

It looks like that both ports (11 and 12) aren't members of a Trunk Group because, from what I see, there isn't any...the logical procedure, Switch side, is first to create a Trunk Group then to assign some members ports to it (let me say at least two) and, once done, only then physically connect with other peer Trunk Group you already created (your two LACP teamed ports, Server side).

Can you show the relevant parts of your current Switch config? ...just to be sure my guess is right.
Jorge_GT
Visitor

Re: Configure LACP in 2530 switch

First of all thank you for responding.
Previously I had already done that configuration creating a trunk lacp group but that way I do not even respond when I ping the ip.

I understand that the trunk group is created for static configuration and the one I am trying to do is dynamic.

I think I know where the error is, I found this on the internet:

"Dynamic LACP trunks operate only in the default VLAN (unless GVRP is enabled and FORBID  is used to prevent the trunked ports from joining the default VLAN). Thus, if an LACP dynamic port forms using ports that are not in the default VLAN, the trunk automatically moves to the default VLAN unless GVRP operation is configured to prevent this from occurring. In some cases, this can create a traffic loop in your network."

The current configuration is as follows:

Running configuration:


hostname "SWTCH001"
mirror-port 46
trunk 11-12 trk1 lacp
gvrp
stack commander "SWT_STACK"
stack auto-grab
stack member 1 mac-address 9457a5***
ip default-gateway 192.168.100.1
interface 48
   monitor
   exit

vlan 1
   name "DEFAULT_VLAN"
   no untagged 2,28-29,39,46-47
   untagged 12,18,25,30,40-44,48-52,Trk1
   tagged 1,3-11,13-17,19-24,26-27,31-36,45
   ip address 192.168.100.2 255.255.255.224
   exit
vlan 101
   name "Data"
  ...
   exit
vlan 102
   name "Servers"
   untagged 31,39
   tagged 25-29,32-34,40-44,47-49
   no ip address
   exit
spanning-tree
spanning-tree Trk1 priority 4

 

clearly the trunk group is in the default vlan and I need it in vlan 102

there is an error.

 

Jorge_GT
Visitor

Re: Configure LACP in 2530 switch

 

finally I made a static configuration to be able to specify the desired vlan. I closed the subject but it was not the expected solution. thanks anyway