Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware update on HP 2530-48G j9028A

SOLVED
Go to solution
adelgado
Frequent Advisor

Firmware update on HP 2530-48G j9028A

Hello,

I'm planning updating the firmware on two HP 2530-48G j9028A.

Both has firmware YA.15.12.0007, ROM YA.15.12, and I've seen is available firmware YA.16.02.0012

I think there are a lot of firmwares in the middle, and here cames my doubt, as I thouhg it was recommend to upgrade two-three stesp, I mean, don't jump 10 firmware versions, but 2-3 at a time.

What do you think?

Regards,

Senior Systems Administrator
7 REPLIES
parnassus
Honored Contributor

Re: Firmware update on HP 2530-48G j9028A

IMHO it would be a good practice (I'm not sure it is a mandatory way of proceeding) to update to each interim YA.15.xx branch...terminating, at the end of all these update steps, on the final YA.16.xx branches...clearly, if you have enough time and patience to do things that way, it will not hurt for sure.

Apart from that, keep in mind that, on each Release Notes document, there are clear informations about update guidelines and restrictions (as example when a Switch will perform a dual consecutive reboot due to concurrent BootROM update when you're updating to a particular software version).

Edit: Be careful...the J9028A refers to a HP ProCurve 1800 Switch Series (exactly the HP ProCurve 1800-24G model)...so, since the Post refers to HP 2530-48G Switch with YA.15.xx software, is that an error or what?

The HP ProCurve (now Aruba) 2530-48G Switch has Product Number J9775A.

adelgado
Frequent Advisor

Re: Firmware update on HP 2530-48G j9028A

Hi paranassus,

What do you mean with:

"to update to each interim YA.15.xx branch...terminating, at the end of all these update steps, on the final YA.16.xx branches"

Could I upgrade starting from YA15.12.007 to YA15.12.0016, or should I upgrade froom YA15.12.007 to YA15.12.0008, then YA15.12.009......

There are branches YA15.13, YA15.14, YA15.15,..... YA15.18, should I upgrade from branch to branch, and every interim one?

There are a lot of them.....

Regards,

Senior Systems Administrator
parnassus
Honored Contributor
Solution

Re: Firmware update on HP 2530-48G j9028A

No, I meant that if you're on (say) YA.15.12.007 you could go to the latest software version released for the entire YA.15.12 branch (let's say that version is the YA.15.12.0016) and then jump directly to the latest software version released for YA.15.13, and so on consecutively up to the YA.15.18 branch...but IMHO this long and tedious step-by-step procedure is-not-strictly-required nor strictly mandatory (AFAIK).

If I were you probably - being in a hurry - I would go straight to YA.16.02.0012 or, eventually, I will pass just through just the two main interim releases that specifically require a BootROM update: the YA.15.12.0016 and the YAB.15.18.0013...prior to the final jump to the latest YA.16.02.0012.

OTOH maybe avoiding two BootROM forced updates (so for sure four Switch reboots) is probably better than unblindly doing them and, in the end, going straight to YA.16.02.0012 with just one BootROM forced update, is less risky even if it looks like a "big" jump.

The key point is eventually try to understand if there are some particular software versions that require the BootROM [*] to be (automatically) upgraded...in those cases you should expect an automatic dual reboot...just that.

[*] Read below:

As example, regarding the YA.15.12.0016 (the latest of YA.15.12 branch) there is this note:

YA/YB15.12.0016 uses BootROM YA.15.13 or YB.15.05. If your switch has an older version of BootROM, the BootROM will be updated with this version of software.

The same is valid on YA.15.13.0014 and on YA.15.14.0011.

conversely on the YA.15.18.0013 (the latest of YA.15.18 branch) this note above changes into:

YA/YB.15.18.0013 uses BootROM YA.15.17 or YB.15.07. If your switch has an older version of BootROM, the BootROM will be updated with this version of software.
 
Which looks valid also for YA.15.15.0013, YA.15.16.0013m and YA.15.17.0012...so no BootROM changes between these branches.
 
YA.16.02, as example, uses the same BootROM of YA.15.18.0013...so going from this one to YA.16.02.0012 doesn't require the Switch to perform an automatic dual reboot because the BootROM didn't changed.
 
So, by acknowledging that, you already know what to expect in terms of reboots your Switch will do automatically (if you hit those versions).
adelgado
Frequent Advisor

Re: Firmware update on HP 2530-48G j9028A

Hi parnassuys,

Thanks a lot for your support.

Senior Systems Administrator
adelgado
Frequent Advisor

Re: Firmware update on HP 2530-48G j9028A

BTW, should I upgrade first primary flash or secondary?

After I upgrade the first flash, should I force a boot, or it will do it by itself?

Regards,

Senior Systems Administrator
domdgr
Frequent Visitor

Re: Firmware update on HP 2530-48G j9028A

Happily running on version 15.16.0005, recently updated 80 or so switches that were all on different version of 15.15.x

I would copy the primary flash to the secondary before copying the new firmware to the primary, this way if anything goes wrong your switch can boot off the secondary image.

parnassus
Honored Contributor

Re: Firmware update on HP 2530-48G j9028A

Yep, that's the recommended procedure.