Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 1950 and Procurve 5406zl

 
komarovaa
Occasional Collector

HP 1950 and Procurve 5406zl

Good afternoon, colleagues!
I have a small part of the network that operates HP 1950- cisco 2960-hp procure 5406zl.
ports have the following settings:
hp 1950
interface GigabitEthernet1 / 0/3
 port link-type trunk
 port trunk permit vlan all
cisco 2960
interface GigabitEthernet1 / 0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 no mdix auto
hp procurver 5406
port A3
vlan1 untagged
the rest of vlan taged
I want to exclude cisco 2960 from this chain. On hp 1950 I leave the same port settings
I need a new port on HP procurve. I made it trk1, indicated vlan1 untagged, the rest vlan tagged. For some reason, this configuration does not work, everything is vlan, except vlan1 do not see hp 1950 and the server behind it. Please tell me what I did wrong. Thank you in advance!

7 REPLIES 7
jguse
HPE Pro

Re: HP 1950 and Procurve 5406zl

Hello,

Did you configure the "switchport trunk native vlan" for the untagged VLAN and permit the tagged VLANs across the links on Cisco with "switchport trunk allowed vlan x" ? It looks like it's missing in the configuration you've posted.

Best regards,
Justin

Working @ HPE
Accept or Kudo
parnassus
Honored Contributor

Re: HP 1950 and Procurve 5406zl


@komarovaa wrote: I need a new port on HP procurve. I made it trk1, indicated vlan1 untagged, the rest vlan tagged. For some reason, this configuration does not work, everything is vlan, except vlan1 do not see hp 1950 and the server behind it. Please tell me what I did wrong.

You're confusing HP ProVision / HPE Aruba ArubaOS-Switch "Trunk" (Aggregation of more physical ports in a logical port called trkX where X is a positive integer number which define the Trunk ID) with "trunk" mode of operation of a port - in HP Comware / Cisco IOS jargon - which permits to carry more tagged VLAN into a physical (or logical) link.

So HP/Aruba side if you need a single physical port Z to be untagged member of a VLAN X and also tagged member of various other VLAN IDs (typically that port will be used to "trunk" in Cisco jargon various VLANs to downlink/uplink devices...which should be your case here) you just need to type these commands:

 

 

interface ethernet Z untagged vlan X
interface ethernet Z tagged vlan A,B,C,D-F,G

 

 

Change letters with VLAN IDs you really need (single, multiple, ranges).

Not sure what you mean with the expression "exclude cisco 2960 from this chain" but if you just need to relocate (topologically speaking) your Cisco 2960 to uplink it directly to your HP 5406zl then you just need to configure a dedicated port (downlink to Cisco 2960) with the same VLAN settings you actually have on the Cisco 2960 port used for actual uplink. 

komarovaa
Occasional Collector

Re: HP 1950 and Procurve 5406zl

Thank you, I corrected, removed the group mk 1
I configured port D24 to connect the Procurve 5406 to it. Have I configured it correctly?

vlan 1 
   name "first" 
   untagged A1-A24,B1-B24,C1,C4-C21,C23-C24,D1-D24 
   ip address 10.16.0.22 255.255.0.0 
   tagged C2 
   no untagged C3,C22 
   exit 
vlan 51 
   name "51" 
   untagged C3 
   tagged A3,D1,D24 
   no ip address 
   exit 
vlan 52 
   name "52" 
   tagged A3,C24,D1,D24 
   no ip address 
   exit 
vlan 100 
   name "100" 
   tagged A3,D24 
   no ip address 
   exit 
vlan 53 
   name "53" 
   tagged A3,C15,D1,D24 
   no ip address 
   exit 
vlan 99 
   name "99" 
   ip address 10.1.30.3 255.255.255.0 
   tagged A3,C15,D24 
   exit 
vlan 110 
   name "VLAN110" 
   tagged A3,D24 
   no ip address 
   exit 
vlan 190 
   name "190" 
   tagged A3,D4,D24 
   no ip address 
   exit 
vlan 167 
   name "167" 
   tagged A3,C1,D24 
   no ip address 
   exit 
vlan 112 
   name "112" 
   tagged A3,C1,D24 
   no ip address 
   exit 
vlan 700 
   name "K11" 
   tagged A3,C1,D1,D24 
   no ip address 
   exit 
vlan 701 
   name "701" 
   tagged A3,C1,D1,D24 
   no ip address 
   exit 
vlan 702 
   name "702" 
   tagged A3,C1,D1,D24 
   no ip address 
   exit 

 

parnassus
Honored Contributor

Re: HP 1950 and Procurve 5406zl

I'm lazy today...it's Friday! ...please show us the output of:

show vlan port D24 detail

 that's useful to see port D24's VLAN tagging status.

komarovaa
Occasional Collector

Re: HP 1950 and Procurve 5406zl

Understand. I will decide this question only next weekend, so I decided to ask in advance why it didn’t work for me earlier

  port D24

VLAN ID Name | Status Voice Jumbo Mode
------- -------------------- + ---------- ----- ----- --------
1  | Port-based No No Untagged
25  | Port-based No No Tagged
30  | Port-based No No Tagged
34  | Port-based No No Tagged
40  | Port-based No No Tagged
51  | Port-based No No Tagged
52  | Port-based No No Tagged
53  | Port-based No No Tagged
99 | Port-based No No Tagged
100 | Port-based No No Tagged
110  | Port-based No No Tagged
111  | Port-based No No Tagged
112  | Port-based No No Tagged
150  | Port-based No No Tagged
167  | Port-based No No Tagged
190  | Port-based No No Tagged
700  | Port-based No No Tagged
701  | Port-based No No Tagged
702 | Port-based No No Tagged
703 | Port-based No No Tagged
704 | Port-based No No Tagged
705 | Port-based No No Tagged

parnassus
Honored Contributor

Re: HP 1950 and Procurve 5406zl

Not sure to follow you when saying "I decided to ask in advance why it didn’t work for me earlier"...are you saying that it now works but previously not or what else?

In any case port D24 is untagged member of VLAN id 1 and tagged member of VLAN id 25, 30, 34, 40, 51, 52, 53, 99, 100, 110, 111, 112, 150, 167, 190, 700, 701, 702, 703, 704 and 705...so the only thing you need Cisco side is to setup its uplink interface with something like (if the port will remain the 1/0/5):

interface GigabitEthernet 1/0/5
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,25,30,34,40,51,52,53,99,100,110,111,112,150,167,190,700,701,702,703,704,705
switchport mode trunk
switchport nonegotiate
komarovaa
Occasional Collector

Re: HP 1950 and Procurve 5406zl

Thank!
Now works using hp 1950 - cisco 2960 - hp procurve 5406.
I want to remove the unnecessary transit switch cisco 2960.
Trunk port is made on HP 1950, it has such settings
interface GigabitEthernet1 / 0/4
port link-type trunk
port trunk permit vlan all
On HP procurve 5406 I will use port D24, it has such settings (they are also there above)
vlan 1 untagged
vlan 2-4096 tagged
I tried with these settings, but only vlan 1 worked for me.