Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP 5500 HI IRF

 
SOLVED
Go to solution
colly72
Occasional Advisor

HP 5500 HI IRF

Hi all,

I've got 2 HP 5500 HI switches that I'm trying to connect with IRF, with one pair of 10Gbe SFP+ transceivers connected with a fibre cable.  I've followed all the guides I can find and have set it up as I think it should be but when I connect the 2 switches, they initially show IRF port as up before failing with a heartbeat timeout message.  I've made sure the switches are on the same firmware.  Here's my config for the master switch:

#
version 5.20.99, Release 5501P20
#
sysname HP
#
dhcp relay server-group 1 ip 10.1.0.149
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
irf member 1 priority 32
#
domain default enable system
#
telnet server enable
#
password-recovery enable
#
acl number 2000
rule 0 deny source 172.16.28.0 0.0.3.255
#
acl number 3001
hardware-count enable
rule 0 deny ip source 172.16.28.0 0.0.3.255 destination 192.168.10.0 0.0.0.255
rule 5 deny icmp source 172.16.28.0 0.0.3.255 destination 192.168.10.0 0.0.0.255
rule 10 permit ip
#
vlan 1
#
vlan 10
description Accounts
#
vlan 20
description Servers
#
vlan 30
description Curriculum
#
vlan 40
description Printers
#
vlan 60
description IT Admin
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user admin
password cipher $c$3$1Q8Fu74tA+WUcpcTGeKWn2/UizAb4H3k7Q==
authorization-attribute level 3
service-type telnet
service-type web
#
cwmp
undo cwmp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 10.1.3.67 255.255.0.0
#
interface Vlan-interface10
ip address 192.168.10.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
packet-filter 3001 inbound
#
interface Vlan-interface20
ip address 192.168.20.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface30
ip address 172.16.28.1 255.255.252.0
dhcp select relay
dhcp relay server-select 1
packet-filter 3001 inbound
#
interface Vlan-interface40
ip address 192.168.40.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface Vlan-interface60
ip address 192.168.60.1 255.255.255.0
dhcp select relay
dhcp relay server-select 1
#
interface GigabitEthernet1/0/1
port link-mode bridge
#
interface GigabitEthernet1/0/2
port link-mode bridge
#
interface GigabitEthernet1/0/3
port link-mode bridge
#
interface GigabitEthernet1/0/4
port link-mode bridge
#
interface GigabitEthernet1/0/5
port link-mode bridge
#
interface GigabitEthernet1/0/6
port link-mode bridge
#
interface GigabitEthernet1/0/7
port link-mode bridge
#
interface GigabitEthernet1/0/8
port link-mode bridge
#
interface GigabitEthernet1/0/9
port link-mode bridge
#
interface GigabitEthernet1/0/10
port link-mode bridge
#
interface GigabitEthernet1/0/11
port link-mode bridge
#
interface GigabitEthernet1/0/12
port link-mode bridge
#
interface GigabitEthernet1/0/13
port link-mode bridge
#
interface GigabitEthernet1/0/14
port link-mode bridge
#
interface GigabitEthernet1/0/15
port link-mode bridge
#
interface GigabitEthernet1/0/16
port link-mode bridge
#
interface GigabitEthernet1/0/17
port link-mode bridge
#
interface GigabitEthernet1/0/18
port link-mode bridge
#
interface GigabitEthernet1/0/19
port link-mode bridge
#
interface GigabitEthernet1/0/20
port link-mode bridge
#
interface GigabitEthernet1/0/21
port link-mode bridge
#
interface GigabitEthernet1/0/22
port link-mode bridge
#
interface GigabitEthernet1/0/23
port link-mode bridge
#
interface GigabitEthernet1/0/24
port link-mode bridge
#
interface GigabitEthernet1/0/25
port link-mode bridge
#
interface GigabitEthernet1/0/26
port link-mode bridge
#
interface GigabitEthernet1/0/27
port link-mode bridge
#
interface GigabitEthernet1/0/28
port link-mode bridge
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet1/0/30
port link-mode bridge
#
interface Ten-GigabitEthernet1/0/29
#
ip route-static 0.0.0.0 0.0.0.0 10.1.10.2
#
dhcp enable
#
ssh server enable
#
load xml-configuration
#
load tr069-configuration
#
user-interface aux 0
user-interface vty 0 15
#
irf-port 1/1
port group interface Ten-GigabitEthernet1/0/29 mode enhanced
#
return

 

 

Here's the config on the slave switch:

#
version 5.20.99, Release 5501P20
#
sysname HP
#
irf mac-address persistent timer
irf auto-update enable
undo irf link-delay
#
domain default enable system
#
password-recovery enable
#
vlan 1
#
domain system
access-limit disable
state active
idle-cut disable
self-service-url disable
#
user-group system
group-attribute allow-guest
#
local-user admin
password cipher $c$3$mAOPzI066QeH3djBbCybHk3DyaQ8SSo5TA==
authorization-attribute level 3
service-type telnet
service-type web
#
cwmp
undo cwmp enable
#
interface NULL0
#
interface Vlan-interface1
ip address 10.1.3.75 255.255.0.0
#
interface GigabitEthernet2/0/1
port link-mode bridge
#
interface GigabitEthernet2/0/2
port link-mode bridge
#
interface GigabitEthernet2/0/3
port link-mode bridge
#
interface GigabitEthernet2/0/4
port link-mode bridge
#
interface GigabitEthernet2/0/5
port link-mode bridge
#
interface GigabitEthernet2/0/6
port link-mode bridge
#
interface GigabitEthernet2/0/7
port link-mode bridge
#
interface GigabitEthernet2/0/8
port link-mode bridge
#
interface GigabitEthernet2/0/9
port link-mode bridge
#
interface GigabitEthernet2/0/10
port link-mode bridge
#
interface GigabitEthernet2/0/11
port link-mode bridge
#
interface GigabitEthernet2/0/12
port link-mode bridge
#
interface GigabitEthernet2/0/13
port link-mode bridge
#
interface GigabitEthernet2/0/14
port link-mode bridge
#
interface GigabitEthernet2/0/15
port link-mode bridge
#
interface GigabitEthernet2/0/16
port link-mode bridge
#
interface GigabitEthernet2/0/17
port link-mode bridge
#
interface GigabitEthernet2/0/18
port link-mode bridge
#
interface GigabitEthernet2/0/19
port link-mode bridge
#
interface GigabitEthernet2/0/20
port link-mode bridge
#
interface GigabitEthernet2/0/21
port link-mode bridge
#
interface GigabitEthernet2/0/22
port link-mode bridge
#
interface GigabitEthernet2/0/23
port link-mode bridge
#
interface GigabitEthernet2/0/24
port link-mode bridge
#
interface GigabitEthernet2/0/25
port link-mode bridge
#
interface GigabitEthernet2/0/26
port link-mode bridge
#
interface GigabitEthernet2/0/27
port link-mode bridge
#
interface GigabitEthernet2/0/28
port link-mode bridge
#
interface M-GigabitEthernet0/0/0
#
interface Ten-GigabitEthernet2/0/29
port link-mode bridge
#
interface Ten-GigabitEthernet2/0/30
#
load xml-configuration
#
load tr069-configuration
#
user-interface aux 1
user-interface vty 0 15
#
irf-port 2/1
port group interface Ten-GigabitEthernet2/0/30 mode enhanced
#
return

I can't work out what it is that I'm doing wrong.  Can anyone help?

 

Thanks in advance

4 REPLIES 4
TerjeAFK
Respected Contributor

Re: HP 5500 HI IRF

Did you shutdown the ports you use for the IRF link before you added them to the IRF port group?

colly72
Occasional Advisor

Re: HP 5500 HI IRF

Yes, I shut them down first.  When I connect the fibre, the port becomes up for a few seconds then fails.

showneek
Respected Contributor
Solution

Re: HP 5500 HI IRF

Hi,

I think that you have logical IRF port misconfiguration.

logical IRF port 1 has to be connected to logical IRF port 2.

So IRF 1/1 should be connected ot IRF port 2/2.

Try to change configuration in second device. Delete IRF port 2/1  and create the IRF port 2/2.

BR,

Jan

colly72
Occasional Advisor

Re: HP 5500 HI IRF

That's it exactly, it all works great now!

Thanks for your help,

Kind Regards,

Michael