Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP/Aruba 2920 802.1x connection problem

 
Wozer
Occasional Visitor

HP/Aruba 2920 802.1x connection problem

Hi,

I have been trying to set up 802.1x with machine authentication on my Aruba 2920 switch and have run into some issues. I have been following this link for instructions : http://h22208.www2.hpe.com/eginfolib/networking/docs/switches/WB/15-18/5998-8152_wb_2920_asg/content/ch13s05.html

Checking settings, 802.1x is active on the ports, the RADUIS server settings are correct, but whenever I plug in a computer it gets stuck at connecting when running this command 

show port-access authenticator clients

 The first computer i have plugged in is a non domain computer, so it should fail authentication and be sent down my unauth vlan. If I run 

show mac-address aa:aa:aa:bb:bb:bb

it is showing the computer is going over the unauth vlan, but it does not have any internet connection.

The second computer I have plugged in is a domain computer and should pass the RADIUS authentication, but it just sits at connecting. I tried checking the NPS server event logs but it seems that it never even hits the RADIUS server. 

Any help would be greatly appreciated. Just let me know if any configuration or logs need to get posted.

Chris

1 REPLY 1
Wozer
Occasional Visitor

Re: HP/Aruba 2920 802.1x connection problem

Bumping this with an update. I was able to get computers authenticated. My current issue is with computers that should be sent down the guest VLAN. My test computer just gets stuck connecting, it seems that the authentication never actually times out which would signal the switch to send it down the Guest VLAN.

Are there any specific settings I need to look for to make sure the timeout occurs.

I have already set aaa port-access authenticator 1-44 server-timeout 30

Thanks,

Chris