Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

HP and Cisco switch connected on my test lab.

 
JOSIAHBOZIAH
Occasional Advisor

HP and Cisco switch connected on my test lab.

I have Hp Procurve  2610 and Cisco C3560 switches. The Cisco switch is where my DHCP server is connected and its configured with multiple VLANs, IP routing etc.  All clients both wired and wireless get DHCP addresses from DHCP just fine and can connect to the internet. I want to extend my network to the HP switch to be able to have clients also connect to the HP switch and get DHCP and internet access through the Cisco switch. I have set up the default gateway on the HP switch as the IP of the Cisco switch. I am able to ping the Cisco switch from the HP switch and vice versa. I am even able to ping the HP switch from a client connected to the Cisco switch. I am however not able to get any DHCP or internet access if I connect any device to the HP switch.. what routing configs should I have on the HP switch to make this possible. below is my hp config

mose# show conf

Startup configuration:

; J9087A Configuration Editor; Created on release #R.11.72

hostname "mose"
time timezone -360
time daylight-time-rule Continental-US-and-Canada
mirror-port 6
trunk 1 Trk1 LACP
ip default-gateway 10.76.0.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "kenya"
untagged 25
ip address 10.76.0.3 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28,Trk1
no untagged 2-24
exit
vlan 12
name "Servers"
untagged 2-8
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28
exit
vlan 200
name "ArubaAP"
untagged 9-12
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28
exit
vlan 100
name "HP530AP"
untagged 13-16
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28
exit
vlan 50
name "Wired_Clients"
untagged 17-22
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28
exit
vlan 28
name "Printers"
untagged 23-24
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 26-28
exit
vlan 32
name "CISC3560Routerr"
ip address 10.76.32.1 255.255.255.0
ip helper-address 10.76.12.15
exit
ip route 10.76.0.0 255.255.255.0 10.76.0.2
ip route 0.0.0.0 0.0.0.0 10.76.0.1
dhcp-snooping
spanning-tree Trk1 priority 4
ip ssh
password manager
password operator

7 REPLIES
Vince-Whirlwind
Honored Contributor

Re: HP and Cisco switch connected on my test lab.

Why do you have IP addresses on all your HP switch's VLAN interfaces? 
Surely each of those subnets has the Cisco switch doing its routing?

You have one static route that won't do anything (the switch already "owns" 10.76.0.0, so you can't have a route for it) and your default route says something different from your default gateway config on the switch. I think it might ignore the latter, but not sure.

If you're just extending an existing network to an additional - Layer2 - switch, then all you need is:
1/ add all the VLANs as "tagged" to the Cisco interfaces that are being patched to the HP switch
2/ create all the VLANs and add them as "tagged" to the HP interfaces that are being patched to the Cisco switch.
3/ Configure your HP switch ports as "untagged" in the appropriate VLANs
4/ create one layer3 interface on the HP switch for management, and give the switch a default gateway in that subnet. (If it's not VLAN1 some HP switches need you to run a "management vlan..." command)
5/ patch one uplink live and
 - test hosts on the HP switch can ping their default GW within each VLAN
 - test hosts can ping an IP address off their own subnet
 - test DHCP
6/ Add additional uplinks, configure your link aggregation and test.

JOSIAHBOZIAH
Occasional Advisor

Re: HP and Cisco switch connected on my test lab.

I am not sure how to do step 2. i entered the interface(port25) linked to the switch but i dont know the command to add vlan to the interface(port25)

JOSIAHBOZIAH
Occasional Advisor

Re: HP and Cisco switch connected on my test lab.

I have it working now, (i receive DHCP and internet access), I had to untag all the ports on the HP switch in VLAN 1., so the whole switch has 1 VLAN.The DHCP server is connected to the Cisco switch and the HP switch is uplinked from the Cisco switch.  I still want to be able to have it working with multiple VLANs on the HP switch. How do I achieve that?????

here are my HP and cisco config

HP

Startup configuration:

; J9087A Configuration Editor; Created on release #R.11.72

hostname "mose"
time timezone -360
time daylight-time-rule Continental-US-and-Canada
mirror-port 6
ip access-list standard "dellserver"
permit 10.76.12.15 0.0.0.0
exit
ip access-list standard "11"
permit 10.76.12.15 0.0.0.0
exit
ip default-gateway 10.76.0.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "kenya"
untagged 1-26
ip address 10.76.0.3 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28
exit
vlan 12
name "Servers"
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 200
name "ArubaAP"
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 100
name "HP530AP"
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 50
name "Wired_Clients"
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28
exit
vlan 28
name "Printers"
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28
exit
vlan 32
name "CISC3560Routerr"
no ip address
ip helper-address 10.76.12.15
tagged 1,27-28
exit
dhcp-relay option 82 append
ip route 0.0.0.0 0.0.0.0 10.76.0.2
dhcp-snooping
ip ssh
dhcp host-name-option
password manager
password operator

 

CISCO

CISCO3560#show run

no aaa new-model
clock timezone CST -6
clock summer-time CDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
!

shutdown vlan 99

ip subnet-zero
ip routing
ip dhcp relay information trust-all
!
ip ssh version 2
ip dhcp-server 10.76.12.15
!
!
c
!

!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
!
interface FastEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
speed 100
!
interface FastEthernet0/2
switchport access vlan 12
speed 100
!
interface FastEthernet0/3
switchport access vlan 12
!
interface FastEthernet0/4
switchport access vlan 12
speed 100
!
interface FastEthernet0/5
switchport access vlan 12
!
interface FastEthernet0/6
switchport access vlan 12
!
interface FastEthernet0/7
switchport access vlan 12
!
interface FastEthernet0/8
switchport access vlan 12
!
interface FastEthernet0/9
switchport access vlan 12
!
interface FastEthernet0/10
switchport access vlan 12
!
interface FastEthernet0/11
switchport access vlan 50
!
interface FastEthernet0/12
switchport access vlan 50
!
interface FastEthernet0/13
switchport access vlan 50
!
interface FastEthernet0/14
switchport access vlan 50
!
interface FastEthernet0/15
switchport access vlan 50
!
interface FastEthernet0/16
switchport access vlan 50
!
interface FastEthernet0/17
switchport access vlan 50
!
interface FastEthernet0/18
switchport access vlan 50
!
interface FastEthernet0/19
switchport access vlan 50
!
interface FastEthernet0/20
switchport access vlan 50
!
interface FastEthernet0/21
power inline static
switchport access vlan 100
switchport mode access
speed 100
!
interface FastEthernet0/22
switchport access vlan 100
!
interface FastEthernet0/23
switchport access vlan 100
!
interface FastEthernet0/24
switchport access vlan 100
!
interface FastEthernet0/25
switchport access vlan 100
!
interface FastEthernet0/26
switchport access vlan 100
!
interface FastEthernet0/27
switchport access vlan 100
!
interface FastEthernet0/28
switchport access vlan 100
!
interface FastEthernet0/29
switchport access vlan 100
!
interface FastEthernet0/30
switchport access vlan 100
!
interface FastEthernet0/31
switchport access vlan 200
speed 100
!
interface FastEthernet0/32
switchport access vlan 200
!
interface FastEthernet0/33
switchport access vlan 200
!
interface FastEthernet0/34
switchport access vlan 200
!
interface FastEthernet0/35
switchport access vlan 200
!
interface FastEthernet0/36
switchport access vlan 200
!
interface FastEthernet0/37
switchport access vlan 200
!
interface FastEthernet0/38
switchport access vlan 200
!
interface FastEthernet0/39
switchport access vlan 200
!
interface FastEthernet0/40
switchport access vlan 200
!
interface FastEthernet0/41
switchport access vlan 28
!
interface FastEthernet0/42
switchport access vlan 28
!
interface FastEthernet0/43
switchport access vlan 28
!
interface FastEthernet0/44
switchport access vlan 28
!
interface FastEthernet0/45
switchport access vlan 28
!
interface FastEthernet0/46
!
interface FastEthernet0/47
!
interface FastEthernet0/48
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1
switchport mode trunk
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
ip address 10.76.0.2 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan12
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan28
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan50
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan100
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
!
interface Vlan200
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
!
ip default-gateway 10.76.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.76.0.1
ip route 10.76.0.0 255.255.255.0 10.76.0.3
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
exec-timeout 30 0
logging synchronous
line vty 0 4

no login
transport input telnet ssh
line vty 5 15

no login
!
ntp clock-period 36029535
ntp server 128.138.140.44
!
end

Vince-Whirlwind
Honored Contributor

Re: HP and Cisco switch connected on my test lab.

Oh boy. Did you just copy and paste your switch configs, incuding all passwords, to a public forum?
You might want to delete your post before your boss finds out what you've done. If an employee of mine did that, I'd have all his logons cancelled immediately and have him re-assigned to building maintenance.

Your Cisco port 48 needs the additional VLANs added to it.

Your HP port 25 needs the additional VLANs added to it.

JOSIAHBOZIAH
Occasional Advisor

Re: HP and Cisco switch connected on my test lab.

@Vince-Whirlwind Thank you much, this is more of test lab at my home, but i totally agree.. which commands do run to add vlans to a port on the HP.

JOSIAHBOZIAH
Occasional Advisor

Re: HP and Cisco switch connected on my test lab.

@Vince-Whirlwind  see below still doesnt work

; J9087A Configuration Editor; Created on release #R.11.72

hostname "mose"
time timezone -360
time daylight-time-rule Continental-US-and-Canada
mirror-port 6
trunk 25 Trk1 Trunk
ip default-gateway 10.76.0.2
ip routing
snmp-server community "public" Unrestricted
vlan 1
name "kenya"
untagged 1,11-24,26
ip address 10.76.0.3 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28,Trk1
no untagged 2-10
exit
vlan 12
name "Servers"
untagged 2-6
ip address 10.76.12.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28,Trk1
exit
vlan 200
name "ArubaAP"
ip address 10.76.200.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28,Trk1
exit
vlan 100
name "HP530AP"
ip address 10.76.100.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28,Trk1
exit
vlan 50
name "Wired_Clients"
untagged 7-10
ip address 10.76.50.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 1,27-28,Trk1
exit
vlan 28
name "Printers"
ip address 10.76.28.1 255.255.255.0
ip helper-address 10.76.12.15
tagged 27-28
exit
ip route 10.76.12.0 255.255.255.0 10.76.0.2
ip route 10.76.50.0 255.255.255.0 10.76.0.2
ip route 10.76.100.0 255.255.255.0 10.76.0.2
ip route 10.76.200.0 255.255.255.0 10.76.0.2
spanning-tree Trk1 priority 4
ip ssh
password manager
password operator

mose#

 

Vince-Whirlwind
Honored Contributor

Re: HP and Cisco switch connected on my test lab.

Your Cisco port 48 needs the additional VLANs added to it.
eg int f0/48 swi tr all vlan 12,28

Your HP port 25 needs the additional VLANs added to it.
eg vlan 12 tag 25
vlan 28 tag 25