Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

IGMP Aruba 2920 multicast problem

 
hector_cordoba
Frequent Visitor

IGMP Aruba 2920 multicast problem

hello 

I have a problem on iptv system, TVs has connection to ip tv video server, clock info, channel names are ok but video cannot be watch. it is all black screen. there is an Access point (ruckus zf7025) between switch and tv, when I reset AP it shows video again and everyting returns normal. but so many reset request is a big problem for me. 

 

I thing I have mismatced smthng on İGMP. I have hp 5400  backbone sw and aruba 2920 edge switches. whiich  has poe ports for access points. 

 

when I check IGMP on an edge switch I see  (querrier value allways zero in all swtiches.)

 

 

switch-12-floor-14-A# sh ip igmp vlan 4

IGMP Service Protocol Info

Total VLANs with IGMP enabled : 1
Current count of multicast groups joined : 1

IGMP Filter Unknown Multicast: Disabled
IGMP Filter Unknown Multicast Status: Disabled

VLAN ID : 4
VLAN Name : IPTV
IGMP version : 2
Querier Address : 172.19.255.100
Querier Port : 48
Querier UpTime : 4d 3h 13m 47s
Querier Expiration Time : 0h 3m 17s

Active Group Addresses Type Expires Ports Reports Queries
---------------------- ---------- --------------- ---------- ------- -------
230.1.1.25 Filter 0h 3m 23s 1 16683 0

 

 

when I check counters

 


switch-12-floor-14-A# sh ip igmp vlan 4 counters

IGMP service Vlan counters

VLAN ID : 4
VLAN Name : IPTV

General Query Rx : 5949
General Query Tx : 0
Group Specific Query Rx : 0
Group Specific Query Tx : 0
V1 Member Report Rx : 0
V2 Member Report Rx : 0
V3 Member Report Rx : 27857
Leave Rx : 0
Unknown IGMP Type Rx : 0
Unknown Pkt Rx : 0
Forward to Routers Tx Counter : 27857
Forward to Vlan Tx Counter : 5949
Port Fast Leave Counter : 0
Port Forced Fast Leave Counter : 0
Port Membership Timeout Counter : 0

 

tx is allways zero.

this is my config on all swtiches.

switch-12-floor-14-A# sh run vlan 4

Running configuration:

vlan 4
name "IPTV"
tagged 1-16,18-25,48
untagged 17
no ip address
ip igmp
exit

my querrier swtich is cisco, different then my Backbone HP swich. what do you think? my igmp works normal or not?

regards

1 REPLY 1
hector_cordoba
Frequent Visitor

Re: IGMP Aruba 2920 multicast problem

hello,

 

I will make my question more simple

 


switch# sh ip igmp vlan 4

IGMP Service Protocol Info

Total VLANs with IGMP enabled : 1
Current count of multicast groups joined : 6

IGMP Filter Unknown Multicast: Disabled
IGMP Filter Unknown Multicast Status: Disabled

VLAN ID : 4
VLAN Name : OTRUM-IPTV
IGMP version : 2
Querier Address : 172.19.255.100
Querier Port : 48
Querier UpTime : 9d 11h 50m 53s
Querier Expiration Time : 0h 3m 58s

Active Group Addresses Type Expires Ports Reports Queries
---------------------- ---------- --------------- ---------- ------- -------
230.1.1.25 Filter 0h 4m 6s 14 54 0
230.3.1.8 Filter 0h 4m 8s 4 12 0
230.3.1.32 Filter 0h 4m 6s 11 93 0
230.3.1.113 Filter 0h 4m 4s 15 281 0
230.3.1.119 Filter 0h 4m 7s 9,20 114 0
230.3.1.128 Filter 0h 4m 10s 13 5 0

 

queries part is all "0" as you can see above. is this normal in an ip tv system?  or is it a clue that my igmp is not working proper. ip tv screens allways freez and I am tring to investigate the incident.