HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Inter VLAN not functioning

 
Nerwin
Occasional Advisor

Inter VLAN not functioning

I really need your expertise on my problem.  I have a core switch and 4 access switches. Inter vlans are not working even if I have already configured IP ROUTING. All the vlans are tagged on ports 2/21-2/24 except vlan 1on the core and on the access switches all vlans are tagged except vlan 1 on the access switches.

 

Thanks in advance for your help.

 

Here is my actual running config.

 

hostname "CORE-SWITCH1"
console idle-timeout 7200
console idle-timeout serial-usb 7200
timesync sntp
sntp unicast
sntp 30
sntp server priority 1 121.58.193.100
time timezone 480
ip dns server-address priority 1 8.8.8.8
ip dns server-address priority 2 4.2.2.2
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip routing
interface 1/11
name "CONNECTION-TO-QNAP"
exit
interface 1/13
name "WIFI_ACCESS_CONNECTION"
exit
interface 1/14
name "WIFI_ACCESS_CONNECTION"
exit
interface 1/15
name "GUEST_ACCESS_CONNECTION"
exit
interface 1/16
name "GUEST_ACCESS_CONNECTION"
exit
interface 2/21
name "CONNECTION-TO-ENGINEERING"
exit
interface 2/22
name "CONNECTION-TO-AM-LOGISTICS-PROC"
exit
interface 2/23
name "CONNECTION-TO-ITandEXECUTIVE"
exit
interface 2/24
name "CONNECTION-TO-DESIGNandFINANCE"
exit
snmp-server community "public" unrestricted
oobm
ip address dhcp-bootp
member 1
ip address dhcp-bootp
exit
member 2
ip address dhcp-bootp
exit
exit
vlan 1
name "MANAGEMENT-VLAN"
no untagged 1/13-1/17
untagged 1/1-1/12,1/18-1/24,1/A1-1/A2,1/B1-1/B2,2/1-2/24,2/A1-2/A2,2/B1-2/B2
ip address 192.168.1.1 255.255.255.0
exit
vlan 20
name "ENGINEERING"
tagged 2/21-2/24
ip address 192.168.20.1 255.255.255.0
dhcp-server
exit
vlan 30
name "AM-LOGISTICS-PROCUREMENT"
tagged 2/21-2/24
ip address 192.168.30.1 255.255.255.0
dhcp-server
exit
vlan 40
name "IT-AND-EXCUTIVE"
tagged 2/21-2/24
ip address 192.168.40.1 255.255.255.0
dhcp-server
exit
vlan 50
name "DESIGN-AND-FINANCE"
tagged 2/21-2/24
ip address 192.168.50.1 255.255.255.0
dhcp-server
exit
vlan 60
name "WIFI"
untagged 1/13-1/14
ip address 192.168.60.1 255.255.255.0
dhcp-server
exit
vlan 70
name "Guest_WIFI"
untagged 1/15-1/16
ip address 192.168.70.1 255.255.255.0
dhcp-server
exit
vlan 100
name "VONAGE"
untagged 1/17
ip address 192.168.100.1 255.255.255.0
dhcp-server
exit
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
dhcp-server pool "WIFI"
default-router "192.168.60.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.60.0 255.255.255.0
range 192.168.60.20 192.168.60.200
exit
dhcp-server pool "VONAGE"
default-router "192.168.100.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.100.0 255.255.255.0
range 192.168.100.20 192.168.100.200
exit
dhcp-server pool "Guest-Wifi"
default-router "192.168.70.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.70.0 255.255.255.0
range 192.168.70.100 192.168.70.120
exit
dhcp-server pool "ENGINEERING"
default-router "192.168.20.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.20.0 255.255.255.0
range 192.168.20.20 192.168.20.200
exit
dhcp-server pool "IT-AND-EXECUTIVE"
default-router "192.168.40.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.40.0 255.255.255.0
range 192.168.40.20 192.168.40.200
exit
dhcp-server pool "AM-LOGISTICS-PROC"
default-router "192.168.30.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.30.0 255.255.255.0
range 192.168.30.20 192.168.30.200
exit
dhcp-server pool "DESIGN-AND-FINANCE"
default-router "192.168.50.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.50.0 255.255.255.0
range 192.168.50.20 192.168.50.200
exit
dhcp-server enable
password manager
password operator

8 REPLIES
Uma_Maheswar
Frequent Advisor

Re: Inter VLAN not functioning

Pls check Ip Default-Gateway on all access switches.

 

Paste access switches config here...

Nerwin
Occasional Advisor

Re: Inter VLAN not functioning

the access switches can be manage with GUI only.

Nerwin
Occasional Advisor

Re: Inter VLAN not functioning

all the access switches default gateway is 192.168.1.1 switch is the IP of the VLAN 1

Uma_Maheswar
Frequent Advisor

Re: Inter VLAN not functioning

None of the Vlans work or only few which has Internal DHCP enabled ?

 

Try creating a testing vlan and check if it works.... 

 

 

vlan 200
name "TEST"
tagged 2/21-2/24
ip address 192.168.200.2 255.255.255.0
dhcp-server
exit

 

dhcp-server pool "TEST"
default-router "192.168.200.1"
dns-server "8.8.8.8"
lease 00:23:59
network 192.168.200.0 255.255.255.0
range 192.168.200.100 192.168.200.120
exit

Nerwin
Occasional Advisor

Re: Inter VLAN not functioning

VLANs are working each client stations are being lease with their own IP. Problem is that vlans 20, 30, 40, 60 and 70 can't ping any device from vlan 50 but any device from vlan 50 can ping the other devices from any other vlan.

Nerwin
Occasional Advisor

Re: Inter VLAN not functioning

I tried the testing VLAN, the same thing vlan 50 can ping going to vlan 200 but vlan 200 can't ping going back to vlan 50

Nerwin
Occasional Advisor

Re: Inter VLAN not functioning

I was able to isolate the problem. It was the firewall blocking the ICMP cousing other vlans not to ping each other. My config was working fine at all.

 

Thanks guys.

 

 

Vince-Whirlwind
Honored Contributor

Re: Inter VLAN not functioning

Just remember: a "ping" is a test of both directions.

If a ping response is successfully received, that means both directions are working.