Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Multicast Routing (Apple Bonjour) on 5406zl

Torsten Kurbad
Occasional Visitor

Multicast Routing (Apple Bonjour) on 5406zl

Hello,

we are about to introduce VLANs to our network. Thus, I successfully set up a 5406zl (incl. Premium Edge license) to act as a routing switch between 15 VLANs.

There's, however, still one issue left:
The printers in VLAN 4 should be able to advertise themselves via Bonjour to VLAN 8. Therefore, I enabled multicast-routing, pim, and rip in the global context of the switch as well as pim-dense, rip, and igmp in the affected VLANs (4 and 8).

Nontheless, the clients in VLAN 8 are unable to see the bonjour printers in VLAN 4.

What am I missing here?

Thank you in advance
Torsten

Here's the relevant excerpt from my running-config:

Running configuration:

; J8697A Configuration Editor; Created on release #K.15.03.0007

hostname "xxx"
max-vlans 200

module 2 type J9535A
module 3 type J9534A
module 4 type J8705A
ip routing
no ip source-route
vlan 1
name "MANAGEMENT"
untagged C2
ip address 10.168.1.1 255.255.255.0
tagged B19,C1,C3
no untagged B1-B18,B20-B24,C4-C24,D1-D24
exit
vlan 2
name "SERVERS"
untagged B20
ip address 192.168.0.1 255.255.0.0
tagged B19
jumbo
exit
vlan 3
name "BACKUP"
ip address 10.168.3.1 255.255.255.0
tagged B19
jumbo
exit
vlan 4
name "PRINTERS"
untagged B1
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.4.1 255.255.255.0
tagged B19
ip igmp
exit
vlan 5
name "ADMINISTR"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.5.1 255.255.255.0
tagged B19
exit
vlan 8
name "CLIENTS"
untagged C1,C3-C5
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.8.1 255.255.248.0
tagged B19
ip igmp
exit
vlan 20
name "CLASSROOM"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.20.1 255.255.254.0
tagged B19
exit
vlan 30
name "EXPERIMENTS"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.30.1 255.255.254.0
tagged B19
exit
vlan 40
name "DEPLOYMENT"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.40.1 255.255.254.0
tagged B19
jumbo
exit
vlan 50
name "VPN"
ip address 10.168.50.1 255.255.255.0
tagged B19
exit
vlan 60
name "TRANSFER"
ip address 10.168.60.1 255.255.255.0
tagged B19
jumbo
exit
vlan 70
name "VOICE"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.70.1 255.255.254.0
tagged B19
voice
jumbo
exit
vlan 80
name "GUESTS"
untagged B2-B18,B21-B24,C6-C24,D1-D24
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.80.1 255.255.254.0
tagged B19
exit
vlan 100
name "DMZ"
ip address 10.168.100.1 255.255.255.0
tagged B19
exit
vlan 90
name "GUESTS_WLAN"
ip helper-address 192.168.0.21
ip helper-address 192.168.0.22
ip address 10.168.90.1 255.255.254.0
tagged B19
exit
dhcp-snooping
dhcp-snooping authorized-server 192.168.0.21
dhcp-snooping authorized-server 192.168.0.22
dhcp-snooping vlan 1-100
include-credentials
password operator sha1 "xxx"
password manager user-name "root" sha1 "xxx"
power-over-ethernet pre-std-detect
timesync sntp
sntp unicast
sntp 60
sntp server priority 1 192.168.1.254
no telnet-server
no web-management
web-management ssl
ip dns domain-name "xxx"
ip dns server-address priority 1 192.168.1.254
ip dns server-address priority 2 192.168.1.10
ip route 0.0.0.0 0.0.0.0 192.168.1.254
ip route 192.168.0.0 255.255.0.0 vlan 2
ip multicast-routing
router rip
redistribute connected
exit
router pim
state-refresh 45
trap hardware-mrt-full
exit
interface B1
dhcp-snooping trust
exit
interface B2
dhcp-snooping trust
exit
interface B3
...

snmp-server community "public" unrestricted
snmp-server contact "xxx" location "xxx"
snmpv3 engineid "xxx"
vlan 4
ip rip 10.168.4.1
ip pim-dense
ip-addr any
exit
exit
vlan 8
ip rip 10.168.8.1
ip pim-dense
ip-addr any
exit
exit
primary-vlan 2
management-vlan 1
no autorun
no dhcp config-file-update
no dhcp image-file-update

 

P.S. This thread has been moved from Switches, Hubs, Modems (Legacy ITRC forum) to ProCurve / ProVision-Based. -HP Forum Moderator

4 REPLIES
Antonio Milanese
Trusted Contributor

Re: Multicast Routing (Apple Bonjour) on 5406zl

Hello,

http://developer.apple.com/networking/bonjour/faq.html

IIRC the multicast mDNS range is 224.0.0.x and so the switch assume (per RFC) it's a mcast address for propagation on the local subnet only! AFAIK no way you can route mDNS between vlans..

Best regards,

Antonio
Torsten Kurbad
Occasional Visitor

Re: Multicast Routing (Apple Bonjour) on 5406zl

Hello Antonio,

thank you for your quick reply.

I was able to solve the issue, without utilizing multicast, by static DNS-entries, i.e. "wide area bonjour".

Best regards,
Torsten
Husseinali201
Occasional Visitor

Re: Multicast Routing (Apple Bonjour) on 5406zl

Hi ,

 

please how do you solve this problem ?


Torsten Kurbad wrote:
Hello Antonio,

thank you for your quick reply.

I was able to solve the issue, without utilizing multicast, by static DNS-entries, i.e. "wide area bonjour".

Best regards,
Torsten

 

Fernando_Osorio
Occasional Visitor

Re: Multicast Routing (Apple Bonjour) on 5406zl

Kindly, Could you explain How you made it work, I am in the same situacion with my printers and i want to "share" those between vlans

Regards,

Fernando