Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Need help configuring multicast between switches and vlans

 

Need help configuring multicast between switches and vlans

I inherrited a previously configured VOIP system that at one time was successfully configured for multicast paging to phones at a school district. It is currently broken and I need assistance issuing commands for troubleshooting and  modifying the configs to get it working again.

My environment:

Near end:

HP 5440z
(All voip servers configured for vlan 110)

Far end:

HP 3500yl

(All voip devices configured for vlan 72)

Port 20 on the 3500 connects to the school district LAN on vlan 72

 

In short, I need pages made from vlan 72 to hit our Informacast server on vlan 110 (across the WAN), and play on all phones on vlan 72. At present time this fails. The phones seem to sense the page but do not play it.

 

I have run the following commands below  to see if it would reveal what is broken or missing in the configs. (Apologies... could not get file to upload)

 

Are there more troubleshooting steps available to determine what changes are needed to get this working?

LCTN Edge Switch (HP 5440z)
vlan 110
name "VLAN110"
untagged A3,B5-B6
tagged
(port list)
ip address 10.201.0.1 255.255.248.0
ip igmp
ip igmp forward (port list)
qos priority 7
forbid B2
voice
exit
display igmp interface Interface information Vlan-interface110(10.201.0.1): IGMP is enabled Current IGMP version is 2 Value of query interval for IGMP(in seconds): 125 Value of other querier present interval for IGMP(in seconds): 255 Value of maximum query response time for IGMP(in seconds): 10 Querier for IGMP: 10.201.0.1 (this router) Total 3 IGMP Groups reported display igmp group Interface group report information Vlan-interface110(10.201.0.1): Total 3 IGMP Groups reported Group Address Last Reporter UpTime Expires 239.255.255.250 10.201.0.4 196d 04:... 00:03:48 239.255.255.253 10.201.0.15 78d 02:0... 00:03:40 239.255.255.254 10.201.0.5 35d 22:4... 00:03:42 display multicast forwarding-table No results display pim routing-table No results display pim neighbor VPN-Instance: n/a Total Number of Neighbors = n/a Neighbor Interface Uptime Expires Dr-Priority Mode display pim interface No results display pim re-info invalid input display pim bsr-info PIM-SM is not enabled ---------------------------------------------------------------------------------------------------------------------------- KMS Switch: (HP 3500YL) vlan 72 name "VLAN72" untagged 17,20,22 tagged 1 ip address 10.201.72.1 255.255.248.0 ip igmp exit vlan 110 name "VLAN110" tagged 1 ip address 10.201.120.3 255.255.248.0 ip pim-sparse ip-addr any exit exit display igmp interface Interface information Vlan-interface72(10.201.72.1): IGMP is enabled Current IGMP version is 2 Value of query interval for IGMP(in seconds): 125 Value of other querier present interval for IGMP(in seconds): 255 Value of maximum query response time for IGMP(in seconds): 10 Querier for IGMP: 10.201.72.1 (this router) display igmp group No results display multicast forwarding-table Matched 0 packets(bytes n/a), Wrong If 0 packets Forwarded 0 packets(0 bytes) display pim routing-table No results display pim neighbor VPN-Instance: n/a Total Number of Neighbors = n/a Neighbor Interface Uptime Expires Dr-Priority Mode display pim interface Neighbor Interface Uptime Expires Dr-Priority Mode VPN-Instance: n/a Interface NbrCnt HelloInt DR-Pri DR-Address Vlan110 n/a 30 1 10.201.120.3 display pim re-info invalid input display pim bsr-info VPN-Instance: n/a Elected BSR Address: 0.0.0.0 Priority: 0 Hash mask length: 0 State: Elected Scope: n/a Uptime: 00:00:00 Next BSR message scheduled at: 00:00:00 Candidate BSR Address: 0.0.0.0 Priority: 0 Hash mask length: 30 State: Elected

 

3 REPLIES 3
Som77
HPE Pro

Re: Need help configuring multicast between switches and vlans

Hi Raymond,

As mentioned The VOIP system was successfully working for multicast paging earlier and now its not working,

1>Was it the same set-up where multicast was working before or has there been any changes in the config/set-up.

2>HP 5440z// HP 3500yl Please provide the Product Number and current running software for both.

3>Since we do not know what version the 3500yl is running, recommend you to please go through below release notes for any software issue identiication.
https://support.hpe.com/hpsc/doc/public/display?docId=a00059460en_us

4> Since we do not have the complete show tech all, Prior working configuration and show logg information to see and analyze configuration and log events that would indicate any issues/failures to isolate the problem
Recommend to go through Multicast and Routing Guide for Multicast Configuration of PIM-SM for Operating Notes, Configuration Pre-requisties, Troubleshooting with Display Commands.

 



I am a HPE Employee

Accept or Kudo

Re: Need help configuring multicast between switches and vlans

Here is the firmware info:

HP 5440z:
Image stamp:
/ws/swbuildm/rel_portland_qaoff/code/build/bom(swbuildm_rel_portland_qaoff_rel_
portland)
Jun 17 2015 16:11:24
KB.15.17.0007
884
Boot Image: Primary

Boot ROM Version: KB.15.01.0001
Active Boot ROM: Primary

 

I came in on this issue only after it was reported that things were broken, so I am not aware of what the config once looked like when it was working correctly.

I have taken a few hours to look through online documentation on multicasting again but have not found an issue that reveals why things are not workng. I think the best approach for me would be to provide the connection details and ask how each switch should be configured.

The VOIP servers are VMs, connecting to the 5440 on ports A12&A13 on vlan 110. Port B21 of the same switch connects to our WAN. On the far end (HP3500yl) Vlan 110 is tagged on int 1 and 17. Port 1 connects to our WAN

The school phones (vlan 72) hang off of port 17 of the 3500yl.

The informacast server is part of vlan 110.

Flow:

User inititiates a voice page on a vlan 72 phone device.

Page hits the Informacast server across the WAN on vlan 110

Page is played on all participating vlan 72 phones.

With this scenario, what what should the config look like on the 5440z and 3500?

 

Som77
HPE Pro

Re: Need help configuring multicast between switches and vlans

Hi Raymond,

I assume,  Apart from 3500yl  you have Aruba 5412 Switch running KB.15.17.0007 ver which is from JAN-2016, where the servers are connected,.

Both switch (5400 and 3500 series) configuration needs to be looked at first and if necessary have the latest firmware for these switches, other than examples provided in Manual for configuring Multicast, there is no other cookbook related to this Multicast Configuration.

https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-a00055703en_us&withFrame 

I recommend to log a support case to have deeper analysis of logs/configuration and troubleshoot further.

 

 



I am a HPE Employee

Accept or Kudo