Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

OPSF Routing Issue

 
Occasional Contributor

OPSF Routing Issue

Hi,

 

I seem to have a ospf Routing issue, it is quite a simple setup, I have 2 3500 switches in two different locations with 2 circuits between them,

 

Swicth A                                                            Switch B

-------------------             10 Mb               ------------------ 

|               Port 23   |---------------------|   Port 23              |

|               Port 24   |---------------------|   Port 24              |

|-----------------|              100Mb             |-----------------

 

All I want to do is have the 100Mb link as the main and the 10 Mb to be a backup in the event of a failure.

 

I have configured ospf but I seem to have routes to different subnets on each switch going over both circuits rather than the one,  I have enclosed my currenty config, I just need a way force the traffic over the 100 Mb circuit 1st,

 

Running configuration:

; J8692A Configuration Editor; Created on release #K.14.84

hostname "Switch A"
time timezone 60
time daylight-time-rule Western-Europe
module 1 type J86xxA
interface 1
   name "802-1q_To_Data_1_Port49"
exit
interface 2
   name "802-1q_To_Data_1_Port50"
exit
interface 3
   name "802-1q_To_Data_2(NC)"
exit
interface 4
   name "802-1q_To_Data_2(NC)"
exit
interface 5
   name "802-1q_To_Voice_1_Port49"
exit
interface 6
   name "802-1q_To_Voice_1_Port50"
exit
interface 7
   name "802.1q_To_Voice_2(NC)"
exit
interface 8
   name "802.1q_To_Voice_2(NC)"
exit
interface 9
   name "Wireless_1"
exit
interface 10
   name "Wireless_2"
exit
interface 11
   name "802-1q_To_Server_1_Port23"
exit
interface 12
   name "802-1q_To_Server_1_Port24"
exit
interface 13
   name "802-1q_To_Server_2_Port23"
exit
interface 14
   name "802-1q_To_Server_2_Port24"
exit
interface 15
   name "SAN1"
exit
interface 16
   name "SAN2"
exit
interface 17
   name "Guest_Wifi_1"
exit
interface 18
   name "Guest_Wifi_2"
exit
interface 23
   name "Ospf_10MB"
exit
interface 24
   name "Ospf_100MB"
   speed-duplex 100-full
exit
trunk 1-2 Trk1 Trunk
trunk 3-4 Trk2 Trunk
trunk 5-6 Trk3 Trunk
trunk 7-8 Trk4 Trunk
trunk 11-12 Trk5 Trunk
trunk 13-14 Trk6 Trunk
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 19-22,Trk1-Trk6
   ip address 192.168.101.254 255.255.255.0
   no untagged 9-10,15-18,23-24
   exit
vlan 160
   name "Data"
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip address 192.168.160.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 161
   name "Voice"
   ip helper-address 192.168.161.1
   ip helper-address 192.168.163.1
   ip address 192.168.161.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 162
   name "Wireless"
   untagged 9
   ip helper-address 192.168.163.1
   ip address 192.168.162.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 163
   name "Server"
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip address 192.168.163.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 164
   name "San"
   untagged 15-18
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip address 192.168.164.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 165
   name "Gst_Wireless"
   untagged 10
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip address 192.168.165.254 255.255.255.0
   tagged Trk1-Trk6
   exit
vlan 172
   name "10MB Link"
   untagged 23
   ip address 172.16.160.2 255.255.255.0
   exit
vlan 173
   name "100MB Link"
   untagged 24
   ip address 172.16.170.2 255.255.255.0
   exit
timesync sntp
sntp unicast
sntp server priority 1 192.168.163.1 3
sntp server priority 2 192.168.153.1 3
router ospf
   area backbone
   redistribute connected
   redistribute static
   exit
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 4
spanning-tree Trk2 priority 4
spanning-tree Trk3 priority 4
spanning-tree Trk4 priority 4
spanning-tree Trk5 priority 4
spanning-tree Trk6 priority 4
vlan 172
   ip ospf 172.16.160.2 area backbone
   exit
vlan 173
   ip ospf 172.16.170.2 area backbone
   exit
no autorun

 

 

 

Switch B

Running configuration:

; J8692A Configuration Editor; Created on release #K.14.84

hostname "Switch B"
time daylight-time-rule Western-Europe
module 1 type J86xxA
interface 1
   name "802-1q_To_Data_1_Prt49"
   no power-over-ethernet
exit
interface 2
   name "802-1q_To_Data_1_Prt50"
   no power-over-ethernet
exit
interface 3
   name "802-1q_To_Data_2_Prt49"
   no power-over-ethernet
exit
interface 4
   name "802-1q_To_Data_2_Prt50"
   no power-over-ethernet
exit
interface 5
   name "802-1q_To_Voice_1_Prt49"
   no power-over-ethernet
exit
interface 6
   name "802-1q_To_Voice_1_Prt50"
   no power-over-ethernet
exit
interface 7
   name "802-1q_To_Voice_2_Prt25"
   no power-over-ethernet
exit
interface 8
   name "802-1q_To_Voice_2_Prt26"
   no power-over-ethernet
exit
interface 9
   name "Wifi Connection"
   no power-over-ethernet
exit
interface 10
   name "Wifi Connection"
   no power-over-ethernet
exit
interface 11
   name "802-1q_To_Voice_1_Prt23"
   no power-over-ethernet
exit
interface 12
   name "802-1q_To_Voice_1_Prt24"
   no power-over-ethernet
exit
interface 13
   name "802-1q_To_Voice_2_Prt23"
   no power-over-ethernet
exit
interface 14
   name "802-1q_To_Voice_2_Prt24"
   no power-over-ethernet
exit
interface 15
   name "Storage / Live Migration Management SW1"
   no power-over-ethernet
exit
interface 16
   name "Storage / Live Migration Management SW2"
   no power-over-ethernet
exit
interface 17
   no power-over-ethernet
exit
interface 18
   no power-over-ethernet
exit
interface 19
   no power-over-ethernet
exit
interface 20
   name "Firewall 1"
   no power-over-ethernet
exit
interface 21
   name "Firewall 2"
   no power-over-ethernet
exit
interface 22
   name "Existing LAN"
   no power-over-ethernet
exit
interface 23
   name "OSPF_10MB"
   no power-over-ethernet
exit
interface 24
   name "OSPF_100MB"
   speed-duplex 100-full
   no power-over-ethernet
exit
trunk 1-2 Trk1 Trunk
trunk 3-4 Trk2 Trunk
trunk 5-6 Trk3 Trunk
trunk 7-8 Trk4 Trunk
trunk 11-12 Trk5 Trunk
trunk 13-14 Trk6 Trunk
trunk 17-18 Trk8 Trunk
ip default-gateway 192.168.150.250
ip routing
vlan 1
   name "DEFAULT_VLAN"
   untagged 15-16,19,Trk1-Trk6
   ip address 192.168.100.254 255.255.255.0
   tagged Trk8
   no untagged 9-10,20-24
   exit
vlan 150
   name "Data"
   untagged 20-21
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip address 192.168.150.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 151
   name "Voice"
   ip helper-address 192.168.151.1
   ip helper-address 192.168.153.1
   ip address 192.168.151.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 152
   name "Wireless"
   untagged 9
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip address 192.168.152.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 153
   name "Server"
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip address 192.168.153.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 154
   name "San"
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip address 192.168.154.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 155
   name "Gst_Wireless"
   untagged 10
   ip helper-address 192.168.153.1
   ip helper-address 192.168.153.2
   ip helper-address 192.168.163.1
   ip helper-address 192.168.163.2
   ip address 192.168.155.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 54
   name "Old_Torquay_Lan"
   untagged 22
   ip address 192.168.54.245 255.255.255.0
   exit
vlan 172
   name "VLAN172"
   untagged 23
   ip address 172.16.160.1 255.255.255.0
   exit
vlan 173
   name "VLAN173"
   untagged 24
   ip address 172.16.170.1 255.255.255.0
   exit
vlan 156
   name "VirtualDesktop"
   ip address 192.168.156.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 157
   name "VirtualServer"
   ip address 192.168.157.254 255.255.255.0
   tagged Trk1-Trk6,Trk8
   exit
vlan 158
   name "Migration"
   ip address 192.168.158.254 255.255.255.0
   tagged Trk8
   exit
vlan 159
   name "VirtualPC"
   ip address 192.168.159.254 255.255.255.0
   tagged Trk8
   exit
timesync sntp
sntp unicast
sntp 30
sntp server priority 1 192.168.153.1 3
sntp server priority 2 213.239.163.1 3
ip dns server-address priority 1 81.17.66.13
ip route 0.0.0.0 0.0.0.0 192.168.150.250
ip route 172.16.18.0 255.255.255.0 192.168.54.254
ip route 192.168.50.0 255.255.255.0 192.168.54.254
ip route 192.168.51.0 255.255.255.0 192.168.54.254
ip route 192.168.52.0 255.255.255.0 192.168.54.254
ip route 192.168.53.0 255.255.255.0 192.168.54.254
ip route 192.168.180.0 255.255.255.0 192.168.150.250
router ospf
   area backbone
   redistribute connected
   redistribute static
   exit
snmp-server community "public" unrestricted
spanning-tree
spanning-tree Trk1 priority 1
spanning-tree Trk2 priority 1
spanning-tree Trk3 priority 1
spanning-tree Trk4 priority 1
spanning-tree Trk5 priority 1
spanning-tree Trk6 priority 1
spanning-tree Trk8 priority 1
spanning-tree priority 0

vlan 172
   ip ospf 172.16.160.1 area backbone
   exit

vlan 173
   ip ospf 172.16.170.1 area backbone
   exit
no autorun
password manager
password operator

 

 

Thanks

 

 

 

P.S. This thread has beenmoevd from Switches, Hubs, Modems (Legacy ITRC forum) to ProCurve / ProVision-Based. - Hp Forum Moderator

 

2 REPLIES 2
Honored Contributor

Re: OPSF Routing Issue

Howdy,
How about -
sh ip ospf interface
to see what the link costs are (default used to be just = 1 so all links were equal - therefore liable to ECMP) and then :
vlan 172
ip ospf cost 100
exit
vlan 173
ip ospf cost 10
exit
Repeat on other switch.
Puts a lower metric on your faster link.
Let us know if that does the trick
HTH
Ian
Hope that helps - please click "Thumbs up" for Kudos if it does
## ---------------------------------------------------------------------------##
Which is the only cheese that is made backwards?
Edam!
Tweets: @2techie4me
Occasional Contributor

Re: OPSF Routing Issue

Hi Ian,

 

Worked a treat, thankyou very much.

 

Andy ..