Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Procurve takes long time out bring port up - PXE timeout

 
hpbon
Advisor

Procurve takes long time out bring port up - PXE timeout

Got a client with a very short PXE boot timeout. It is attached to a procurve switch that takes a loooooong time to bring a port up. Can I reduce this time somehow?

Regards, Lars.

3 REPLIES
parnassus
Honored Contributor

Re: Procurve takes long time out bring port up - PXE timeout

Is it TFTP PXE Boot timeout?

The Switch port should change its status from Down to Up in a reasonable time (speedy enough)...once the device powers its NIC.

Probably you should play a little bit with STP and Edge port's settings (changing from "Auto" to "Enable" on that particular port) provided that your ProCurve based Switch will let you...this in order to speed up the forwarding state of that port: once the port links up the forwarding state is immediately reached without delay (with "Auto" few seconds will pass to let STP to resolve for potential loops).

hpbon
Advisor

Re: Procurve takes long time out bring port up - PXE timeout

Switch is a HP 2530-48G Switch (J9775A) YA.16.02.0008, ROM YA.15.19 and it takes long time for the port to come up (ligths on the NIC/port)

This makes the PXE agent fail on "checking media" (even before it starts TFTP)

Regards, Lars.

parnassus
Honored Contributor

Re: Procurve takes long time out bring port up - PXE timeout

Don't know if {R|M}STP is enabled or not on your Switch...but, generally, to enable the immediate transition to the forwarding state for a (known) Edge port on a Switch that has STP enabled you would use a command like:

spanning-tree <port-list> admin-edge-port

Syntax:

[no] spanning-tree <port-list> admin-edge-port

Enables admin-edge-port on ports connected to end nodes. During spanning tree establishment, ports with admin-edge-port enabled transition immediately to the forwarding state. If a bridge or switch is detected on the segment, the port automatically operates as non-edge, not enabled.

Default: Disabled

If admin-edge-port is disabled on a port and auto-edge-port has not been disabled, the auto-edge-port setting controls the behavior of the port.

The no form of this command disables edge port operation on the specified ports.

There is also spanning-tree forward-delay (default: 15 seconds)...which sets time that the Switch waits between transitioning from listening to learning and from learning to forwarding states...so, probably, you could also change (lower) that time down to 4 seconds (which is the minimum admitted, if enough for your scenario)...if you don't want to set that port as an admin-edge-port instead of the default auto-edge-port.