Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk Issues (Comware vs Procurve)

 
coffeebreakteam
Occasional Advisor

Trunk Issues (Comware vs Procurve)

Good Day to all!

My current setup is this:

1 A5500 24G Switch

1 2920 - 24G Procurve Switch

1 IP Phone

1 Laptop

 

A5500 is already in the network and I want to trunk the Procurve where all IP Phones are connected.

A5500: (i created a new bagg for this)

interface Bridge-Aggregation20
description LINK to PROCURVE
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan A B -> A is Voice / B is VLAN of floor
link-aggregation mode dynamic

for the port:

interface GigabitEthernet2/0/24
port link-mode bridge
port link-type trunk
port trunk permit vlan A B
undo trunk permit vlan 1
voice vlan A enable

for the procurve:

VLAN A
name VOICE
tagged 1-24

I did not used trunk e 24 trk1 trunk/lacp since both voice and data cannot pass. Voice gets through but data does not. Any walkthroughs on this and tips on proper configuration between Comware and Procurve? (trunk setting preferred)

Thank You!

 

6 REPLIES 6
Highlighted
parnassus
Honored Contributor

Re: Trunk Issues (Comware vs Procurve)

This page should be of help.

Highlighted
coffeebreakteam
Occasional Advisor

Re: Trunk Issues (Comware vs Procurve)

Hi Parnassus,

I tried the config stated on that page, but still, no connection.

I tried another way. Setting the A5500 port as hybrid and adding the Voice VLAN to the untagged vlans.


port hybrid vlan A B untagged

May I know the risks of this setting?

 

Thank You!

Highlighted
parnassus
Honored Contributor

Re: Trunk Issues (Comware vs Procurve)

Did you followed exactly the steps on that guide? especially on Comware based switches is very important to follow the right order of commands (not messing up single physical ports members of the LAG after you have set up the LAG and, IMHO, starting with future LAG member ports in a default state).

Have you tested by permitting VLAN 1 on the logical LAG interface other than your other two VLANs (named VLAN "a" for your Voice traffic and "b" for your data traffic) or what?

Can you show us your current configurations for all involved ports logical (LAG)/physical (LAG members) and for all involved VLANs, on both sides of your Trunk (Comware/ProCurve)?

It's shouldn't be so tricky to setup a Port Trunking (Static or LACP) and permitting some VLANs flowing through it.

Highlighted
coffeebreakteam
Occasional Advisor

Re: Trunk Issues (Comware vs Procurve)

Good Day!

I followed through the step by step process on your reply:

1. create a bridge aggregation group (encoded also the link-agg mode dynamic)

2. port membership association (gi2/0/24)

3. return to the aggregation group and make changes. (trunks and vlan memberships)

I created a new aggregation (BAGG 70), included port gi2/0/24, and returned to the bridge-aggregation config and performed trunk permissions and others. switched to procurve and only encoded VLAN 2 as voice. it has the default VLAN (1). It can receive voice packets but not data packets.

On the 5500:

[Distribution-Bridge-Aggregation70]dis this

#
interface Bridge-Aggregation70
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 27 (2 as voice / 27 as data / we used separate vlans per floors)
link-aggregation mode dynamic

----------------------------------------------

#
interface GigabitEthernet2/0/24
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 27
port link-aggregation group 70

What could be the error here?

Procurve settings are blank and I only added VLAN 2 and classified it as voice vlan. We set VLAN 1 as Server Farm VLAN and decided not to allow it to accessed by other VLANS.

Thank You.

Highlighted
parnassus
Honored Contributor

Re: Trunk Issues (Comware vs Procurve)

Sorry for asking but really have you a BAGG (Bridge-Aggregation70) with only one physical member port (ge2/0/24) assigned to it? it's unclear to me...

What is the status of the BAGG defined on the Comware side? perform the command:

display link-aggregation verbose Bridge-Aggregation 70

What is the status of the BAGG defined on the ProCurve side? the command to evaluate the BAGG status is similar to the one used on the Comware but it uses show instead of display if I recall correctly (show trunks and show lacp).

What is the status of BAGG's VLAN IDs and PVIDs on both sides? see here also this post for managing the Untagged VLAN of logical BAGG Trunk port (on both sides)...if you removed the VLAN 1 as its default PVID.

What do you mean with the statement "Procurve settings are blank..."? what do you mean with "blank"?

Highlighted
rouletteyou
Occasional Visitor

Re: Trunk Issues (Comware vs Procurve)

Switch Side

#
undo voice vlan security enable
#
interface GigabitEthernet1/0/4
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan A B
port trunk pvid vlan B
undo voice vlan mode auto
voice vlan A enable
broadcast-suppression pps 3000
undo jumboframe enable
poe enable
stp edged-port enable
lldp compliance admin-status cdp txrx
#
interface Ten-GigabitEthernet1/2/1
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
port trunk pvid vlan 999
port link-aggregation group 1
#
interface Ten-GigabitEthernet1/2/2
port link-mode bridge
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan 2 to 4094
port trunk pvid vlan 999
port link-aggregation group 1
shut
#

Edge Side

#
interface Ten-GigabitEthernet6/0/4
port link-mode bridge
description Bridge_Aggregation_4
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan A B
port trunk pvid vlan 999
port link-aggregation group 4
#
interface Ten-GigabitEthernet7/0/x
port link-mode bridge
description Bridge_Aggregation_4
port link-type trunk
undo port trunk permit vlan 1
port trunk permit vlan A B
port trunk pvid vlan 999
port link-aggregation group 4
#