Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunk mode with HP Switches

 
fga76
Occasional Advisor

Trunk mode with HP Switches

I am facing a problem within my network.

The scenario is this.

I have two HP 2920-24G Switch (J9726A). They are connected with each other and also both are connected to a HP V1910-24G Switch (JE006A) and a 3Com Baseline Switch 2952-SFP Plus.

The ports between those switches are not in trunk mode.

When I put the ports in trunk mode, I lost connection within my network. With a serial cable connected to the HP V1910-24G Switch (JE006A) switch, I can see the port I putted in trunk going up and down. Below is the log error:

Jul 31 17:49:20:338 2017 SW03 IFNET/4/INTERFACE UPDOWN: Trap 1.3.6.1.6.3.1.1.5.3: Interface 9437206 is Down, ifAdminStatus is 1, >ifOperStatus is 2

Jul 31 17:49:20:520 2017 SW03 IFNET/4/LINK UPDOWN: GigabitEthernet1/0/23: link status is DOWN

Jul 31 17:49:22:819 2017 SW03 IFNET/4/INTERFACE UPDOWN: Trap 1.3.6.1.6.3.1.1.5.4: Interface 9437206 is Up, ifAdminStatus is 1, >ifOperStatus is 1

Jul 31 17:49:23:00 2017 SW03 MSTP/1/PFWD:hwPortMstiStateForwarding: >Instance 0's Port 0.9437206 has been set to forwarding state!

Jul 31 17:49:23:160 2017 SW03 IFNET/4/LINK UPDOWN: GigabitEthernet1/0/23: link status is UP

Jul 31 17:49:23:280 2017 SW03 MSTP/2/PFWD:Instance 0's >GigabitEthernet1/0/23 has been set to forwarding state!

This happens on the other switches as well.

I have 8 vlans that are all configured in all switches across the network. The management vlan is 1 (default).

I don't have the ports in trunk mode now because the problem.

Is this a STP problem?

Where and what should I look for? How could I solve this problem?

Here is the image with the scenario I described above

f_almeida
10 REPLIES 10
AbeAbe
Trusted Contributor

Re: Trunk mode with HP Switches

Hi,

a Comeware trunk is a tagged interface in procurve cli

so if you have sonthing like

interface Gigabitethernet1/01

port-link type trunk

exit

 

that would be at the procurve side:

vlan x tag 24

vlan y tag 24

etc

 

hth

Alex

fga76
Occasional Advisor

Re: Trunk mode with HP Switches

Hi. Well, I didn't get at all what you told me to do.

Here as the configuration of both switches, without the ports in trunk mode because it causes my network to stop.

SWSRV01
Running configuration:

; J9726A Configuration Editor; Created on release #WB.15.16.0006
; Ver #06:0c.fc.f3.ff.35.0d:c2

hostname "SWSRV01"
module 1 type j9726a
console idle-timeout 600
password minimum-length 10
timesync sntp
sntp unicast
sntp server priority 1 10.10.1.12
no telnet-server
time timezone -180
no web-management
web-management ssl
snmp-server community "public" operator
snmp-server host 10.10.1.60 community "public" trap-level all
snmp-server contact "9877" location "Rack"
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT"
   untagged 1-24,A1-A2,B1-B2
   ip address 10.10.1.100 255.255.254.0
   exit
vlan 100
   name "100"
   no ip address
   exit
vlan 110
   name "110"
   no ip address
   exit
vlan 120
   name "120"
   no ip address
   exit
vlan 130
   name "130"
   no ip address
   exit
vlan 140
   name "140"
   no ip address
   exit
vlan 150
   name "150"
   no ip address
   exit
vlan 160
   name "160"
   no ip address
   exit
vlan 170
   name "170"
   no ip address
   exit
spanning-tree
spanning-tree mode rapid-pvst
spanning-tree vlan 1 root primary
spanning-tree root primary
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager 
password operator
---------------
SRV02

Running configuration:

; J9726A Configuration Editor; Created on release #WB.15.16.0006
; Ver #06:0c.fc.f3.ff.35.0d:c2

hostname "SWSRV02"
module 1 type j9726a
timesync sntp
sntp unicast
sntp server priority 1 10.10.1.12
no telnet-server
time timezone -180
no web-management
web-management ssl
ip default-gateway 10.10.1.252
snmp-server community "public"
snmp-server host 10.10.1.60 community "public" trap-level all
snmp-server contact "9877" location "Rack"
oobm
   ip address dhcp-bootp
   exit
vlan 1
   name "DEFAULT"
   untagged 1-24,A1-A2,B1-B2
   ip address 10.10.1.101 255.255.254.0
   exit
vlan 100
   name "100"
   no ip address
   exit
vlan 110
   name "110"
   no ip address
   exit
vlan 120
   name "120"
   no ip address
   exit
vlan 130
   name "130"
   no ip address
   exit
vlan 140
   name "140"
   no ip address
   exit
vlan 150
   name "150"
   no ip address
   exit
vlan 160
   name "160"
   no ip address
   exit
vlan 170
   name "170"
   no ip address
   exit
spanning-tree
spanning-tree mode rapid-pvst
spanning-tree priority 2
no tftp server
no autorun
no dhcp config-file-update
no dhcp image-file-update
password manager
password operator
f_almeida
parnassus
Honored Contributor

Re: Trunk mode with HP Switches

Strange, on SWSRV01 and SWSRV02 (both HP 2920-24G) there are few non Default (port based, since the no ip address) VLAN IDs configured (VLAN IDs are: 100, 110, 120, 130, 140, 150, 160 and 170)...but NO port of those Switches is assigned as tagged member (of one or multiple) or untagged member (of one and only one) of those VLAN IDs (the directive on VLAN ID 1 means you have all ports - 1-24, A1-A2 and B1-B2 of each 2920-24G - as untagged members of Default VLAN ID 1, that's OK...but what's the purpose of having others VLAN IDs defined if no physical/logical port is configured to be member of them?).

AFAIK with STP properly configured on all four units you should see at least two uplinks automatically down (respectively one of those originating on SW03 and originating on SW04) facing the 2920s...that's to avoid a double loop (SW04-SWSRV02-SWSRV01-SW04 and SW03-SWSRV01-SWSRV02-SW03).

fga76
Occasional Advisor

Re: Trunk mode with HP Switches

Just another question/doubt.

If i use a stacking option, would it resolve the problem?

SRV01 as a commander and SRV02 as a member. The VLANs msut come across both switches because within my network I have other switches with distinguished VLANs (besides the default). For example, VLAN 100 is for servers, VLAN 110 is for printers, VLAN 120 is for Wifi, and so on. All those must come across the network to both SRV01 and SRV02 because I have servers connected to it.

Also my internet links are connected on those switches. I didn't assing a VLAN to the ports wet because I am setting all the trunk ports first. After that, I will apply an IP address to each VLAN interface on each switch of my network.

I am in a process of changing my IP address range. That's why I am creating different VLANs for different IP segment. Hope my explanation helps the understanding. thanks

f_almeida
parnassus
Honored Contributor

Re: Trunk mode with HP Switches

OK, now it's clear.

If you are going to deploy backplane stacking on two HP 2920 (using dedicated Stacking modules and Stacking Cables) your network topology is going to change too: at that point the cluster of two stacked 2920 will become a single virtual logical switch and both SW03 and SW04 can then be connected using, each one, a Port Trunk (where Port Trunk means here aggregated interfaces also known as LAG or BAGG, configured to use LACP) with member links (e.g. SW03 Trk1 Ports 23+24 and SW04 Trk1 Ports 47+48) terminated and distributed on the stack (let me say SW03 Ports 23+24 on SW01 Port 23 and SW02 Port 23, SW04 Ports 47+48 on SW01 Port 24 and SW02 Port 24) for balancing in case of Stack node failure.

Clearly also on the Stack you should configure Port Trunking groups (Trk1 Ports 1/23+2/23 and Trk2 Ports 1/24+2/24) with LACP.

No more physical loops (It's a simple star topology), STP enabled.
fga76
Occasional Advisor

Re: Trunk mode with HP Switches

Another thing that I read in some other forum, said that the 1910 and the 2952 are not compatible with RPVST.

Is that true?

If so, this could be the problem because I had on both 2920-24G Switch (J9726A) spanning-tree set to RPVST. The other option is MSTP under the configuration.

The error on SW03 for example, when I put the uplink ports on both SW03 and SRV01, is:

#Jul 31 17:49:20:338 2017 SW03 IFNET/4/INTERFACE UPDOWN:
 Trap 1.3.6.1.6.3.1.1.5.3: Interface 9437206 is Down, ifAdminStatus is 1, ifOperStatus is 2
%Jul 31 17:49:20:520 2017 SW03 IFNET/4/LINK UPDOWN:
 GigabitEthernet1/0/23: link status is DOWN
#Jul 31 17:49:22:819 2017 SW03 IFNET/4/INTERFACE UPDOWN:
 Trap 1.3.6.1.6.3.1.1.5.4: Interface 9437206 is Up, ifAdminStatus is 1, ifOperStatus is 1
#Jul 31 17:49:23:00 2017 SW03 MSTP/1/PFWD:hwPortMstiStateForwarding: Instance 0's Port 0.9437206 has been set to forwarding state!
%Jul 31 17:49:23:160 2017 SW03 IFNET/4/LINK UPDOWN:
 GigabitEthernet1/0/23: link status is UP
%Jul 31 17:49:23:280 2017 SW03 MSTP/2/PFWD:Instance 0's GigabitEthernet1/0/23 has been set to forwarding state!

Stacking might now be an option, since I do not have the stack module neither the stack cable.

f_almeida
parnassus
Honored Contributor

Re: Trunk mode with HP Switches

Shouldn't you use basically RSTP (Rapid STP) globally on all your Switches? why citing MSTP (Multiple STP)? is that necessary to manage different STP regions related to different VLANs by adopting MSTP or using, as it seems you're already doing now on SW01 and SW02, the RVSTP (Rapid per-Vlan STP)?

What exactly you're trying to achieve (or to avoid) in case the network topology will remain as is...with various Port-based or Protocol-based VLANs you're going to deploy?

RSTP, AFAIK, should be supported on HPE OfficeConnect 1910 and on HP ProCurve (now Aruba) 2920...3Com should be checked, but should be easy enough.

Edit: 3Com Baseline Switch 2952-SFP is basically a 3Com branded 1910-48G with 4 additional SFP...and it supports RSTP for sure.

fga76
Occasional Advisor

Re: Trunk mode with HP Switches

I was think about my network layout. I do not have an uplink between SW03 and SW04. Should I have an uplink between those two switches? And then disconnect SW03 from SRV02 and SW04 from SRV01?

The path from SW03 to the servers on SRV02 would go through SW04. And vice-versa.

For some reason, when the ports within those 4 switches are in trunk mode, I got a loop.

Or disable STP on all switches, create the trunks in the current layout and then reestablish STP?

I just don't get why the loop when in trunk mode.

f_almeida
parnassus
Honored Contributor

Re: Trunk mode with HP Switches

fga76 wrote: I was think about my network layout. I do not have an uplink between SW03 and SW04.

Exactly, you haven't an uplink between SW03 and SW04...if an uplink ever exists it will produce another loop other than your two loops (SW03-SVR01-SVR02-SW03 and SW04-SRV02-SRV01-SW04). So it's good that you haven't that additional uplink.

Should I have an uplink between those two switches?

No.

And then disconnect SW03 from SRV02 and SW04 from SRV01?

Eureka, no more physical loops: your topology will became a daisy chain SW03-SRV01-SRV02-SW04.

The path from SW03 to the servers on SRV02 would go through SW04. And vice-versa.

Yes, that's true...such design could (or couldn't) became a bottleneck, it all depends where you client hosts are and where your server hosts are and where the majority of data traffic flows.

For some reason, when the ports within those 4 switches are in trunk mode, I got a loop.

IMHO you got a loop in any mode because there are two loops (see above). At least if you haven't configured something like MSTP or PVSTP correctly instead of (R)STP.

Or disable STP on all switches, create the trunks in the current layout and then reestablish STP?

Or rethink your network topology in order to prevent loop forming...and then enable (R)STP.

I just don't get why the loop when in trunk mode.

In Trunk Mode only? Are you sure? I ran out of ideas.