Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Trunking on HP ProCurve 2524

 
Greens85
Occasional Visitor

Trunking on HP ProCurve 2524

Hello All,

I have discovered a HP ProCurve 2524 within our environment (connected to the core through an access switch) and I need to attach a CISCO AP to the HP ProCurve 2524 and have it connect back to the rest of the network. I have done a similar thing on a CISCO switch but I am not too familar with HP. I have the relevant config from the working CISCO switch and was hoping that someone might be able to convert that to HP speak for me.

I did try what I thought but I got a bit muddle with how HP treats trunks i.e.. tagged, untagged etc. I found whatever I tried was dropping some VLANS i.e. the data VLAN was no longer passing traffic etc.

Here is what works on the Cisco:

Uplink interface:

!
interface GigabitEthernet1/0/24
switchport mode trunk
!

and the interface where the AP is connected:

!
interface GigabitEthernet1/0/13
switchport access vlan 130
switchport trunk native vlan 130
switchport mode trunk
switchport voice vlan 131
spanning-tree portfast
!

.....any ideas for the commands needed on the HP ProCurve? Basically, as far as I understand... I need the interface where the AP is connected to trunk in native vlan 130 and the uplink to also trunk all vlans.

Thanks in advance.

1 REPLY 1
parnassus
Honored Contributor

Re: Trunking on HP ProCurve 2524

Supposing you have VLAN Id 130 and 131 already defined on HP ProCurve 2524 and supposing you're uplinking your Cisco (on interface 1/0/24) to your HP ProCurve (on interface 24 <-- just an example) then:

HP ProCurve side (uplink interface):

vlan 1
untagged 24 [*]
vlan 130 tagged 24 vlan 131 tagged 24

[*] that's default: all ports are - for a factory default switch - untagged members of VLAN 1 (DEFAULT_vlan) which is their unique initial native VLAN Id.

HP ProCurve side (access interface to AP):

vlan 130
untagged 23 [**]
vlan 131
tagged 23

[**] You're going to see that port 23 it will become marked as "no untagged vlan 1", or correctly, VLAN 1 will report that port 23 will be no untagged...that's because port 23 is no more an untagged member of VLAN 1 (since you assigned it to another VLAN, the VLAn 130), it's now an untagged member of VLAN 130.

Clearly this should be OK if the AP side requires an interface untagged on VLAN 130 an tagged on VLAN 131 (for Voice)

VLAN 131 on HP ProCurve 2524 should be marked voice:

vlan 131
voice

 I expect that interface 1/0/23 on Cisco has this configuration to downling to HP ProCurve:

interface GigabitEthernet 1/0/23
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 1
switchport trunk allowed vlan 1,130,131
switchport mode trunk
switchport nonegotiate