Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to ping switch SVI from workstation VLAN

 
gazy007
Advisor

Unable to ping switch SVI from workstation VLAN

Hi,

i have configured 2920 and two 2530 switches with 3 VLANs and ip routing enabled on 2920. 

Vlan 10 servers   10.10.1.0/24

Vlan 20 employees 10.20.1/24

I have connected myself on vlan 20 and I could ping everything but I can't ping 2530 switch IP address vlan 10 address,

No t sure what I missed as I could see VLANs on 2530 OK. Has anyone got any idea where I have gone wrong?

Thanks,

 

7 REPLIES 7
gazy007
Advisor

Re: Unable to ping switch SVI from workstation VLAN

Any advice? It maybe default behaviour?

HP-Browniee
Respected Contributor

Re: Unable to ping switch SVI from workstation VLAN

Hello

You should add some static routes. 

By default 2 different vlans can't communicate between each other.

 

Kind regards

gazy007
Advisor

Re: Unable to ping switch SVI from workstation VLAN

Hi,

IP routing is enabled on the switch and I can communicate with other VLANs ip addresses. I am not sure if there is a need to add static route on the switch. I can not ping only switch SVI ip address of another Vlan.

HP-Browniee
Respected Contributor

Re: Unable to ping switch SVI from workstation VLAN

If you stay on the same switch there is no problem.

But when you communicate with other switches you need routes.

Vince-Whirlwind
Honored Contributor

Re: Unable to ping switch SVI from workstation VLAN

You should provide us with more info:

IP addressing details of the host you are using for testing

Switch IP configuration

Switch VLAN configuration

Switch VLAN port membership

Physical topology (ie, which switchport connects to which switchport).

gazy007
Advisor

Re: Unable to ping switch SVI from workstation VLAN

Switch IP configuration         Switch IP is on Vlan 10         10.10.1.0/24

Switch VLAN configuration       Switches are running both Vlan10 and Vlan 20  

Switch VLAN port membership     VLAN 10 ip address 10.10.1.1

Physical topology (ie, which switchport connects to which switchport).

All switches connects to core switch and running all VLANs Vlan10-20.
Workstations are on Vlan 20 and Switches IP address is on Vlan 10.

 

Vince-Whirlwind
Honored Contributor

Re: Unable to ping switch SVI from workstation VLAN

You've provided one IP address and no VLAN port membership or pohysical topology information.

If you are trying to troubleshoot connectivity between two subnets on two switches, you need to document a minimum of 3 relevant IP addresses, at least one default GW, the physical topology and the VLAN port membership of the relevant physical ports.

We can't help you without this information.