Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

VLAN - Tagged & Untagged

 
gwhite214
Occasional Visitor

VLAN - Tagged & Untagged

Hello, 

 

I'm new to HP Procurve and I am a Cisco eng. I have been assigned a project to audit our multiple Procurve switches and had a question. I understand the Tagged and Untagged features(Access and Trunk ports in the Cisco context);  however, I am not clear on how they are assigned to a VLAN in Procurve.  If a VLAN to assigned tagged and untagged ports,  does that mean that this VLAN is assigned to an access port and an allowed on a trunk port(Cisco setup)? 

 

 

 

vlan 1205     

    name "SF-WAN"      

    untagged E2      

    ip address 10.13.1.2 255.255.255.0      

    tagged B1,E15   

   exit 

 

 

Thanks in advance. 

 

~GW

4 REPLIES
EricAtHP
Esteemed Contributor

Re: VLAN - Tagged & Untagged

The best way to think about this is:

 

Cisco uses a port/interface based config.

 

ProCurve uses a VLAN based config.

 

That means that in Cisco, you go to the port/interface context and define which VLANs (one or more) that are passed on that port and which VLAN is untagged (native). In ProCurve, you go to the VLAN context and define which ports are a member of that vlan and whether or not they are tagged or untagged.

 

So in ProCurve, a port that is only a member of one VLAN and it is passed untagged, would be the equivalent of an access port in Cisco. In addition, if a port is tagged in one or more VLANs, it could also be untagged in one VLAN, meaning native VLAN. You do not have to define a port as an access or trunk port on a ProCurve switch.

 

Does that help?

gwhite214
Occasional Visitor

Re: VLAN - Tagged & Untagged

Thanks for the prompt response and clear explanation. 

 

Best, ~GW

gwhite214
Occasional Visitor

Re: VLAN - Tagged & Untagged

Hi Eric, 

 

I'm a bit confused about how a VLAN can be assigned several subnets.  Again, in Cisco a VLAN is only associated with a single subnet. How can a single VLAN be associated with multiple subnets as listed below? 

 

Thanks in advance. 

 

~GW

 

 


vlan 1332

name "SF-Users"

untagged B2-B3,B6-B14,C1-C14,D1-D14

ip address 10.13.32.1 255.255.248.0

ip address 10.32.32.1 255.255.255.0

ip address 10.32.36.1 255.255.255.0

ip address 10.32.37.1 255.255.255.0

ip helper-address 10.35.26.25

ip helper-address 10.35.26.30

tagged B15-B16,C15-C16,D15-D16

exit

EricAtHP
Esteemed Contributor

Re: VLAN - Tagged & Untagged

I don't think I understand. The config you show will work and does associate multiple subnets with a single VLAN, aka multinetting. It is like secondary addresses in Cisco.

 

I do see that you are doing DHCP on this VLAN. It has been a while since I have done this but I believe that the switch will use the first assigned IP address in the DHCP relay messages to your DHCP servers. In other words, I would only expect clients to get a DHCP address in the 10.13.32.1 255.255.248.0 subnet.

 

Can you clarify your question if I didn't get it right?