Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

Voice port configuration issue in HP procurve 2610-24 switch

 
pradeepS1
Visitor

Voice port configuration issue in HP procurve 2610-24 switch

Hello All,

I have different different vendor’s switches like HP comrware , procurve, brocade and cisco, and I have configured it with Panasonic IP phone successfully and my data and voice device absolutely working ok.

But unfortunately I’m facing issue with one of the my HP procurve 2610-24 switch

Issue: I have done the configuration like below but the IP phone is not getting voice vlan IP address

I have checked that both vlan are passed in network, even if I untagged the port in voice vlan it working fine its getting an IP address of voice vlan but not working in following configuration.

 

vlan 16

   name "Voice"

   no ip address

   qos priority 6

   tagged 14,16,22,25-28

   voice

   exit

 

vlan 4

   name "DATA"

   untagged 6,9,11-15,17

   tagged 16,19,22,25-28

   exit

 ----------------------------------------------------------------------------------------

CKVEHOFFPPC_HP2610_1_185# sh mac-address ethernet 14

 Status and Counters - Port Address Table - 14

  MAC Address   VLAN

  7446a0-a2c691     (this PC’s MAC-ID)

  bcc342-55a9b3 4    (this is IP phone MAC-ID)

--------------------------------------------------------------------------------

My IP phone port is Ethernet 14

I am unable to understand what exactly happening because the same configuration working fine on my another procurve switches.

Please help me in this regards.

thanks in advance 

2 REPLIES 2
network_king
HPE Pro

Re: Voice port configuration issue in HP procurve 2610-24 switch

Create voice Vlan such as Vlan 3 and configure the ports that will be connected to phones as "tagged" in Vlan 3. Add the voice parameter to make it a voice Vlan.


ProCurve Switch# conf t 
ProCurve Switch(config)# Vlan 3 
ProCurve Switch(Vlan-3)# voice 
ProCurve Switch(Vlan-3)# name "Voice_Vlan" (add a name to the voice Vlan if you want)
ProCurve Switch(Vlan-3)# 

If the PC and phone are on the same port, the port is tagged in the voice Vlan and the port is untagged in the data Vlan. (By default all ports are untagged in Vlan 1 on an HP switch)

The HP edge switches would normally be configured with the PC Vlan "untagged" and the voice Vlan "tagged". (Tagging allows for 802.1Q Tag for phones)


ProCurve Switch# config t 
ProCurve Switch(config)# Vlan 3 
ProCurve Switch(Vlan-3)# voice 
ProCurve Switch(Vlan-3)# name "Voice_Vlan" 
ProCurve Switch(Vlan-3)# tagged A1-A12 (ports dedicated for Phones) 

For a layer 3 switch that is doing the routing, enable ip routing:


ProCurve Switch# config t 
ProCurve Switch(config)#ip routing 

Assign an ip address to voice Vlan 3.


ProCurve Switch# conf t 
ProCurve Switch(config)# Vlan 3 
ProCurve Switch(Vlan-3)# voice 
ProCurve Switch(Vlan-3)# name "Voice_Vlan"  
ProCurve Switch(Vlan-3)# tagged A1-A12 
ProCurve Switch(Vlan-3)# ip address 192.168.3.1 255.255.255.0 

Use the CLI in the HP ProCurve switch and issue the ip helper-address command on the Voice Vlan in the switch.


ProCurve Switch# conf t 
ProCurve Switch(config)# Vlan 3 
ProCurve Switch(Vlan-3)# voice 
ProCurve Switch(Vlan-3)# name "Voice_Vlan" 
ProCurve Switch(Vlan-3)# tagged A1-A12 
ProCurve Switch(Vlan-3)# ip address 192.168.3.1 255.255.255.0 
ProCurve Switch(Vlan-3)# ip helper-address 192.168.2.125 (ip address of DHCP server for IP Phones on the data network)

Layer 2 switch using external router:

The HP L2 switch needs each Vlan added to the interface the router is linked to. Make sure Vlans are "tagged" on that interface except for whichever Vlan is "native" on the router interface that Vlan needs to be "untagged" on the HP switch.

Voice Vlan troubleshooting:

One essential step if users are not entirely sure what is going on is to configure one port on the HP switch to be "untagged" in the voice Vlan. Place a laptop on this port to test voice Vlan DHCP and basic connectivity in the voice Vlan.

Configuration example:

Set up the Vlans on L3 switch, one for voice and one for data. Give them the .1 address for that Vlan. Make sure whichever ports on L3 switch that will link to L2 switches are set as tagged for the voice Vlan, and untagged for data. Then set up the Vlan on L2 switches and give them the .2 addresses. As an example,

L3 switch configuration example:


ip routing 
Vlan 2  
name "Data_Vlan" 
untagged 48 (port is linked to your L2 switch for that Vlan) 
ip address 192.168.2.1 255.255.255.0 

Vlan 3 
name "Voice_Vlan" 
qos dscp 101110 
ip address 192.168.3.1 255.255.255.0 
tagged 48 (port is linked to your L2 switch for that Vlan) 
voice 
ip helper-address 192.168.2.125 

And then user would link port 48 to L2 switch port 26, and set up the config as follows:

L2 switch configuration example:


no lacp 25-26 (these are the two uplink ports on a 24 port ProCurve switch)
Vlan 2 
name "Data_Vlan" 
ip address 192.168.2.2 255.255.255.0 
untagged 1-24 
tagged 25-26 

Vlan 3 
name "Voice_Vlan" 
ip address 192.168.3.2 255.255.255.0 
tagged 1-26 
primary-Vlan 1 
ip default-gateway 192.168.1.1 
ip helper-address 192.168.2.125 

That should do it. User should be able to route between the two Vlan and split the data and voice traffic.

I am an HPE Employee

Accept or Kudo

pradeepS1
Visitor

Re: Voice port configuration issue in HP procurve 2610-24 switch

Hi sir,

thanks for your reply on this,

i am using switch is HP procurve 2610 and the configuration i am using for voice as below, the issue is ip phone is not getting IP address of voice vlan subnet but the same on other procurve switch with same configuration the ip phone working fine.  

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

IP phone port is ethernet 14

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

vlan 16

   name "Voice"

   no ip address

   qos priority 6

   tagged 14,16,22,25-28

   voice

   exit

 

vlan 4

   name "DATA"

   untagged 6,9,11-15,17

   tagged 16,19,22,25-28

   exit