Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

configure sflow on procurve hp5400zl

fredd33
Occasional Visitor

configure sflow on procurve hp5400zl

Trying to configure sflow on HP 5400 and not sure how to enter config lines for ports. Configured HP 2910 using 1-48 for config line for ports but 5400 has both tagged and untagged ports and are listed in this manner:

untagged A1-A24,B1-B24,C1-C24,D1-D24,E1-E22,F4-F21,F24-G24,L1-L22,Trk1
no untagged E23-E24,F1-F3,F22-F23

untagged E23-E24,F1-F3,F23
tagged A4-A24,B1-B24,C1-C24,D1-D24,E1-E22,F4-F18,F20-F22,F24-G24,L1-L22,Trk1
voice

Ports are on these type modules:
module 1 type J8702A
module 2 type J8702A
module 3 type J8702A
module 4 type J8702A
module 5 type J8702A
module 6 type J8702A
module 7 type J8702A

Any help would be extremely appreciated.

Fernando dela Garza

3 REPLIES
Rich R_1
Advisor

Re: configure sflow on procurve hp5400zl

Ok, sflow on HP 5400/2920 should be the same.

 

conf t

sflow 1 destination x.x.x.x xxxx

sflow 1 polling 

sflow 1 sampling

 

for the trunk port, you would need to enter Trk1 instead of the port/ports that are part of the trunk.

n3tm1n
Valued Contributor

Re: configure sflow on procurve hp5400zl

Receiving the following error when trying to enable sflow:

 

sflow 1 sampling A1-A24,B1-B24,C1-C24,D1-D8,E1-E24, trk1-trk9
,trk13-trk15 50
Module not present for port or invalid port: A1-A24,B1

 

I also got the same error for polling as well.

 

I tried a working around for the ports with "all". if this is wrong, how do I change or disable that?

 

Read/re-read hp documentation, but it's poorly written if it's a modular switch. Would this error occour if a port in the series of ports i.e. A1-A24 is part of a trunk?

 

 

Michael Patmon
Trusted Contributor

Re: configure sflow on procurve hp5400zl

Hello.  Yeah, the CLI doesn't generally like "all" when trunks are configured.  Try "<first-port>-<last-port>", such as "sflow 1 sampling a1-e24 50". 

 

Quick note on setting the sampling rate manually.  Those are processed on the interface modules so exercise caution when setting a high sampling rate when you have ports with large amounts of traffic.