Aruba & ProVision-based
cancel
Showing results for 
Search instead for 
Did you mean: 

ntp on 5400 with k.14.41

 
SOLVED
Go to solution
EckerA
Respected Contributor

ntp on 5400 with k.14.41

Hi,
sntp isn't working anymore with k.14.41. the setup isn't changed from bevor(K.13.63m) but now i only get :
all configured servers failed.
did someone get it to work?
thanks
alex

 

 

P.S. This thread has been moved from Switches, Hubs, Modems (Legacy ITRC forum) to ProCurve / ProVision-Based. - Hp Forum Moderator

22 REPLIES 22
Tijl van der Steeg
Valued Contributor

Re: ntp on 5400 with k.14.41

What are you using as a time server?
EckerA
Respected Contributor

Re: ntp on 5400 with k.14.41

Hi,
i don't know, it' not mine. but it worked before with "the same settings".
thanks
alex
Mohammed Faiz
Honored Contributor

Re: ntp on 5400 with k.14.41

Hi,

I'm running a few 5400 on K14.41 and sntp is working fine for me.
What do you get on a "sh sntp stat" ?
EckerA
Respected Contributor

Re: ntp on 5400 with k.14.41

Hi

SNTP Statistics

Received Packets : 0
Sent Packets : 5445
Dropped Packets : 0

SNTP Server Address Auth Failed Pkts
--------------------------------------- ----------------
10.64.114.40 0
10.16.8.55 0

i guess no solution there..
alex
Tijl van der Steeg
Valued Contributor
Solution

Re: ntp on 5400 with k.14.41

Maybe the new firmware want NTP instead of SNTP. Have you tried changing that setting?

"timsync timep" instead of "timesync sntp"
EckerA
Respected Contributor

Re: ntp on 5400 with k.14.41

Thanks
that worked..
Alex
Jarmo Laakso
Occasional Visitor

Re: ntp on 5400 with k.14.41

I have exactly the same problem. I upgraded from 13.68 to 14.41.

We have XNTPD 3.4y on Aix. Seems to be running timep which is a different protocol and it works but I would like to have NTP working.
Tijl van der Steeg
Valued Contributor

Re: ntp on 5400 with k.14.41

Every windows domain controller is an NTP server. Do you have any of those in your network?
Jarmo Laakso
Occasional Visitor

Re: ntp on 5400 with k.14.41

That didn't come into my mind.

So i added a windows dc as ntp server with lower priority. Log says:
I 10/13/09 16:27:38 00414 SNTP: all configured servers failed
I 10/13/09 16:27:38 02631 SNTP: server not found at 10.1.31.234.
I 10/13/09 16:27:29 02631 SNTP: server not found at 10.0.16.8.
Tijl van der Steeg
Valued Contributor

Re: ntp on 5400 with k.14.41

Same story: "timsync timep" instead of "timesync sntp"

sntp is old
Tijl van der Steeg
Valued Contributor

Re: ntp on 5400 with k.14.41

Otherwise there could be a problem with a firewall and udp 123. But that's unlikely because nothing changed right?
Jarmo Laakso
Occasional Visitor

Re: ntp on 5400 with k.14.41

I updated another switch and sntp stopped working.

So I changed protocol to timep and time is ok now.

So beware that sntp is not working in 14.41. Timep works if there are still timep servers.

I think NTP is a newer protocol which can handle delays in network. Timep is just a service which tells date and time in standard form. Enough for small environments where you have ntp-synced time available somewhere. Anyway timep is enough to keep logs in different systems synchronized.
serpel
Trusted Contributor

Re: ntp on 5400 with k.14.41

hi,
at a hp procurve switch roadshow a hp tc told me that this is a bug in the software and that hp knows of it and that it will be fixed in an future release of the software.
it has something to do with the new sntp authentication feature. the switch always send an empty password with the ntp request if authentication is disabled and the server can't handle this and drops the packet.

hth
alex
Glen Van Lehn
Frequent Advisor

Re: ntp on 5400 with k.14.41

we started updating to K.14.41 last week and have 23 5406zl's done so far. I just did a sample of 6 and all were working:
sho sntp stat no dropped packets, Tx=Rx

we point sntpv3 to generic linux server.
don't know what else to say
glen
ps: if sntp is old, timep is ancient
Rainer Stenzel TG
Occasional Visitor

Re: ntp on 5400 with k.14.41

Hi,
we have this problem, too. We upgraded a switch to 14.41.
We want to syncronize via sntp from a W2K3 Standard Server with SP2, but the eventlog shows now only errors:
I 01/01/90 01:51:59 00414 SNTP: all configured servers failed
I 01/01/90 01:52:41 02631 SNTP: server not found at 192.168.1.1.

If sntp works fine with Linux, there is probably a error with Windows-Servers.


Trevor Commulynx
Regular Advisor

Re: ntp on 5400 with k.14.41

Got the same problem here. rolled back to 14.34 and works fine.
Rainer Stenzel TG
Occasional Visitor

Re: ntp on 5400 with k.14.41

From Procurve support we get an actual firmware K.14.50 and the info, that the problem is solved with firmware K.14.48.
Highlighted
Case Van Horsen
Frequent Advisor

Re: ntp on 5400 with k.14.41

In addition to the other suggestions, such as "timesync timep", it also depends the version of software on the time server. I can't get K.14.48 to work with our old Solaris time servers but I K.14.48 (and .41) have always worked when configured with a recent Linux time server.

Jeff Carrell
Honored Contributor

Re: ntp on 5400 with k.14.41

hmm...i've had sntp working on K.14.41 to a cisco 2621 router/timesrvr for a few months...

here is my config:

timesync sntp
sntp unicast
sntp 60
sntp server priority 1 10.222.100.251 3
ip source-interface sntp vlan 100

however, the switch will not sync to a W2K8 server...and i do seem to remember this problem when i upg to K.14.41.....

so, how do we get the latest K.14 code???

cheers...jeff
Rainer Stenzel TG
Occasional Visitor

Re: ntp on 5400 with k.14.41

Just open a case via "Support Case Manager" an explain the problem. So I get version K.14.50.
EckerA
Respected Contributor

Re: ntp on 5400 with k.14.41

hi,
i got the info from HP that this bug isn't solved right now, not even with software K.14.51.
But they send me a "workaround", which just disables the massege in the log ;-)

alex
JR30
Occasional Visitor

Re: ntp on 5400 with k.14.41

Hi all,
I just got a K14.52 version from HP support. It solves this SNTP issue.