Automated Backup
cancel
Showing results for 
Search instead for 
Did you mean: 

Surestore 2/20 dual drive throughput

SOLVED
Go to solution
Richard McIndoe
Occasional Contributor

Surestore 2/20 dual drive throughput

Server: Dell Poweredge 2650
Tape Library: Surestore 2/20 dual Ultrium drives LVDS
SCSI cards: two Adaptec 29160LP cards, one for each drive.

My problem is that i am getting different transfer rates from each card. The card that has only one drive connected to it has a rate of 22MB/S (1.3GB/minute) but the card that has the first drive and library controller has a rate that is 10 times slower. I get these rates using the HP Libarary and Tape tool read/write tests, so I don't think it has to do with the backup software (Ultrabac). Both cards are in 64 bit slots. Any ideas would be appreciated.

Thanks,
Rick
4 REPLIES
Rothery Harris
Trusted Contributor

Re: Surestore 2/20 dual drive throughput

Dear Rick,
Are the card settings identical. It is possible one card is set to negotiate a slower speed or maybe has synchronous SCSI disables. You could just try swapping the cards to check this. I wouldn't think the controller has any effect. Check the SCSI termination is OK on the slower channel and that the disy chain cable to the controller is not too long or suspect.

Regards

Rothery
Richard McIndoe
Occasional Contributor

Re: Surestore 2/20 dual drive throughput

Rothery,
Both cards have identical settings. One thing I realized was that it just happened that the bus order for the cards was different then the SCSI ID settings. For example,
Drive 2 : 3/0.2.0 and
Controler : 4/0.0.0
Drive 1 : 4/0.1.0 ,so that Drive 2 is actually seen first. In this configuration Drive 2 has 80MB/s and Drive 1 is ASYNC NARROW. However, if I do:
Controller: 3/0.0.0
Drive 1 : 3/0.1.0
Drive 2 : 4/0.2.0
Then both drives sync to the contoller with ASYNC NARROW.
I am stumped. Any new thoughts.

Rick
CA274452
Occasional Visitor
Solution

Re: Surestore 2/20 dual drive throughput

Try uninstalling the Adaptec driver and using the default Microsoft driver. There was a bug in one version of the Adaptec 29160 driver that would cause it to use async narrow on all devices on a bus if it found one device on the bus that was async narrow. You may be able to work around the problem by changing the id of the library controller but I have been unable to duplicate this problem to test that.
Richard McIndoe
Occasional Contributor

Re: Surestore 2/20 dual drive throughput

Curtis,
Reverting back to the older driver helped considerable (which was an excercise in itself), but I am still experiencing different rates for each drive. The drives are no longer syncing to the lowest device, so Drive 2 has the 22MB/S backup rate regardless of the bus order of the card. And, Drive 1 (on the same as the controller) is now 10 MB/S, which is 10X faster then when the latest driver was installed (1MB/S), but it is still half the speed of the drive that has it's own card. Is this normal or is there something else I can try?

Rick