Storage Boards Cleanup
To make it easier to find information about HPE Storage products and solutions, we are doing spring cleaning. This includes consolidation of some older boards, and a simpler structure that more accurately reflects how people use HPE Storage.
Automated Backup
cancel
Showing results for 
Search instead for 
Did you mean: 

Suse Linux 8.0 not recognizing SureStore 24x6

Don Pettini
Occasional Contributor

Suse Linux 8.0 not recognizing SureStore 24x6


I have Suse Linux 8, running on a Compaq 8500r, with a 4200 series RAID card. I have one external array connected to the 4200.

I have connect an HP SureStore 24x6 to this system, when booting the device is detected as SCSI ID 5 on the built-in SCSI of the 8500(it is the only external device on the bus), but when the operating system boots, the operating system does not discover the device and add it to /dev/st* as one expects. I have /dev/st0 and /dev/st1 but neither response to a mt -f /dev/st* command, I have verified that the multi-lun kernel parameter is set, as well as SCSI tape. Are there Unix tools to scan the SCSI bus and report through the OS what is seen?

I believe the tape drive itself is OK as I pulled it from backup on a Win2K system.
Any help here greatly appreciated.

Just work, Damn it.
4 REPLIES
Eugeny Brychkov
Honored Contributor

Re: Suse Linux 8.0 not recognizing SureStore 24x6

Don,
looks like OS, not autoloader problem. Post your question into Linux section of ITRC forum http://forums.itrc.hp.com/cm/FamilyHome/1,,118,00.html .
Please do not forget that these autoloaders have drive hardwired to LUN 0 and robot (autochanger) hardwired to LUN 1.
Also pay attention to autoloader option switch (at the back of the unit) and drive's dip switches (at the bottom of the unit). In most common configs autoloader option=7, and drive's dip switches all are on except 3rd is off
Eugeny
Don Pettini
Occasional Contributor

Re: Suse Linux 8.0 not recognizing SureStore 24x6

Thanks for the quick reply Eugeny, I have verified both the switch poisition on back at 7 and the dip switch below are set correctly. I did try them at 5 and switch 8 off, no change. Thanks for the pointer, I will repost where suggested.

Don
Just work, Damn it.
Hans Loos_3
Occasional Advisor

Re: Suse Linux 8.0 not recognizing SureStore 24x6

Hello there,

Tape devices are NOT supported on a RAID card.
Connect the dat 24*6 to an normal scsi card ,such as adaptec 2940 an it will run.

see also at following webpage:
recommanded scsi card for tape devices

http://h20015.www2.hp.com/en/document.jhtml?lc=en&docName=lpg50063


regards from Hans
Don Pettini
Occasional Contributor

Re: Suse Linux 8.0 not recognizing SureStore 24x6

Thanks Hans. It is really counter-intuitive that the tape system would not be discovered on the builtin SCSI channel, what make the RAID card work differently than a regular SCSI card to recognize the tape drive & loader?

Thanks again for the help, I have ordered an ordinary scsi card.

Don
Just work, Damn it.