Automated Backup
cancel
Showing results for 
Search instead for 
Did you mean: 

Tape Tools install error

SOLVED
Go to solution
CA254409
Occasional Visitor

Tape Tools install error

When I try to istall the HP library and Tape Tools program I get the following error:
IKernel.exe could not be copied o C:\Program Files\Common Files\InstallShield\Engine\6\Intel32
Make sure you have the appropriate priviledges to copy files to this folder (0x20)

I'm the domain as well as local admin so I've got full rights to the folder. How do I fix this?

4 REPLIES
CA628575
Trusted Contributor

Re: Tape Tools install error

Which version of HP L&TT are you trying to install?

This used to be a known bug with an earlier version of InstallShield used back with HP L&TT 2.5. But we have not seen this error message in any of our recent versions.
CA254409
Occasional Visitor

Re: Tape Tools install error

I'm trying to install version 2.7 of the TT&L on a new Dell Server running Windows NT4 with SP6a. It's also running Veritas BackupExec 8.6. Any thoughts of why it's bombing on the install.

CA628575
Trusted Contributor
Solution

Re: Tape Tools install error

The latest version of LTT is LTT 2.7 SR4 - and we did not have any reports of ikernel.exe related errors with that version so far - but never say never.

I searched for suggestion on the InstallShield web site related to this problem. Here are there suggestions (from http://www.installshield.com - knowledgebase search on ikernel for version 6.x) - check into the DCOM item, that sounds familiar; and you already verified permissions, etc.:

Setup initialization errors can be caused by a number of factors. This is a non-exhaustive list of possible resolutions:

Insufficient permissions on the machine. If you are using a Windows NT or a Windows 2000 machine, you need to have administrative permissions to run an InstallShield Professional 6.x setup. Make sure you have the correct permissions.

If you just ran an InstallShield setup, the engine takes a few seconds at the end of the installation to clean up. During this time Ikernel.exe (the engine file) is running in memory from a previous process. That is why you are not allowed to launch another setup. Waiting a few seconds and running the setup again should resolve this.

Check and make sure Ikernel.exe is not in memory. If it is, and no setup is running at the time, end that task and restart the system.

Clean out the Temp directory.

Delete the Program Files\Common Files\InstallShield\Engine folder and then rerun the setup.

Reinstalling Internet Explorer (IE) 5.x can also repair a number of corrupted/missing core Windows files from your machine, so reinstalling IE 5.x and the NT service pack is also suggested.

Another possibility is that you do not have sufficient COM permissions. For information on how to troubleshoot this, see article Q104986, INFO: Initialization Error Troubleshooting.

The other potential cause is a missing Stdole.tlb, stdole32.tlb, or stdole2.tlb file. These are core Windows files and should exist on your machine. Make sure that if you get these file from another machine, the machine is running the same operation system as the machine you are trying to run the setup on.

If you are trying to install to a Windows 98 machine, download and run Dcom98.exe from the following site: http://www.microsoft.com/com/dcom/dcom98/download.asp.

Make sure that you are using the latest version of the InstallShield engine. To install the latest engine see article Q105097, INFO: Install the Latest Version of Ikernel.exe
CA254409
Occasional Visitor

Re: Tape Tools install error

All fixed. It ended up being a DOM security issue. Changed the default security seetings and it installed beautifully.

Thanks for the help.