BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL35p ilo not working & nic issues

SunCat1
Occasional Contributor

BL35p ilo not working & nic issues

Hi there,
Hoping some of you experienced HP admins / engineers might be able to help me.

Recently I tried to fix 2 BL35p blades, on which the ilo connections were not available on the network.

The actual blades were running SLES, and were available on the network. Other blades in the enclosure had both the ilo and nic's working too.

What i tried:
On the first blade i swapped out the nic mezzanine board, and checked & configured the static ip address for the ilo was correct.
SysAdmin was able to connect to the ilo, BUT the network was not reachable. Tried a second mezzanine card, again ilo working, but no network. In the end, put the original mezz card back in, resulting in no ilo, but at least network back up.

On the second blade, i swapped out the system board and the nic mezzanine card. The ilo did not work remotely. Placed a second mezz card in, now ilo working, but on boot up, NO network again. So back in with original mezz card, still no ilo, but network up.

Logically based on above, i have either some DOA parts, or partially DOA mezz cards?

Or is there something else at play?

Somebody mentioned "arp tables" cache being full?

Any pointers or ideas would be greatly appreciated.

Thanks,
1 REPLY
Matti_Kurkela
Honored Contributor

Re: BL35p ilo not working & nic issues

If your iLO connections are plugged into a network with a DHCP service, it's possible that they did not get an IP address originally (cause unknown). Unplug/replug of the blades caused the iLO to try DHCP again, and this time it worked.

iLO should be completely independent of any mezzanine cards.


Regarding your network configuration problems: Did you update the MAC addresses of the new NICs to the network configuration?

SuSE attempts to bind the network configuration to each NIC mostly based on the MAC address. If you swap a NIC without updating the MAC addresses, the new NIC gets a new ethX name and will be left unconfigured until the sysadmin explicitly configures it.

Things to check, based on my notes about SuSE 10:

(Disclaimer: I don't know how it really should be done on SuSE/SLES. I just know that this method worked for me.)

1.) There is a file in /etc/udev/rules.d that determines the ethX names of each NIC, using the MAC addresses. After swapping the mezz cards, you probably have a lot of entries in that file. Comment out the lines referring to NICs that are no longer present, and re-number the existing NICs as you wish.

2.) The network configurations for each NIC are stored in /etc/sysconfig/network, in files named like "ifcfg-*". The suffix of the ifcfg file is again the MAC address: rename the files so that they point to the correct MAC addresses.

3.) If you have enabled iptables firewall on the system, see also /etc/sysconfig/SuSEfirewall2. There is a line that begins with "FW_DEV_EXT": this line will also list the MAC addresses of NICs. You may wish to remove the MACs that are no longer present in the system.

After making these changes, reboot the system, or at least unload and reload your NIC driver module(s).

MK
MK