BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c G6 NIC Problem FLEX 10

 
jd7000
Frequent Advisor

BL460c G6 NIC Problem FLEX 10

I have a C7000 blade enclosure with 7 x BL460c Blades.

3 x Windows 2003 x64
3 x Windows 2003 x86
1 x Windows 2008 R2 x64

I have just upgraded the VC Modules to Flex 10 in bay 1 and 2.

I booted the blades back up and after re-teaming the cards on the 64 bit servers they are working as expected.

On the 3 x 32 - bit servers they BSOD.

Once I disabled one of the NICS in the BIOS the server booted up fine.

I attempted to re-install the new NIC driver but the server complained about the new driver.

The cards are NC532i.

Anyone seen this before?

Thanks
5 REPLIES
Ali
HPE Pro

Re: BL460c G6 NIC Problem FLEX 10

Hi there,

What is the exact error message that you getting on the Blue screen.

for BSDO 0X8E due to an network frame size incompatibility with the NC532i driver and Teefer2 driver. following steps has helped.


A: Disable the Teefer 2 driver: From Windows Device Manager you can select to show hidden devices and to disable the Teefer 2 driver for each one of the NC532i LOM's showed.

B: Disable the Checksum offload features for the NIC: From windows device manager Nc532i properties go under advanced tab and disable IPv4 and IPv6 Checksum offload and IPv4 IPv6 Large Send Offload, repeat this steps for all the NC532i Interfaces.

Latest NC532i driver
http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=3884098&swItem=MTX-6e44c6cf0824451eba5f716a7e&prodNameId=3884099&swEnvOID=1005&swLang=13&taskId=135&mode=5

hope this helps,

Thanks,
Aftab
I work for HPE
Looking for a quick resolution to a technical issue for your HPE products? HPE Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
jd7000
Frequent Advisor

Re: BL460c G6 NIC Problem FLEX 10

Hi,

Thanks for the reply.

I have since rolled back to the old VC modules and all is working fine.

I need to get this resolved asap so I can get the VC modules upgraded.

I have attached a PDF which has the pictures on including the BSOD.

The problem is weird.

HP have said to upgrade the firmware for everything.

Will let you know the outcome.

Ali
HPE Pro

Re: BL460c G6 NIC Problem FLEX 10

Hi,

there has been quite a few advisory related to NC532i
http://h20000.www2.hp.com/bizsupport/TechSupport/DocumentIndex.jsp?contentGroup=NT_DT_CustomerAdvisory〈=en&cc=us&docIndexId=64174&taskId=101&prodTypeId=329290&prodSeriesId=3958220

Follow the HP recommendations for firmware update as per bladesystem firmware compatibility matrix.

once all the firmware are updated including VC you may try Clean/manual installation of NIC driver.

please keep me posted on the outcome.

thanks,
Aftab
I work for HPE
Looking for a quick resolution to a technical issue for your HPE products? HPE Support Center Knowledge-base – Just a Click Away!
See Self Help Post for more details
jd7000
Frequent Advisor

Re: BL460c G6 NIC Problem FLEX 10

Ok HP analysed all the logs sent and they came to the conclusion that it is the /3GB in the boot.ini that is causing the problem.

I have been in today and removed this from the 32 bit servers and low and behold they start up fine.

BUT... I am now having a conflict with the networks in blades 12 and 13.

Each one will only work when the other is off!

Both are BL460c G6 blades.

The blade in bay 12 has no mez cards and is using just the onboard nic.

The blade in bay 13 is using the onboard nic and has a mez card installed but I have disabled this.

If you set a continuous ping to each server whilst they are both on they are both losing quite a few pings intermitently?

Any ideas?




jd7000
Frequent Advisor

Re: BL460c G6 NIC Problem FLEX 10

Found out what it was. The 2 servers had the same virtual MAC address.

Re-teaming sorts the problem.

What an experience :)