BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL460c + Windows 2003 + Teaming + VMWARE + RH ES3u8 + NFS + Blue Screen

Andrew Young_2
Honored Contributor

BL460c + Windows 2003 + Teaming + VMWARE + RH ES3u8 + NFS + Blue Screen

Hi All

This is just for info to everyone else out there. Since there are so many variables I'm going to post it in this section unless someone can suggest another place to post it.

We have a SAN attached BL460c blade running Windows 2003 R2 with VMWARE running multiple virtual servers one of them being an instance of Red Hat Enterprise Server 3 Update 8. The BL460c was using the HP supplied drivers off the Smart Start 7.6 disk (I think version 8.55 of the driver) with teaming enabled.

The original symptom was the Windows server would randomly reboot and when doing so it would intermitantly lose its SAN connetivity. There were no errors on the SAN switches or the EVA.

Eventually we traced it to a process on the Red Hat VM where it tried to access an NFS share on an HP-UX 11iv2 rx7640, the Windows server on which the VM's were running would Blue Screen and reboot. By chance one of the sysadmins managed to get a screenshot of the BSOD with the following stop message:

DRIVER_IRQL_NOT_LESS_OR_EQUAL

with the following stop code:

0x000000D1

It turns out this was an issue with the cpqteam.sys driver. Upgrading to the latest version of the driver (8.70) stopped this problem.

The unusual factors in this was that this problem only started after we allowed a second different (RH ES4u4) host to access the NFS share on the rx7640. Both NFS mounts were set up as automounts. Apparently this is a problem with an unsupported frame type on the teaming driver. The losing the SAN connections was a symptom of the problem and not the cause like we initially suspected. Of course we only found that out having replaced the QLogic mezanine card.

I hope someone finds this usefull.

Regards

Andrew Y
Si hoc legere scis, nimis eruditionis habes
2 REPLIES
Gene Laoyan
Super Advisor

Re: BL460c + Windows 2003 + Teaming + VMWARE + RH ES3u8 + NFS + Blue Screen

When you say "replaced the QLogic mezanine card" did you replace it with a different card or an identical card?

Thanks
Andrew Young_2
Honored Contributor

Re: BL460c + Windows 2003 + Teaming + VMWARE + RH ES3u8 + NFS + Blue Screen

Hi.

We carry two spare blades which are fully provisioned, we borrowed a card from one of them. The same model, the only difference being the WWN numbers, but adjusting that on the SAN was easy.

We also tried a full server replace with one of the spares in case it was some other odd hardware error, but after endless ILO errors we gave up on that, provisioned a new server and moved the VM onto that server to save the other VM's and it allowed us to trouble shoot.

Regards

Andrew Y
Si hoc legere scis, nimis eruditionis habes