BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

NiallS
Occasional Visitor

BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

I have dropped a set of BL495c G5 servers into my pre-existing working RDP setup only to find that they won't boot to PXE. The PXE NIC agent starts and acquires an IP address via DHCP but then falls over with error "PXE-E11: ARP timeout". Does anybody have any idea what could be going wrong?

The NIC PXE agent, DHCP server and RDP servers are all on different subnets. Routing between then is handled by a cisco router using the helper address feature to handle the DHCP and PXE forwarding. The servers on board broadcom NICs are used with PXE agent version UNDI PXE-2.1 v4.5.20. These are hooked up to a flex-10 switch with a very simple configuration.

Finally, if I move the PXE NIC agent to the same subnet as the RDP server all is well.
18 REPLIES
Adrian Clint
Honored Contributor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

NiallS.

Have you seen the answers in the RDP Knowledge Base (scroll down a page)
http://h18013.www1.hp.com/products/servers/management/rdp/knowledgebase/00000138.html?jumpid=reg_R1002_USEN
Its probably something to do with scope option 60

PS: there is a separate RDP forum
http://forums11.itrc.hp.com/service/forums/categoryhome.do?categoryId=299
Lmm_1
Honored Contributor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Do you have VC Flex10 Modules?
NiallS
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Adrian: I will double check the DHCP option 60 configuration but I am pretty sure it is OK. In any case it works fine with my bl25p and bl460c just not any bl495c.

Lmm: Yes I am using flex10 switches. It is a basic setup where the server profile puts port LOM:1-a in the required vLAN (untagged). External ports are trunked with the "Auto" setting to a ProCurve 5412 and the vlan presented to the servers is carried (along with others) as tagged traffic between the flex-10 and ProCurve. Outside of this PXE problem this has served flawlessly for all other network traffic.

I have noticed one difference in the output of the PXE NIX agent between working and non-working hardware types. We use a pair cisco routers with HSRP to forward packets between the various subnets (vLANs). For working PXE NIC agents it reports the floating and physical addresses as gateway IP. In the bl495c case the one of the physical addresses is missing.
Lmm_1
Honored Contributor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

NiallS,
I´ve seen this issue before, only when using Flex10 NICs, VC Flex10 Module and relay agent. As far as I know the the only available workaround will be using the target server and DHCP server on the same VLAN. There should be a fix coming soon from HP.
Lmm_1
Honored Contributor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

I meant using the Target and PXE server on the same VLAN as workaround.
Gareth Lloyd
Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

I have had the same issue with BL495 G5 and BL460 G6 blades with 10GB Nics in c7000 enclosures with Flex10 VC switches.

I have been told to upgrade the firmware of all my VC switches to v2.30 to fix the issue.

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=3794423&swItem=MTX-6279f8b6261b4b938b7b7b41a7&prodNameId=3794431&swEnvOID=1005&swLang=13&taskId=135&mode=4&idx=3



Stefan Muegeli
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

In my case HP told me that they still working on a new Firmware-Update.

@Gareth Lloyd
Did the FW-Upgrade 2.30 of the FC solve your problem. It didn't helped in my case.

Still using workaround at the moment.
Stefan Muegeli
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Sorry typo...

@Gareth Lloyd
Did the FW-Upgrade 2.30 of the VC solve your problem. It didn't helped in my case.
Gareth Lloyd
Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

No, I didn't bother to upgrade to v2.30 in the end as HP changed their mind and said the issue was still under investigation.
NiallS
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Thanks for the suggestions everybody. I haven't, as yet, had time to test firmware version 2.30 as we are currently using the directly connected work around. I hope to do so in the next week or so.
TheDude_1
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Anyone heard an update to this one? We're experiencing it connecting through Cisco nexus 5k switches as well. We were able to get it working by setting the upstream links to native vlans that had appropriate dhcp scopes configured.

Our next step will be to setup packet capture to see where the response is getting dropped (or received??)

The hardware we're testing on are BL460_G6 using a c7000 chassis. All hosts (iLO's, and BIOS') up to date as well as the OA's and flex-10 VC's (2.60/2.30 respectively).

Could be a PXE bug with that adaptor? I'll post back if I find anything interesting on packet capture.

Additionally we'll open a case and reference this thread.
Gareth Lloyd
Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

I raised a call for the same issue a few weeks ago and am still waiting for a fix. A firmware update was promised, not sure when it will come out.

The only workaround available is to move the blade to the same (build) vlan as the PXE server to build the server. After build you can move the server to the correct production vlan.

If you want to rebuild the server, you've got to move it back to the build vlan which is a bit of a pain.

Haven't noticed any issues after moving the server to the production vlan though. It just seems to be PXE boot which is affected.

Looks like a pxe bug in the adaptor.
Lmm_1
Honored Contributor
Gareth Lloyd
Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Great, that takes care of the BL460 G6. Now just the BL495 G5's to go.

How are we supposed to find out about fixes for issues?

I don't like finding out by chance when I have raised support calls and have been told to wait for a fix.
Lmm_1
Honored Contributor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

HP Support should be able to provide you accurate information. You can also receive support alerts (such as Customer Advisories), as well as updates on drivers, software, firmware, etc.

https://h30046.www3.hp.com/subchoice/country/us/en/subscribe.aspx?subs=DRIVERSIGNUP&jumpid=em_sc-gen/us/jul07/all/xbu/signup/mrm/mcc/loc/xbu/go-myadvisory
TheDude_1
Occasional Visitor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

I did want to follow up w/ this and say that the BIOS patch did fix the 460G6's we have. If I had a 495 to test with I would have but since they use a common nic I'd expect it will fix it. The BIOS for the embedded flex10's went from 4.5.x to 5.x.x. Major update seemed to be required.

Anyway -- life is better now. Thanks for the responses.
dospavlos
Frequent Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

Anyone have the link to this fix? URLs in thread don't work.
Gareth Lloyd
Advisor

Re: BL495c G5 unable to PXE boot - PXE-E11: ARP timeout

The latest BIOS update will fix the issue on any 10GB NIC server.

This is the link for the BL460 G6 Drivers and Software Updates:

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?lang=en&cc=uk&prodNameId=3884099&prodTypeId=3709945&prodSeriesId=3884098&swLang=13&taskId=135&swEnvOID=1005#12212

Install one of the BIOS firmware updates under BIOS - System ROM or download and run the SmartUpdate Firmware DVD under Firmware - CD-ROM.