BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

BladeSystem Firmware 1.30 Deployment Tool

 
Andre Alexanian
Occasional Visitor

BladeSystem Firmware 1.30 Deployment Tool

I'm using the Bladesystem firmware deployment tool with great success. I can update my whole enclosure in minutes. The sad thing about this is that the ISO provided is out of date. If try to change. If I try to inject a CP00xxxx.scexe file, Linux will no longer mount the drive. Is there a way of updating the ISO ourselves?
4 REPLIES
Michael Garner_1
Honored Contributor

Re: BladeSystem Firmware 1.30 Deployment Tool

In the short-term, the way to add components to the FDT tool is as follows:

1) Insert/Mount the FDT as you do today.
2) When the server boots, right after you hear the beep for the OS to load, there will be a blinking cursor for about five seconds before the boot environment on the CD starts. At this blinking cursor, type "console". This will drop you to a Linux prompt.
3) Put the components you want to add on a USB key and insert it via the dongle on the server you have at the console prompt.
4) Make a new mountpoint for the CD (eg. mkdir /usbkey)
5. Mount the USB key (normally this will be something like: mount /dev/sdb1 /usbkey
6. Copy the files from your USB key to the RAM drive where where HPSUM will be copied ("cp /usbkey/* /tmp/swpackages/")
7. Run HPSUM silently (must be silent since X support is not on the CD) by typing ./hpsum -s

You can also use an ISO cracker, but it must known how to write a Linux boot kernel based on SLES10 SP2.

Longer-term, I'm looking at several possible solutions to this problem, but you probably won't see them until the February 2009 release of the FDT.

Regards,
Michael Garner
HP PSP/Firmware/FDT Architect
Jimmy Vance
HPE Pro

Re: BladeSystem Firmware 1.30 Deployment Tool

As Micheal stated, you can use an ISO editor, but the few I've tried don't handle the image properly and are not bootable once edited

If you have access to a Linux system, you can use this method

Make a working directory, for this example I'll call it respin

# cd /tmp
# mkdir respin

copy BB130.2008_0822.11.iso into /tmp, or use the full path to BB130.2008_0822.11.iso on the next line

# mount BB130.2008_0822.11.iso /mnt -oloop
# cp -a /mnt/* respin/

now copy the new .scexe files into /tmp/respin/compaq/swpackages

finally run this command to create a new bootable .iso image

# cd /tmp
# mkisofs -J -iso-level 3 -R -L -o BB130_respin.iso -b isolinux/isolinux.bin -c isolinux/boot.cat -V BB130_respin -no-emul-boot -boot-load-size 4 -boot-info-table ./respin

# umount /mnt




__________________________________________________
No support by private messages. Please ask the forum!      I work for HPE

If you feel this was helpful please click the KUDOS! thumb below!   
JKytsi
Honored Contributor

Re: BladeSystem Firmware 1.30 Deployment Tool

Have You tried the HP USB key utility ?

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=3709945&prodSeriesId=3454580&prodNameId=3562397&swEnvOID=1005&swLang=8&mode=2&taskId=135&swItem=MTX-f7adf0b120004742b2b24076bb

With firmware maintance CD it worked just by copying the new versions to USB key.
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
Michael Garner_1
Honored Contributor

Re: BladeSystem Firmware 1.30 Deployment Tool

Just an FYI...the FDT does not work with the USB Key Creator Utility. It has a different boot kernel and doesn't contain several files necessary for the USB KCU to work with it.