BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

 
BeltwayBenny
Advisor

Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

BL460c G6
HP NC532i Dual Port 10GbE NICs
- Driver 4.8.5.0
Using a single adapter or using a HP team

When I set the TCP/IP properties to a static address and click OK the static address is applied. When I go back into the TCP/IP gui it says I'm using DHCP but it's still static via ipconfig.

Anyone have similar issues?

Ben
6 REPLIES
Woosha
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

Same server and driver on Windows 2003 R2 SP2 STD and ENT 32 bit OS without issue using HP Network Configuration utility 9.65.0.9 to Team Nic's. Did not try static ip on individual nic before teaming though.

BL460c G6
HP NC532i Dual Port 10GbE NICs
- Driver 4.8.5.0
srussell
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

Yes I am having the same issue on a BL685c NC532i Quad Port 10GbE NIC
My OS is windows 2003 64bit and I have an open case with HP. They say they have no idea why the NIC would display dhcp when clearly it is set to manual.
For me this issue occurs whether the nic is teamed or not. Did you resolve your issue and if so please, please tell me what the solution is. I have two servers with dual ports that do not have any issues.
srussell
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

Correction I have 2 embedded Dual port NC532i 10GbE nics and all display same behavior you describe above.
BeltwayBenny
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

OK, here is the scoop with our issue.

For many years we have been using the Qlogic QLA4050C iSCSI HBAs, one of the things we install is the Qlogic NULL driver which removes the NDIS adapters on this HBA.

We've got the QMH4062 in the blades and I installed the NULL driver from the Qlogic site on the HP versioned QMH adapter. That is what blew up the TCP/IP properties.. Ouch.

At this time we are only able to disable the NDIS adapters. Qlogic says they won't be releasing a NULL driver for Win2008, that's too bad.

Ben
srussell
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

so did you get the NIC adapter properties to appear correctly ie. manually configured versus showing dhcp
If so, how did you get this working.
BeltwayBenny
Advisor

Re: Broadcom 10Gb TCP/IP properties shows DHCP even when set to static

Sorry, I forgot the most important part!

The server in question had to be rebuilt after several hours of troubleshooting. I didn't bother calling HP support as that would have been a waste of time ('Sir, can you please reboot your server to see if it clears the issue....') .

Ben