BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

C Class not releasing iLO address

 
Nigel Peirce
Occasional Contributor

C Class not releasing iLO address

I have had the mainboard replaced on one of our C class blades by a HP engineer.
I inserted this C class blade into one of our enclosures which picked up an enclosure assigned address for the iLO, I discovered that the new mainboard does not have a serial number registered but my main problem is that when I moved this blade to another enclosure it is still assigned the original iLO IP address.
Other blades have been configured in the same slot and moved to other enclosures without problems (each picking up the correct new iLO IP address). I have tried to reset the iLO using Switch 1 but it made no difference, the OA still reports it being assigned the original IP address rather than the new enclosure assigned one.

Any help would be much appreciated.
5 REPLIES
Blazhev_1
Honored Contributor

Re: C Class not releasing iLO address

Hi,

to take an EBIPA IP Adress, iLO must be configured to obtain DHCP address, rather than using a static one.
Go into ilo and from network settings change the setting or with F8 during POST.

The HP techncian should have entered the serial number in RBSU ->Advanced options-> Serial number, you can check if it is there.

Further if haven't done yot , update ilo2 FW and OA Firwmare

Pac
Nigel Peirce
Occasional Contributor

Re: C Class not releasing iLO address

Thanks for this, the problem I have is that I cannot get into the iLO as the assigned IP address is in use by another enclosure blade so when I browse to this IP I go to a completely different server!

I have tried using the USB dongle at the front to press F8 (ILO Config) but the keyboard seems to only be operational once windows has loaded (presumably after USB drivers have loaded)

Our older P class blades had a dongle that allowed me to connect to the iLO via a NIC cable on a default address of 192.168.1.1, whereas the C class only seems to offer console connectivity.

From what I can see if you cannot get in via the OA or direct via the browser then you are stuck.

Surely there must be a way of remoting into the iLO without going via the live network.
rick jones
Honored Contributor

Re: C Class not releasing iLO address

You might try a different keyboard. I've been successful getting to the iLO using a dongle, keyboard, mouse and screen on BL460c's.
there is no rest for the wicked yet the virtuous have no pillows
James Kennedy_4
Trusted Contributor

Re: C Class not releasing iLO address

If windows loads up, you can go to C:\Program Files\HP\hponcfg, and run the "hponcfg /reset". This will reset the ILO back to factory defaults, clear all IP addresses, usernames, password..etc.

The ILO will come up DHCP again.
Nigel Peirce
Occasional Contributor

Re: C Class not releasing iLO address

Thanks,

Using hponcfg /reset worked a perfectly, many thanks.