HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

C7000 Ethernet pass-thru

 
LuckyLuch
Occasional Visitor

C7000 Ethernet pass-thru

Can someone please explain how the ethernet pass-thru works? We are trying to use interfaces on our cisco 4506 switch using port-channels

We set up a port-channel with 2 interfaces - (see config below) have to issue
shut on gi5/31 to get to 10.20.3.91 (ESX server IP on vlan 103 - blade server)

interface Port-channel9
description Link to NRPI-HQ C-CLASS CHASSIS BL685c Device Bay-1 to 4506-1
switchport
switchport trunk encapsulation dot1q
switchport trunk native vlan 110
switchport trunk allowed vlan 103,104,110
switchport mode trunk

interface GigabitEthernet5/31
description NRPI-HQ C-Class chassis IC Bay 1 Eth port 1
switchport trunk encapsulation dot1q
switchport trunk native vlan 110
switchport trunk allowed vlan 103,104,110
switchport mode trunk
channel-group 9 mode on
!
interface GigabitEthernet5/32
description NRPI-HQ C-Class chassis IC Bay 1 Eth port 9
switchport trunk encapsulation dot1q
switchport trunk native vlan 110
switchport trunk allowed vlan 103,104,110
switchport mode trunk
channel-group 9 mode on

NRPI-HQ-4506-1#sh etherchannel 9 port-channel
Port-channels in the group:
---------------------------

Port-channel: Po9
------------

Age of the Port-channel = 00d:00h:36m:27s
Logical slot/port = 11/9 Number of ports = 2
GC = 0x00000000
Port state = Port-channel Ag-Inuse
Protocol = -

Ports in the Port-channel:

Index Load Port EC state No of bits
------+------+------+------------------+-----------
1 00 Gi5/31 On/FEC 0
0 00 Gi5/32 On/FEC 0

Time since last port bundled: 00d:00h:00m:28s Gi5/31
Time since last port Un-bundled: 00d:00h:01m:50s Gi5/31


NRPI-HQ-4506-1#sh int gi5/31 etherchannel
Port state = Up Mstr In-Bndl
Channel group = 9 Mode = On/FEC Gcchange = -
Port-channel = Po9 GC = - Pseudo port-channel = Po9
Port index = 1 Load = 0x00 Protocol = -

Age of the port in the current state: 00d:00h:02m:21s

NRPI-HQ-4506-1#sh int gi5/32 etherchannel
Port state = Up Mstr In-Bndl
Channel group = 9 Mode = On/FEC Gcchange = -
Port-channel = Po9 GC = - Pseudo port-channel = Po9
Port index = 0 Load = 0x00 Protocol = -

Age of the port in the current state: 00d:00h:10m:10s

Even though the etherchannel is showing both interfaces as part of the channel, only one is really working.

The OA shows that eth ports 1 and 9 on each of the interconnect pass-thru modules belong to the BL685c blade server in device bay 1, but we can't even move the eth cable from port 1 in interconnect bay 1 to port 1 in interconnect bay 2 and retain connectivity to the ESX server in device bay 1 even though the interfaces on the cisco 4506 that the interconnect interfaces are patched to are configured identically.

Any assistance would be greatly appreciated. We've opened several cases with the support desk and all they want to do is ship us new pass-thru modules. Can't find anyone to speak with that understands the technology.
2 REPLIES
The Brit
Honored Contributor

Re: C7000 Ethernet pass-thru

Hi LuckyLuch,

Your luck just ran out. (Joke(?)).

I know nothing about most of what you wrote here, however I can address your comments in the second from last paragraph.

From the quickspecs I see that the bl685c has two (2) embedded 10Gb NICS. (That surprised me since I thought all full height blades had 4 LOM NICs). Anyway, for blades with 2 Embedded NICs, the paths between the blade and the IC module (regardless of the type of module) are hard wired and out of your control.

If your blade has 2 Embedded NICs, then;

Embedded NIC 1 (in Dev Bay x) will map to IC Bay 1, Port x.
Embedded NIC 2 (in Dev Bay x) will map to IC Bay 2, Port x.

If your blade has 4 Embedded NICs (normal for most full height blades);

Embedded NIC 1 (in Dev Bay x) will map to IC Bay 1, Port (x+1).
Embedded NIC 2 (in Dev Bay x) will map to IC Bay 2, Port (x+1).
Embedded NIC 3 (in Dev Bay x) will map to IC Bay 1, Port x.
Embedded NIC 4 (in Dev Bay x) will map to IC Bay 2, Port x.

These mappings are hard, and cannot be changed. This needs to be taken into account when configuring connectivity.

As I mentioned above, I know nothing about your configuration or this particular blade, however if you log into your OA, under "Device Bays" select your server, then click on "Port Mapping" --> "Table View", then it should be clear how the mappings work.

If I am completely off the track here, then I apologise in advance.

HTH

Dave.



William E Howard
Regular Advisor

Re: C7000 Ethernet pass-thru

1) Make sure you hardcode your nic speeds to gigabit. Since these are 10GB ports going thru a 1GB Passthru, link speed doesn't always autodetect properly. Can cause some strange errors.

2) I only see two listed ports as part of the etherchannel. I assume the other nics are part of a separate etherchannel, or are they not even showing up as part of the system?

3) Since Interconnect 2, port 1 is not part of this etherchannel, not quite sure why you are moving the cables to there and expecting anything to work.

4) This is connected to an ESX server. What is your vswitch configuration?