BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Can't get Altiris to receive a DHCP address

Christophe Vico
Occasional Visitor

Can't get Altiris to receive a DHCP address

Hi,

I have a problem with VLAN tagging that i'm struggling to fix.

I've a blade enclosure with VC 1/10Gb extension.

Uplink is an Ethernet network including two port with "Enable VLAN Tunneling" on.
The bundle of 2 ports goes to a Cisco 4500.
Cisco ports are setup as an EtherChannel trunk.
There are ESX host in the enclosure

Here is the problem:
ESX is working fine (vswitch are set to use the VLAN 100 as it's needed)
I've a W2008 server (manually installed) that work fine (after the NIC is set to connect to VLAN 100)

I've a second server that I want to install with Altiris. NIC Bios has been modified to PXE on the VLAN 100.
I get an IP, then Altiris Linux boots... then I get stuck, the Linux part never gets an IP address (makes sense, VLAN 100 is not configured).

So I tried to set the native VLAN to 100 on the Cisco side .. immediate effect, evertyhing behind the trunk (so the whole enclosure) went off the network.

As I can't play around much with Altiris, I need to make sure than untagged traffic is sent to VLAN100..without isolating the whole enclosure.

I'm sure it's possible... but how ??

Below, the config of the Etherchannel - Cisco Side:

interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk

interface GigabitEthernet1/1
description Conn Main-1/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/2
description Conn Main-1/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!


Any help would be welcome,

Thanks,

Christophe