BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot update firmware Virtual Connect - FiberChannel Module

Vincenzo Mattia
Occasional Visitor

Cannot update firmware Virtual Connect - FiberChannel Module

Hi all,

I've a problem when I try to update the firmware of my HP 4Gb VC-FC Module.

the Module is installed into a c7000 Enclosure, there are 6 modules installed into the Interconnect (2 VC-Enet and 4 VC-FC).

I'm using the Virtual Connect Firmware Version 2.01.

2 VC-FC has been updated succesfully to the 1.30 version (they are located in bay 3 and 4), but the others cannot be updated.

I've tried to use the Automated Update and the Normal Update, but nothing happens, it's stuck to "Installing firmware image ...0% complete..."

I didnt find anything useful in the System log of the Virtual Connect, it says only "[Info]User Operation : Deploy Fibre channel Module firmware image " with no errors.

What can I try?

I've already resetted and restarted the modules.

thanks and sorry for my english :D
4 REPLIES
Neal Bowman
Respected Contributor

Re: Cannot update firmware Virtual Connect - FiberChannel Module

Hi Vincenzo.

I've had similar issues recently, going to VC firmware 1.34, which also has the VC-FC firmware image 1.30. The recommended method to update Virtual Connect is via VCSU, Virtual Connect Support Utility. You install this on your desktop and point it to the IP address of the OA. It will prompt you for VC user and password, but this utility has two benefits.

The first is the ability to create and save detailed logs of what is happening in the background. The other benefit is the ability to point the firmware upgrade to a specific interconnect module, rather than at the entire VC domain. This will reduce the amount of time required, usually about 5-10 minutes for the FC module versus 35-45 for all modules.

You can also use the VCSU to generate a healthcheck report of the VC domain, just to ensure that all modules are in a healthy state and are communicating with VC and OA. I would pull each of the modules out of the chassis again, and leave them out for 10.15 minutes before reinsertng them. You may also want to fail over the OA, as this will force the VC to re-establish the communication channel with VC.

Hope this helps
WFHC-WI
Honored Contributor

Re: Cannot update firmware Virtual Connect - FiberChannel Module

Hi Vincenzo,

I agree with the previous poster. Using VCSU to update the firmware was very helpful for me and provided logs for support to review.

I do suggest one step before taking the time to re-seat each module again. Remove both Onboard Administrator modules and re-seat the OA sleeve. While working on a nearly identical issue I found reseating this piece allowed me to establish normal communication to the VC modules.

Good luck!
Vincenzo Mattia
Occasional Visitor

Re: Cannot update firmware Virtual Connect - FiberChannel Module

thanks for the answers.

i've tried to update the FC module via VCSU, but it fails like the other method, the activation of the firmware seems to not working for something.
I've even tried to upload an older FC firmware version (from 1.11 to 1.20).
I've tried to reset the Active OA, and even to failover it to the passive module without success.

I'll try to reset/power off the entire enclosure :D


p.s.: in attachment you can find the VCSU log, seems that 2 commands failed:

command exec command failed for ACTIVATE_FIRMWARE
fc_sendFirmware on bay 3 failed
WFHC-WI
Honored Contributor

Re: Cannot update firmware Virtual Connect - FiberChannel Module

From what I understand, the firmware is downloaded to the OA and then sent to the VCFC module during the upgrade process. The log seems to show that it is the "send_Firmware" process that isn't succeeding. I would have to say again that some communication problem between the OA and that module exists.

Since you have already removed and replaced the VCFC module and the OA module (and tried both OAs as active), I would again suggest pulling out the OA sleeve (the piece that both OAs plug into) and reseating that.

Let's hope it doesn't come to a power-down for the entire enclosure! :)