HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Cant upgrade NIC on BL460c

 
Ross Devine
Occasional Visitor

Cant upgrade NIC on BL460c

Hi Guys.

Having a nightmare with a BL460c NIC.

I tried installing the latest NCU and multifunction gigabit adaptor driver to cure a problem with a BSOD when network teaming.
Drivers installed...
HP NCU 8.80.1.0
Multifunction NIC 4.1.5.0

The NCU installed without issue however the NIC driver failed to install properly leaving my system in a bit of a mess and unable. leaving only two faulting virtual Bus devices.

After much tampering I managed to reinstalled an earlier version of the driver, reran PSP7.9 which put me into the position that I was before I started.

I then tried to manually upgrade to driver version 3.4.10.0 by using Update driver, which appeared to be a success but when checking in device manager - properties - it reports that version 4.1.5.0 is installed... and to confuse things further if you click 'driver detials' button it says that the original version (3.0.5.0) is still in use.

Does anyone have any ideas on how I can upgrade correctly, or get rid of the remnants of the failed install.

This is proving frustrating now as, teaming is reporting that I have the wrong miniport driver,

Any advice would be much appreciated.

Cheers
Ross

3 REPLIES
Mi6t0
Trusted Contributor

Re: Cant upgrade NIC on BL460c

Well, try following:

1. uninstall NCU (it is a component of the tcp/ip stick)
2. go in device manager and manually uninstall both network adapters.
3. reboot the server
4. then windows will report new hardware found, install the 4.1.5.0 drivers (good idea is to download and extract the package before the uninstall process in step 2)
5. after successful installation install the ncu 8.80.1. If it doesn't work try with the 9. version.

I hope you will fix it that way.

Kind regards,
Ross Devine
Occasional Visitor

Re: Cant upgrade NIC on BL460c

Hi Thanks for the information.

I tried what you suggested and it apperared to work however when you delve deaper that the surface it would appear that the NIC is still using the old driver.

I think it's having trouble updating the virtual Bus driver.

When I try uninstalling this it just autmatically tries to install one of it's choosing. If I try and update this driver manually it reports that it's failed to update.

Very frustrating.

Any further help appreciated
Blazhev_1
Honored Contributor

Re: Cant upgrade NIC on BL460c

Hi,

you can check here, there are some things you can try :

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1211184

same problem, don't know if there is a solution yet...

Pac