HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware dependancies for OA 3.31

 
SOLVED
Go to solution
Mike O.
Regular Advisor

Firmware dependancies for OA 3.31

I'm looking to update our C7000 OA from 3.21 to 3.31. Before I do this, I was trying to find out what minimimum firmware versions I need to have on the blades on in Virtual Connect.

On the OA 3.31 download page, under "release notes" all is says for "Firmware Dependancy" is:
For firmware compatibility information, please see HP BladeSystem Firmware Maintenance, http://www.hp.com/go/bladesystemupdates.

Unless I'm missing something, that link doesn't seem to help. The PDF under the "view the full table" seems to be a list of the compatibility for the 9.3 DVD, but not specifically to OA 3.31.

What we have is some 465G5 blades with the latest system BIOS and at ILO2 v2.01. Some 465G7's with ILO3 at 1.25, and Virtual Connect at 3.15.

I was going to update OA to 3.31, then VC to 3.18, then the ILO, but now I'm confused. What order do I need to do for the updates?
7 REPLIES
Johan Guldmyr
Honored Contributor

Re: Firmware dependancies for OA 3.31

Hey, without a VC it's BIOS, iLO and at the end OA.

Unsure which is best with the VC.

Maybe they don't have a minimum firmware until the release set with OA 3.31 is released?
Mike O.
Regular Advisor

Re: Firmware dependancies for OA 3.31

Even in the BIOS/ILO/OA sequence, I'm still trying to find the minimums for OA 3.31. I know the OA update doesn't affect the systems, but management doesn't like anything being done that might affect production. We have a maintenance window coming up, and I'd like to do any updates that affect the entire chassis while I have the outage window. The blades are running VMWare, so I can put them into maintenance mode and do ILO anytime.

From the "compatibility table" PDF, it shows DVD 9.2 with OA 3.30 as compatible with ILO2 2.01, but on the same chart, it shows DVD 9.3 with OA 3.30 and ILO2 at 2.05.
Johan Guldmyr
Honored Contributor
Solution

Re: Firmware dependancies for OA 3.31

In the same you can find OA 3.10,11,21 and 30 in a release set that works with ILO2 1.82, 2.01 and 2.05.

Looks like it's quite backwards compatible?

It's more like with each release set they just drop some of the older firmwares.
Mike O.
Regular Advisor

Re: Firmware dependancies for OA 3.31

That's what's confusing me, though. The chart is showing what the SmartUpdate DVD 9.3 is compatible with. However, if you're applying the DVD, it's updating them all; it doesn't really say for example that OA3.31 and ILO2 2.01 can coexist.

I guess I was hoping for some release notes type document that specifically says "ILO and VC must be at this level".. Similar to what's in the virtual connect release notes.
Johan Guldmyr
Honored Contributor

Re: Firmware dependancies for OA 3.31

Have you looked through the best practices documents? Maybe they can sched some light.
I only looked in one and it was for the 9.0 DVD but it had this:

"Starting with VC firmware 1.34 and later, the VC firmware should be updated after the OA
firmware."
Mike O.
Regular Advisor

Re: Firmware dependancies for OA 3.31

I'd pretty much always done the OA first (unless the blade BIOS/ILO was really out of date). I figure since the OA controls everything else, it needs to be the most current.

I looked at the VC 3.18 release notes, under "recommended firmware" it says "OA minimum 3.11, recommend 3.31 or higher", and "ILO2 1.82 minimum, recommends 2.01 or higher"

The VC release notes for 3.15 (the version we have) say OA 3.11 minimum, so I would think upgrading our OA to 3.31 would be OK.
bob_moodytx
Advisor

Re: Firmware dependancies for OA 3.31

Having done these updates let me pass along a little info.

First mistake was trying to update our VC (Flex10) to current with an OA less than the minimum requirements. Here's what happens.

The first VC will update, but when you attempt to update the second, it fails because it loses authority to the OA. This is becasue the OA was not up to date.

Then when updating the OA's, we have the OA that includes the KVM. It seems that the OA firmware updater does not work on these OA's like it should.

The solution is take down (remove)one OA, update the remaining then reinsert the OA module. It will complain about them being out of sync. Then repeat the process on the other OA.

Once they both are online at 3.31 the VC update will finish, but there is a caveat.

When you tried to update the 2nd VC, the update got loaded but never completed. You must remove or cycle power to the 2nd VC and the update will complete with no further action.

When its all said and done, the OA's will both be at 3.31 and both VC's will be at 3.18 and all the degredation errors will resolve themselves.

In short, update the OA's to 3.31 and the VC update to 3.18 will go a lot smoother. Just remember the OA updater (depending on your OA) will not update with both inserted.

Bob