BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Firmware update failure on Virtual Connect 4Gb FC Module

SOLVED
Go to solution
wedgecon
Occasional Advisor

Firmware update failure on Virtual Connect 4Gb FC Module

I have been trying to update my VC 4GB FC module and it is failing. I am trying to upgrade form version 1.30 to 1.40. I have attached a log of the update process. I was using the VCSU to perform the update.

This is the command I used:

vcutil -a update -i 10.1.50.55 -u User -p pass -l C:\HP\vcfwe1f232.bin -b 4 -vcu User -vcp pass
15 REPLIES
The Brit
Honored Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

I have had this happen to me. Note that the error was "failure to activate", (implying that the firmware load was OK).

I resolved the issue by removing the module and re-inserting it, thus forcing a "cold" reboot. This activated the new firmware image which was "loaded" by vcsu.

From your post it appears that you only have one FC module in bay 4 (??). If this is the case, then you might want to do this during downtime. (if you have two then it depends on your configuration).

Note: when you remove the FC module, it will disappear from the OA, and will be rediscovered when you replace it, although this might take several minutes. Also, although the new FW version (1.4) shows up in my OA firmware page, the VCM does not show the FC firmware level.

Anyway HTH

Dave
wedgecon
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

I do have a second FC module in bay 3 so I am fully redundant.

I was jus trying to only do one at a time by using the -b option. I get the same results in both bays.

I hate the idea of pulling out the bay, is there any other way to reset them?

Adrian Clint
Honored Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Make sure you are not running the firmware update from a machine with an FTP server running. I think that causes problems with the VC-FC updates.
wedgecon
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

No worries there I was able to update the ethernet VC's with no problem on this C7000.

I have another C7000 that was able to update both the ethernet and fc vc's. The differene being is that the fc on this C7000 were not yet connected to the SAN.

Michal N.
Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Hello,

Try to update FW using following command:
vcutil -a update -i 10.1.50.55 -u User -p pass -l C:\HP\vcfwe1f232.bin -b 4 -vcu User -vcp pass -f health

If it failes again can you please execute following command and provide us with output:

vcutil -a healthcheck -i 10.1.50.55 -u User -p pass -vcu User -vcp pass

Regards,
Michal
wedgecon
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

The update failed agian. I have attached the failed and helath check output files.
wedgecon
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Here is the failed output.
The Brit
Honored Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

I am getting the same error.

I got the error when trying to upgrade from 1.30 to 1.40. HP swapped the module and the "new" module is at 1.11. This still gives the same error.

http://forums11.itrc.hp.com/service/forums/questionanswer.do?threadId=1421718

Dave.
Michal N.
Advisor
Solution

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Hello,

Please try the following:
1. Pull VCFC module out of the enclosure wait for at least 5 minutes, then reinsert it.
2. Failover OA module (active to standby) from OA web interface. Wait for 5 minutes.
3. Upgrade the VCFC firmware using VCSU.

If that does not work try to:
1. VCSU -a resetvcm -i -u -p
2. failover OA
3. Upgrade FW using VCSU

Regards,
Michal

The Brit
Honored Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Please see the resolution of the thread I posted above.

This might be your problem.

Good Luck

Dave.
wedgecon
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

The steps in Michal N post were what finally worked.

I just had to pull each module and I was then able to update it. I did not have to switch to the standby administrator.
Mike Alves
Occasional Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Here is what I did to get it to update. Download the vcfwe1f232.bin file from HP do not get any of the vcfwallxxx.bin files. They will not load in the web interface as they are too large. Open the Firmware Management menu in the web VC login. Use this as the local file to update. After it loads choose the Automated Update button. A panel will appear then check the box to force update of same or lower version and then click yes. The VC-FC modules will usually update first. The activation will go all the way through. It works everytime for me.
Torqsis
Occasional Advisor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

I had the issue were I updated my VC Ethernet modules to 3.01 but the FC's that were at 1.32 would not go to 1.4. I would then get errors that the FC's were Incompatible. Tried everything under the sun (and this forum thread) to update. Got HP's support on the phone and did everything that was also listed on this thread. No GO. Went up the chain. They mentioned that the VC Ethernet modules update over 80\443, the Fiber Modules on the other hand update over FTP... After figuring that out, we used the VCSU 1.5 CLI on a system that was on the same network as the chassis. Everything updated.

Keep in mind what ports are needed to update the firmware on your Blade Systems. Not only you need to check your firewalls but also your Host Intrusion and Prevention software policies.
Markus M.
Trusted Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module


Hi everybody,

Had the same problem with my VC FC 8/24 GB module with the upgrade from 1.01 to 1.02.

As the *** new OA 3.1 has no more possibility to reset the interconnects hard via cli nor to upgrade the firmware by web interface(hint to Mike), i also had to pull the ICs out, wait half a minute and re-insert them.

Afterwards I followed torgsis advice to take a machine in the same subnet as the OAs to make sure no firewall like devices are in between.

I took vcsu v1.5 on a win2008 in 2003 compatibility mode and after waiting for nearly 50(!!)minutes we got the success notification.

@HP: OA 3.1 works fine so far, and also VC 3.01 BUT you made about 10 steps back with the update process !!!

hope this helps somebody in the same situation

kr
Markus
JKytsi
Honored Contributor

Re: Firmware update failure on Virtual Connect 4Gb FC Module

Using subnet "closer" to VC helped me too. And man did I do those raindance manouvers with the modules before reading this thread.

I have to say that upgrading FW on VC is _still_ pain in the arse =)
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi