HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Hours:
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
BladeSystem - General
cancel
Showing results for 
Search instead for 
Did you mean: 

Flex-10 and SFP+ Copper

 
Robert.Costa
Occasional Advisor

Flex-10 and SFP+ Copper

I'm hoping this is the right forum for this..

We are trying to connect a Cisco Nexus 5000 switch to one of our VC Flex-10 modules. Of course, I had no input on hardware, I just have to make it work (sound familiar to anyone?).

Here is the basic scenario:
VC Flex-10 module in c7000 chassis
Cisco Nexus 5000 switch
Cables are supplied Cisco SFP+ copper 5m cables.

In the simplest scenario - can I just plug this stuff in and expect it to link up? As both ends are SFP+, they plug in just fine to both the switch as well as the Flex-10 module. So far neither the switch nor the Flex-10 recognize that they are plugged in. No link lights.. Am I missing something (with the obvious answer being YES).

Thanks in advance.
12 REPLIES
rick jones
Honored Contributor

Re: Flex-10 and SFP+ Copper

If these are DAC - Direct Attach Cables, you need to keep in mind that DAC's have IDs on them, checked in much the same way as the IDs on transceivers. In that sense it really isn't "just" a cable. If one side, or the other, does not like the ID from the DAC, it won't use it.

Since it is a Cisco DAC you are trying to use, if you have a second Cisco switch and can run the cable between the two, that would be a good way to make certain the DAC is good. Being more than "just" a cable, I don't know if the old standby of plugging both ends into the same switch would suffice. But, I suppose you can try that too and see if you get link lights.

If you thus see the DAC is "good" then if it is possible to get the Flex-10 module to accept it "today" it would be in the Flex-10 firmware available "today" on www.hp.com - make certain that is installed. If the Flex-10 still does not accept the cable, you might try an HP DAC and see if the Cisco switch will accept that. Or, you might inquire via the channels through with the VC Flex-10 and c7000 chassis were ordered if "support" for the specific Cisco cable (be as complete as you can with the part numbers) is planned for some future Flex-10 release.

My personal opinion is that there are far fewer interoperability hassles with good old fibre or CX4 when available. There a cable is a cable, and a transceiver is a transceiver and one is not caught in this sort of "Shimmer" situation one has with the DAC.
there is no rest for the wicked yet the virtuous have no pillows
JKytsi
Honored Contributor

Re: Flex-10 and SFP+ Copper

Have You created a network in the VC that includes the uplink ?
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
Ole Thomsen_1
Trusted Contributor

Re: Flex-10 and SFP+ Copper

Been there.

Unless HP changed something since then you cannot use the Cisco cables as the Flex-10 checks for the module ID and only accepts HP cables.

We bought HP cables which works fine with the Nexus box. Go figure!

Ole Thomsen
Robert.Costa
Occasional Advisor

Re: Flex-10 and SFP+ Copper

Jarkko:

Yes I have created the necessary network within the VC administrator. I have that sinking feeling that the other two replies are correct and that the stuff just isn't compatible. I will work on the powers that be and see about getting some HP cables (or fiber modules for the Nexus as I already have a few for the Flex-10).

Thanks all for confirming what I was afraid of!
JKytsi
Honored Contributor

Re: Flex-10 and SFP+ Copper

yes, that is true. I have heard also that 3rd. party cables do not work.
Remember to give Kudos to answers! (click the KUDOS star)

You can find me from Twitter @JKytsi
rick jones
Honored Contributor

Re: Flex-10 and SFP+ Copper

Getting up on my soapbox, "cable" being in their name notwithstanding, and perhaps running afoul of marketing desires, it is probably best for folks to not refer to DACs as "cables" - it implies a simplicity just not supported by reality.
there is no rest for the wicked yet the virtuous have no pillows
Robert.Costa
Occasional Advisor

Re: Flex-10 and SFP+ Copper

It seems that the SFP+ copper are indeed proprietary enough at this point that the Cisco cables will not work with the Flex-10 (at least as of the 2.12 fw). We have tested and will move forward with installing fibre SFP+ transceivers in the Nexus switch.

Thanks to all for the help!
Ole Thomsen_1
Trusted Contributor

Re: Flex-10 and SFP+ Copper

To my best knowledge it is not a question of proprietary - it's a vendor lockin. And could be easily solved by HP by allowing other vendor IDs which is only a label in the cable firmware (excuse my french).

At some point Cisco had the same policy for transceivers and stuff, but that changed. Maybe they listened to their customers.

Ole Thomsen
Robert.Costa
Occasional Advisor

Re: Flex-10 and SFP+ Copper

Well put, Ole.
rick jones
Honored Contributor

Re: Flex-10 and SFP+ Copper

By and large, HPers are not in a position to discuss futures here, which is why we often suggest folks talk with their sales channels.
there is no rest for the wicked yet the virtuous have no pillows
Randall Craig
Occasional Visitor

Re: Flex-10 and SFP+ Copper

Ole,

Could you let me know what were the SKU's for the cables that you used to connect the Flex-10 to the Nexus?

Thanks!
Ole Thomsen_1
Trusted Contributor

Re: Flex-10 and SFP+ Copper

487655-b21 (3m - 10ft)

Ole Thomsen